summaryrefslogtreecommitdiffstats
path: root/main/postfix
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-06 08:27:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-06 08:27:34 +0000
commitb8c4e48734b66d27fc350320bd7ddd9d08786076 (patch)
tree854ce42a7828a8f08de4489f1272ad01fd5a4cc8 /main/postfix
parent9f32b4e3488bc65666b06455ef5db3d52363f20d (diff)
downloadaports-b8c4e48734b66d27fc350320bd7ddd9d08786076.tar.bz2
aports-b8c4e48734b66d27fc350320bd7ddd9d08786076.tar.xz
main/postfix: upgrade to 2.7.1
Diffstat (limited to 'main/postfix')
-rw-r--r--main/postfix/APKBUILD8
-rw-r--r--main/postfix/postfix-2.7.1-dynamic-maps.patch (renamed from main/postfix/postfix-2.7.0-dynamic-maps.patch)10
2 files changed, 9 insertions, 9 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index a2213c269..1bd86bb1e 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
-pkgver=2.7.0
+pkgver=2.7.1
pkgrel=0
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
@@ -12,7 +12,7 @@ subpackages="$pkgname-doc $pkgname-ldap $pkgname-mysql $pkgname-pcre
$pkgname-pgsql"
source="ftp://ftp.porcupine.org/mirrors/$pkgname-release/official/$pkgname-$pkgver.tar.gz
$pkgname.initd
- postfix-2.7.0-dynamic-maps.patch
+ postfix-2.7.1-dynamic-maps.patch
dynamicmaps.cf
postfix-ldap.post-install
postfix-mysql.post-install
@@ -145,9 +145,9 @@ mysql() { _mv_dict mysql ;}
pcre() { _mv_dict pcre ; }
pgsql() { _mv_dict pgsql ; }
-md5sums="df648f59421604e895cce56325f00bae postfix-2.7.0.tar.gz
+md5sums="b7a5c3ccd309156a65d6f8d2683d4fa1 postfix-2.7.1.tar.gz
6bbabcd041aefaf40e1f3ee1fc1d6d7e postfix.initd
-4d9c373e8a35bfb5bfa9b899e64fb70a postfix-2.7.0-dynamic-maps.patch
+8f3ca3a512357d03fdb7abd9d39f4596 postfix-2.7.1-dynamic-maps.patch
442efd1a95b0c061dfb8ab75456e0f24 dynamicmaps.cf
2ebe51a882eb9d6d7866583eb6af3969 postfix-ldap.post-install
2ebe51a882eb9d6d7866583eb6af3969 postfix-mysql.post-install
diff --git a/main/postfix/postfix-2.7.0-dynamic-maps.patch b/main/postfix/postfix-2.7.1-dynamic-maps.patch
index da1c799be..bfc19a152 100644
--- a/main/postfix/postfix-2.7.0-dynamic-maps.patch
+++ b/main/postfix/postfix-2.7.1-dynamic-maps.patch
@@ -1,8 +1,8 @@
-commit 98599e6387147a26d8433e85a4a61ef5c4240e83
+commit a6b79e8091c5e75d5d0a6b45b6652f0378583686
Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon May 31 14:49:38 2010 +0000
+Date: Tue Jul 6 08:16:25 2010 +0000
- added dynamic maps
+ patch for dynamic maps
diff --git a/conf/postfix-files b/conf/postfix-files
index 7ff93ea..7cae109 100644
@@ -577,7 +577,7 @@ index 9829d28..d7dc53c 100644
#define dict_get(dp, key) ((const char *) (dp)->lookup((dp), (key)))
#define dict_put(dp, key, val) (dp)->update((dp), (key), (val))
diff --git a/src/util/dict_db.c b/src/util/dict_db.c
-index e4b301d..8dc9c9d 100644
+index 9e82f9b..93264e6 100644
--- a/src/util/dict_db.c
+++ b/src/util/dict_db.c
@@ -675,6 +675,12 @@ static DICT *dict_db_open(const char *class, const char *path, int open_flags,
@@ -590,7 +590,7 @@ index e4b301d..8dc9c9d 100644
+ if ((errno = db->upgrade(db,db_path,0)) != 0)
+ msg_fatal("upgrade of database %s: %m",db_path);
+ }
- #if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0)
+ #if DB_VERSION_MAJOR == 5 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0)
if ((errno = db->open(db, 0, db_path, 0, type, db_flags, 0644)) != 0)
msg_fatal("open database %s: %m", db_path);
diff --git a/src/util/dict_dbm.c b/src/util/dict_dbm.c