summaryrefslogtreecommitdiffstats
path: root/main/privoxy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-21 07:26:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-21 07:27:51 +0000
commit6f03407f091e9899853dc9d3487391e85559eb97 (patch)
treea54037b69ef75110e46f96ee2c9958713d15c69c /main/privoxy
parent8cb0af0c69a5285a40f616d8d6f66d7aea089625 (diff)
downloadaports-6f03407f091e9899853dc9d3487391e85559eb97.tar.bz2
aports-6f03407f091e9899853dc9d3487391e85559eb97.tar.xz
main/privoxy: upgrade to 3.0.18
Diffstat (limited to 'main/privoxy')
-rw-r--r--main/privoxy/APKBUILD16
-rw-r--r--main/privoxy/privoxy-alpine.patch (renamed from main/privoxy/privoxy-3.0.16-gentoo.patch)44
2 files changed, 34 insertions, 26 deletions
diff --git a/main/privoxy/APKBUILD b/main/privoxy/APKBUILD
index c6a92ebe2..61cff17d1 100644
--- a/main/privoxy/APKBUILD
+++ b/main/privoxy/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=privoxy
-pkgver=3.0.17
-pkgrel=1
+pkgver=3.0.18
+pkgrel=0
pkgdesc="A web proxy with advanced filtering capabilities"
url="http://www.privoxy.org"
arch="all"
@@ -15,13 +15,17 @@ subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/ijbswa/$pkgname-$pkgver-stable-src.tar.gz
$pkgname.initd
$pkgname.logrotate
- privoxy-3.0.16-gentoo.patch
+ privoxy-alpine.patch
"
_builddir="$srcdir"/$pkgname-$pkgver-stable
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/privoxy-3.0.16-gentoo.patch || return 1
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
aclocal && autoheader && autoconf
}
@@ -51,7 +55,7 @@ package() {
"$pkgdir"/etc/privoxy
}
-md5sums="9d363d738a3f3d73e774d6dfeafdb15f privoxy-3.0.17-stable-src.tar.gz
+md5sums="baf0b13bb591ec6e1ba15b720ddea65c privoxy-3.0.18-stable-src.tar.gz
170d5679e4c3504f07ef1a4c9859e9b8 privoxy.initd
f2b6a652dbfbc65e5b89024a8ea3da7e privoxy.logrotate
-48cce19ecdcf8f17a021ac3aa8f837bc privoxy-3.0.16-gentoo.patch"
+cb233d3e5b13027557a405f467ee307c privoxy-alpine.patch"
diff --git a/main/privoxy/privoxy-3.0.16-gentoo.patch b/main/privoxy/privoxy-alpine.patch
index d445ec1b0..c04030613 100644
--- a/main/privoxy/privoxy-3.0.16-gentoo.patch
+++ b/main/privoxy/privoxy-alpine.patch
@@ -1,19 +1,19 @@
---- privoxy/GNUmakefile.in
-+++ privoxy/GNUmakefile.in
-@@ -61,10 +61,10 @@
- MAN_DIR = @mandir@
+diff --git a/GNUmakefile.in b/GNUmakefile.in
+index 2593901..c3a681a 100644
+--- a/GNUmakefile.in
++++ b/GNUmakefile.in
+@@ -62,8 +62,8 @@ MAN_DIR = @mandir@
MAN_DEST = $(MAN_DIR)/man1
+ MAN_PAGE = privoxy.1
SHARE_DEST = @datadir@
-DOC_DEST = $(SHARE_DEST)/doc/privoxy
-+DOC_DEST = @docdir@
-VAR_DEST = @localstatedir@
++DOC_DEST = @docdir@
+VAR_DEST = /var
LOGS_DEST = $(VAR_DEST)/log/privoxy
PIDS_DEST = $(VAR_DEST)/run
- # if $prefix = /usr/local then the default CONFDEST change from
- # CONF_DEST = $(CONF_BASE) to CONF_DEST = $(CONF_BASE)/privoxy
-@@ -901,34 +901,8 @@
+@@ -922,34 +922,8 @@ install: CONF_DEST LOG_DEST PID_DEST check_doc GROUP_T
fi ;\
$(ECHO) Installing configuration files to $(DESTDIR)$(CONF_DEST);\
for i in $(CONFIGS); do \
@@ -48,9 +48,11 @@
if [ "$(prefix)" = "/usr/local" ] || [ "$(prefix)" = "/usr" ]; then \
if [ -f /etc/slackware-version ] && [ -d /etc/rc.d/ ] && [ -w /etc/rc.d/ ] ; then \
$(SED) 's+%PROGRAM%+$(PROGRAM)+' slackware/rc.privoxy.orig | \
---- privoxy/config
-+++ privoxy/config
-@@ -267,7 +267,7 @@
+diff --git a/config b/config
+index 8b20f92..25596d6 100644
+--- a/config
++++ b/config
+@@ -265,7 +265,7 @@
#
# No trailing "/", please.
#
@@ -59,7 +61,7 @@
#
#
# 2.2. templdir
-@@ -324,7 +324,7 @@
+@@ -322,7 +322,7 @@ confdir .
#
# No trailing "/", please.
#
@@ -68,7 +70,7 @@
#
#
# 2.4. actionsfile
-@@ -464,7 +464,7 @@
+@@ -462,7 +462,7 @@ filterfile user.filter # User customizations
# Any log files must be writable by whatever user Privoxy is
# being run as (on Unix, default user id is "privoxy").
#
@@ -77,18 +79,20 @@
#
#
# 2.7. trustfile
---- privoxy/default.action.master
-+++ privoxy/default.action.master
-@@ -564,7 +564,7 @@
- { \
- +change-x-forwarded-for{block} \
+diff --git a/default.action.master b/default.action.master
+index a26a0ec..5c67e8e 100644
+--- a/default.action.master
++++ b/default.action.master
+@@ -566,7 +566,7 @@ allow-ads = -block -filter{banners-by-size} -filter{banners-by-link}
+ +client-header-tagger{css-requests} \
+ +client-header-tagger{image-requests} \
+hide-from-header{block} \
-+set-image-blocker{pattern} \
++set-image-blocker{blank} \
}
standard.Cautious
-@@ -584,7 +584,7 @@
+@@ -588,7 +588,7 @@ standard.Cautious
+hide-from-header{block} \
+hide-referrer{conditional-block} \
+session-cookies-only \
@@ -97,7 +101,7 @@
}
standard.Medium
-@@ -623,7 +623,7 @@
+@@ -627,7 +627,7 @@ standard.Medium
+hide-referrer{conditional-block} \
+limit-connect{,} \
+overwrite-last-modified{randomize} \