summaryrefslogtreecommitdiffstats
path: root/main/rrdcollect
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-23 09:56:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-23 09:56:01 +0000
commit092e87b4b568d7bef2d094ac4926e579f779f671 (patch)
tree9b02ca2fd9cf2c4512bfe116d42b14f30f4a4db9 /main/rrdcollect
parent3cc0c95853fcb021a12c63581c971c65718cc685 (diff)
downloadaports-092e87b4b568d7bef2d094ac4926e579f779f671.tar.bz2
aports-092e87b4b568d7bef2d094ac4926e579f779f671.tar.xz
main/rrdcollect: moved from testing
Diffstat (limited to 'main/rrdcollect')
-rw-r--r--main/rrdcollect/APKBUILD53
-rw-r--r--main/rrdcollect/rrdcollect.conf.patch46
-rwxr-xr-xmain/rrdcollect/rrdcollect.initd6
3 files changed, 105 insertions, 0 deletions
diff --git a/main/rrdcollect/APKBUILD b/main/rrdcollect/APKBUILD
new file mode 100644
index 000000000..56e6499aa
--- /dev/null
+++ b/main/rrdcollect/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=rrdcollect
+pkgver=0.2.9
+pkgrel=2
+pkgdesc="Read system statistical data and feed it to RRDtool"
+url="http://rrdcollect.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="rrdtool"
+makedepends="libpcap-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ rrdcollect.conf.patch
+ rrdcollect.initd"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac;
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc/rrdcollect \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/rrdcollect.initd \
+ "$pkgdir"/etc/init.d/rrdcollect || return 1
+ install -m755 -d "$pkgdir"/var/lib/rrdtool || return 1
+}
+
+md5sums="1e94eb0f8d55ebf0f042c10baebc2d3d rrdcollect-0.2.9.tar.gz
+e09d7a588e31c9ecfc44fd1747ad732b rrdcollect.conf.patch
+d5a892939ee11351f6bbbf9218694f8b rrdcollect.initd"
diff --git a/main/rrdcollect/rrdcollect.conf.patch b/main/rrdcollect/rrdcollect.conf.patch
new file mode 100644
index 000000000..9b1d7b355
--- /dev/null
+++ b/main/rrdcollect/rrdcollect.conf.patch
@@ -0,0 +1,46 @@
+--- rrdcollect-0.2.9.org/doc/sample-rrdcollect.conf
++++ rrdcollect-0.2.9/doc/sample-rrdcollect.conf
+@@ -4,12 +4,12 @@
+ # Configuration values:
+
+ #step = 60
+-#directory = /var/lib/rrdtool
++directory = /var/lib/rrdtool
+ #loglevel = LOG_NOTICE
+
+ # System statistics:
+ file:///proc/stat
+-"cpu %d %d %d %d" stat.rrd:cpu_user,cpu_nice,cpu_system,cpu_idle
++"cpu %d %d %d %d %d %d %d" stat.rrd:cpu_user,cpu_nice,cpu_system,cpu_idle,cpu_iowait,cpu_irq,cpu_softirq
+ "ctxt %u" stat.rrd:ctxt
+ "page %u %u" stat.rrd:page_in,page_out
+ "processes %u" stat.rrd:processes
+@@ -21,15 +21,15 @@
+ "Swap: %*d %d %*d" memory.rrd:swap_used
+
+ # S.M.A.R.T. HDD temperature:
+-file:///proc/ide/hda/smart_values
+-7:"%*04x %*04x %02x%*02x" temperature.rrd:hda
+-file:///proc/ide/hdb/smart_values
+-7:"%*04x %*04x %02x%*02x" temperature.rrd:hdb
++#file:///proc/ide/hda/smart_values
++#7:"%*04x %*04x %02x%*02x" temperature.rrd:hda
++#file:///proc/ide/hdb/smart_values
++#7:"%*04x %*04x %02x%*02x" temperature.rrd:hdb
+
+ # Net: statistics
+ file:///proc/net/dev
+ " eth0: %d %d %*d %*d %*d %*d %*d %*d %d %d" eth0.rrd:bytes_in,pkts_in,bytes_out,pkts_out
+-" eth1: %d %d %*d %*d %*d %*d %*d %*d %d %d" eth1.rrd:bytes_in,pkts_in,bytes_out,pkts_out
++#" eth1: %d %d %*d %*d %*d %*d %*d %*d %d %d" eth1.rrd:bytes_in,pkts_in,bytes_out,pkts_out
+
+ # NEW!
+ # exec:/// -- instead of reading from /proc/ file data is read from
+@@ -40,5 +40,5 @@
+ #
+ # To use it, you must compile with --enable-exec
+ # Remember, programs run with root permissions. Use at your own risk.
+-exec:///bin/df
+-"/dev/hda1 %*d %d %d" hda1.rrd:used,empty
++#exec:///bin/df
++#"/dev/sda1 %*d %d %d" sda1.rrd:used,empty
diff --git a/main/rrdcollect/rrdcollect.initd b/main/rrdcollect/rrdcollect.initd
new file mode 100755
index 000000000..883e574e1
--- /dev/null
+++ b/main/rrdcollect/rrdcollect.initd
@@ -0,0 +1,6 @@
+#!/sbin/runscript
+
+description="rrdcollect daemon"
+pidfile="/var/run/${RC_SVCNAME}.pid"
+command="/usr/sbin/rrdcollect"
+