summaryrefslogtreecommitdiffstats
path: root/main/shorewall-shell
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-05 11:36:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-05 11:43:06 +0000
commit232a4772c27d2825ab7dacc32b63e92477573d23 (patch)
treee039f359375630f6a841918515874e7740e1a744 /main/shorewall-shell
parentb3310fd776c0ad24a34816c4c81867fdc1079df1 (diff)
downloadaports-232a4772c27d2825ab7dacc32b63e92477573d23.tar.bz2
aports-232a4772c27d2825ab7dacc32b63e92477573d23.tar.xz
main/shorewall-shell: upgrade to 4.2.11, add patch for ipset
Diffstat (limited to 'main/shorewall-shell')
-rw-r--r--main/shorewall-shell/APKBUILD24
-rw-r--r--main/shorewall-shell/shorewall-shell-ipset.patch12
2 files changed, 26 insertions, 10 deletions
diff --git a/main/shorewall-shell/APKBUILD b/main/shorewall-shell/APKBUILD
index 2806e0571..095982424 100644
--- a/main/shorewall-shell/APKBUILD
+++ b/main/shorewall-shell/APKBUILD
@@ -1,23 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-shell
-_v=4.2.10
-pkgver=4.2.10
-pkgrel=2
+_v=4.2.11
+pkgver=4.2.11
+pkgrel=0
pkgdesc="Shoreline Firewall shell-based compiler."
url="http://www.shorewall.net/"
-arch="all"
+arch="noarch"
license="GPL-2"
depends="shorewall-common"
#subpackages="$pkgname-doc"
source="http://www.shorewall.net/pub/shorewall/${_v%.*}/shorewall-$_v/$pkgname-$pkgver.tar.bz2
shorewall-policyrouting.patch
+ shorewall-shell-ipset.patch
"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in ../*.patch; do
- msg "Applying $i..."
- patch -p1 -i $i || return 1
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
}
@@ -26,5 +29,6 @@ build() {
PREFIX="$pkgdir" ./install.sh || return 1
}
-md5sums="d6f7cbc3c502c09921ede920547d5017 shorewall-shell-4.2.10.tar.bz2
-64c01bc4f57203fb877bb334994eac38 shorewall-policyrouting.patch"
+md5sums="518a7f389a6f606c109acb7dfbe18372 shorewall-shell-4.2.11.tar.bz2
+64c01bc4f57203fb877bb334994eac38 shorewall-policyrouting.patch
+79745ea284a08cb167b9a356ee0bff3b shorewall-shell-ipset.patch"
diff --git a/main/shorewall-shell/shorewall-shell-ipset.patch b/main/shorewall-shell/shorewall-shell-ipset.patch
new file mode 100644
index 000000000..247eb83d3
--- /dev/null
+++ b/main/shorewall-shell/shorewall-shell-ipset.patch
@@ -0,0 +1,12 @@
+--- ./compiler
++++ ./compiler
+@@ -5627,8 +5627,6 @@
+
+ if [ -f \$f ]; then
+ progress_message2 "Restoring IPSETS..."
+- ipset -U :all: :all:
+- ipset -U :all: :default:
+ ipset -F
+ ipset -X
+ ipset -R < \$f
+