summaryrefslogtreecommitdiffstats
path: root/main/shorewall-shell
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-11 08:34:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-11 08:34:39 +0000
commitc2ad54cf99aadbc72adbdbafd03f615c4d0aaa30 (patch)
treeb641e4953eeccc51edff7e46153187d5200af966 /main/shorewall-shell
parent28f6432c83a8f746d8b08a51d4b3b2773b889b0d (diff)
downloadaports-c2ad54cf99aadbc72adbdbafd03f615c4d0aaa30.tar.bz2
aports-c2ad54cf99aadbc72adbdbafd03f615c4d0aaa30.tar.xz
main/shorewall-shell: fix redirect excludes
Fixes this error: Setting up Rules... Bad argument `10.12.96.1' Try `iptables -h' or 'iptables --help' for more information. ERROR: Command "/sbin/iptables -t nat -A D_96_dnat -p tcp -d ! 10.12.96.1 --dport 80 -j REDIRECT --to-port 8080" Failed on rule: REDIRECT:info D_96 8080 tcp 80 - !10.12.96.1
Diffstat (limited to 'main/shorewall-shell')
-rw-r--r--main/shorewall-shell/APKBUILD6
-rw-r--r--main/shorewall-shell/redirect-excludes.patch15
2 files changed, 19 insertions, 2 deletions
diff --git a/main/shorewall-shell/APKBUILD b/main/shorewall-shell/APKBUILD
index 53849231d..8e087b1f4 100644
--- a/main/shorewall-shell/APKBUILD
+++ b/main/shorewall-shell/APKBUILD
@@ -2,7 +2,7 @@
pkgname=shorewall-shell
_v=4.2.11
pkgver=4.2.11
-pkgrel=5
+pkgrel=6
pkgdesc="Shoreline Firewall shell-based compiler."
url="http://www.shorewall.net/"
arch="noarch"
@@ -15,6 +15,7 @@ source="http://www.shorewall.net/pub/shorewall/${_v%.*}/shorewall-$_v/$pkgname-$
shorewall-shell-providers-gateway-none.patch
shorewall-shell-rp_filter.patch
restore-default-route.patch
+ redirect-excludes.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -37,4 +38,5 @@ md5sums="518a7f389a6f606c109acb7dfbe18372 shorewall-shell-4.2.11.tar.bz2
79745ea284a08cb167b9a356ee0bff3b shorewall-shell-ipset.patch
0c6106a8cbb95d21c0c878a6235a65ac shorewall-shell-providers-gateway-none.patch
d5eadb6be45aa41f80669452baa853a6 shorewall-shell-rp_filter.patch
-c971270086d5de15327f498d1be64fcb restore-default-route.patch"
+c971270086d5de15327f498d1be64fcb restore-default-route.patch
+90e54cbb55213a2b3dcb6f57d20d1490 redirect-excludes.patch"
diff --git a/main/shorewall-shell/redirect-excludes.patch b/main/shorewall-shell/redirect-excludes.patch
new file mode 100644
index 000000000..9230576bd
--- /dev/null
+++ b/main/shorewall-shell/redirect-excludes.patch
@@ -0,0 +1,15 @@
+--- ./lib.nat.orig
++++ ./lib.nat
+@@ -683,10 +683,10 @@
+ fi
+ ;;
+ !*)
+- if [ $(list_count $addr) -gt 1 ]; then
++# if [ $(list_count $addr) -gt 1 ]; then
+ excludedests="${addr#\!}"
+ addr=
+- fi
++# fi
+ ;;
+ esac
+