summaryrefslogtreecommitdiffstats
path: root/main/slim
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-02 07:58:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-02 07:58:36 +0000
commit09df774e06a0772ef2982281e0e2175cf5887c0b (patch)
treee3ce1580ae885044ef9f4f75c817f726bb423948 /main/slim
parent366efa9be93b118428bd8a2ab5c6d82463a65077 (diff)
downloadaports-09df774e06a0772ef2982281e0e2175cf5887c0b.tar.bz2
aports-09df774e06a0772ef2982281e0e2175cf5887c0b.tar.xz
main/slim: upgrade to 1.3.5
Diffstat (limited to 'main/slim')
-rw-r--r--main/slim/APKBUILD31
-rw-r--r--main/slim/pthread.patch29
-rw-r--r--main/slim/slim-1.3.1-gcc4.4.patch17
-rw-r--r--main/slim/slim-png15.patch11
-rw-r--r--main/slim/slim-restart.patch141
5 files changed, 35 insertions, 194 deletions
diff --git a/main/slim/APKBUILD b/main/slim/APKBUILD
index bce7f473e..d4f62395c 100644
--- a/main/slim/APKBUILD
+++ b/main/slim/APKBUILD
@@ -1,22 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=slim
-pkgver=1.3.2
-pkgrel=3
+pkgver=1.3.5
+pkgrel=0
pkgdesc="Desktop-independent graphical login manager for X11"
url="http://slim.berlios.de/"
arch="all"
license="GPL-2"
subpackages="$pkgname-doc"
-makedepends="libxmu-dev libpng-dev jpeg-dev libxft-dev"
+makedepends="libxmu-dev libpng-dev libjpeg-turbo-dev libxft-dev
+ cmake linux-pam-dev"
depends=
install=
source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.gz
http://dev.alpinelinux.org/~ncopa/alpine/slim-alpinelinux.tar.gz
+ pthread.patch
$pkgname.logrotate
$pkgname.initd
- slim-restart.patch
- slim-png15.patch
- pthread.patch
"
prepare() {
@@ -27,9 +26,6 @@ prepare() {
esac
done
- #libpng 1.4.0
- sed -i -e 's/png12/png15/g' Makefile || return 1
-
sed -i -e 's|#xserver_arguments.*|xserver_arguments -nolisten tcp vt07|'\
-e 's|/var/run/slim.lock|/var/lock/slim.lock|' \
-e 's|halt_cmd.*|halt_cmd /sbin/poweroff|'\
@@ -44,6 +40,15 @@ prepare() {
build() {
cd "$srcdir/slim-$pkgver"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_PAM=no \
+ -DUSE_CONSOLEKIT=no \
+ || return 1
+
+
make CXX="${CXX:-g++}" CC="${CC:-gcc}" || return 1
}
@@ -62,10 +67,8 @@ package() {
rm -rf "$pkgdir"/usr/share/slim/themes/default
}
-md5sums="ca1ae6120e6f4b4969f2d6cf94f47b42 slim-1.3.2.tar.gz
+md5sums="1153e6993f9c9333e4cf745411d03472 slim-1.3.5.tar.gz
cd63232c7770b0e67a009a94c2a46b82 slim-alpinelinux.tar.gz
+a2fc2874a3bb2470a96dfa2a34833d05 pthread.patch
43da096480bf72c3ccec8ad8400f34f0 slim.logrotate
-6ee3a023e56052528295034be809cfc6 slim.initd
-648d871fe7d2a97b7d7b928019e2feee slim-restart.patch
-8f63afd7cd390cb8d65f10fb167d4a71 slim-png15.patch
-49cb6cae0b8aa6980b88f90dad2524cf pthread.patch"
+6ee3a023e56052528295034be809cfc6 slim.initd"
diff --git a/main/slim/pthread.patch b/main/slim/pthread.patch
index 9a1379ad1..1fb4852c5 100644
--- a/main/slim/pthread.patch
+++ b/main/slim/pthread.patch
@@ -1,11 +1,18 @@
---- ./Makefile.orig
-+++ ./Makefile
-@@ -7,7 +7,7 @@
- CC=/usr/bin/gcc
- CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include
- CXXFLAGS=$(CFLAGS)
--LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg -lrt
-+LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg -lrt -lpthread
- CUSTOM=-DHAVE_SHADOW
- ifdef USE_PAM
- LDFLAGS+= -lpam
+--- ./CMakeLists.txt.orig 2013-01-02 07:56:30.920523149 +0000
++++ ./CMakeLists.txt 2013-01-02 07:57:27.844341140 +0000
+@@ -134,6 +134,7 @@
+ find_library(M_LIB m)
+ find_library(RT_LIB rt)
+ find_library(CRYPTO_LIB crypt)
++find_library(PTHREAD_LIB pthread)
+
+ add_definitions(${SLIM_DEFINITIONS})
+
+@@ -154,6 +155,7 @@
+ ${M_LIB}
+ ${RT_LIB}
+ ${CRYPTO_LIB}
++ ${PTHREAD_LIB}
+ ${X11_X11_LIB}
+ ${X11_Xft_LIB}
+ ${X11_Xrender_LIB}
diff --git a/main/slim/slim-1.3.1-gcc4.4.patch b/main/slim/slim-1.3.1-gcc4.4.patch
deleted file mode 100644
index 5708d7071..000000000
--- a/main/slim/slim-1.3.1-gcc4.4.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Patch to allow compilation with gcc-4.4
-
-Notified by Daniel J. - from Debian bug tracker
-
-http://bugs.gentoo.org/252745
-
---- a/switchuser.h 2008-11-11 19:40:18.000000000 +0000
-+++ b/switchuser.h 2008-11-11 19:40:28.000000000 +0000
-@@ -18,6 +18,7 @@
- #include <pwd.h>
- #include <grp.h>
- #include <paths.h>
-+#include <cstdio>
- #include <iostream>
- #include "const.h"
- #include "cfg.h"
-
diff --git a/main/slim/slim-png15.patch b/main/slim/slim-png15.patch
deleted file mode 100644
index 25caaed57..000000000
--- a/main/slim/slim-png15.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- slim-1.3.2.orig/png.c
-+++ slim-1.3.2/png.c
-@@ -57,7 +57,7 @@
- return(0);
- }
-
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
- fclose(infile);
diff --git a/main/slim/slim-restart.patch b/main/slim/slim-restart.patch
deleted file mode 100644
index 1f9c02dff..000000000
--- a/main/slim/slim-restart.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-diff -ur slim-1.3.1.orig/app.cpp slim-1.3.1/app.cpp
---- slim-1.3.1.orig/app.cpp 2008-09-26 02:54:15.000000000 +0200
-+++ slim-1.3.1/app.cpp 2008-11-21 20:38:48.000000000 +0100
-@@ -102,6 +102,11 @@
-
- extern App* LoginApp;
-
-+int xioerror(Display *disp) {
-+ LoginApp->RestartServer();
-+ return 0;
-+}
-+
- void CatchSignal(int sig) {
- cerr << APPNAME << ": unexpected signal " << sig << endl;
- LoginApp->StopServer();
-@@ -109,19 +114,6 @@
- exit(ERR_EXIT);
- }
-
--
--void AlarmSignal(int sig) {
-- int pid = LoginApp->GetServerPID();
-- if(waitpid(pid, NULL, WNOHANG) == pid) {
-- LoginApp->StopServer();
-- LoginApp->RemoveLock();
-- exit(OK_EXIT);
-- }
-- signal(sig, AlarmSignal);
-- alarm(2);
--}
--
--
- void User1Signal(int sig) {
- signal(sig, User1Signal);
- }
-@@ -267,7 +259,6 @@
- signal(SIGHUP, CatchSignal);
- signal(SIGPIPE, CatchSignal);
- signal(SIGUSR1, User1Signal);
-- signal(SIGALRM, AlarmSignal);
-
- #ifndef XNEST_DEBUG
- OpenLog();
-@@ -287,7 +278,6 @@
-
- CreateServerAuth();
- StartServer();
-- alarm(2);
- #endif
-
- }
-@@ -603,6 +593,8 @@
- int status;
- while (wpid != pid) {
- wpid = wait(&status);
-+ if (wpid == ServerPID)
-+ xioerror(Dpy); // Server died, simulate IO error
- }
- if (WIFEXITED(status) && WEXITSTATUS(status)) {
- LoginPanel->Message("Failed to execute login command");
-@@ -648,9 +640,6 @@
-
-
- void App::Reboot() {
-- // Stop alarm clock
-- alarm(0);
--
- #ifdef USE_PAM
- try{
- pam.end();
-@@ -673,9 +662,6 @@
-
-
- void App::Halt() {
-- // Stop alarm clock
-- alarm(0);
--
- #ifdef USE_PAM
- try{
- pam.end();
-@@ -761,6 +747,7 @@
-
- StopServer();
- RemoveLock();
-+ while (waitpid(-1, NULL, WNOHANG) > 0); // Collects all dead childrens
- Run();
- }
-
-@@ -831,6 +818,7 @@
-
- for(cycles = 0; cycles < ncycles; cycles++) {
- if((Dpy = XOpenDisplay(DisplayName))) {
-+ XSetIOErrorHandler(xioerror);
- return 1;
- } else {
- if(!ServerTimeout(1, (char *) "X server to begin accepting connections"))
-@@ -913,9 +901,6 @@
- ServerPID = -1;
- break;
- }
-- alarm(15);
-- pause();
-- alarm(0);
-
- // Wait for server to start up
- if(WaitForServer() == 0) {
-@@ -948,15 +933,12 @@
-
-
- void App::StopServer() {
-- // Stop alars clock and ignore signals
-- alarm(0);
- signal(SIGQUIT, SIG_IGN);
- signal(SIGINT, SIG_IGN);
- signal(SIGHUP, SIG_IGN);
- signal(SIGPIPE, SIG_IGN);
- signal(SIGTERM, SIG_DFL);
- signal(SIGKILL, SIG_DFL);
-- signal(SIGALRM, SIG_DFL);
-
- // Catch X error
- XSetIOErrorHandler(IgnoreXIO);
-diff -ur slim-1.3.1.orig/app.h slim-1.3.1/app.h
---- slim-1.3.1.orig/app.h 2008-09-26 02:54:15.000000000 +0200
-+++ slim-1.3.1/app.h 2008-11-21 20:38:48.000000000 +0100
-@@ -34,6 +34,7 @@
- ~App();
- void Run();
- int GetServerPID();
-+ void RestartServer();
- void StopServer();
-
- // Lock functions
-@@ -48,7 +49,6 @@
- void Console();
- void Exit();
- void KillAllClients(Bool top);
-- void RestartServer();
- void ReadConfig();
- void OpenLog();
- void CloseLog();