summaryrefslogtreecommitdiffstats
path: root/main/smartmontools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-19 12:41:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-19 12:50:25 +0000
commit3f5d211dedde1ab48e57ee0e3c77c79e0799da81 (patch)
tree4610632e7f17508086d6c31974880d55f32220d7 /main/smartmontools
parent37d3f3a203a2baf6969057808d7e2f5d8666a925 (diff)
downloadaports-3f5d211dedde1ab48e57ee0e3c77c79e0799da81.tar.bz2
aports-3f5d211dedde1ab48e57ee0e3c77c79e0799da81.tar.xz
main/smartmontools: sync init.d script with gentoo
now with proper checksums ref #943
Diffstat (limited to 'main/smartmontools')
-rw-r--r--main/smartmontools/APKBUILD4
-rw-r--r--main/smartmontools/smartd.initd8
2 files changed, 6 insertions, 6 deletions
diff --git a/main/smartmontools/APKBUILD b/main/smartmontools/APKBUILD
index e5401a84c..e6f5da5e2 100644
--- a/main/smartmontools/APKBUILD
+++ b/main/smartmontools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=smartmontools
pkgver=5.42
-pkgrel=0
+pkgrel=1
pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
url="http://smartmontools.sourceforge.net"
arch="all"
@@ -28,5 +28,5 @@ package() {
install -Dm644 ../smartd.confd "$pkgdir"/etc/conf.d/smartd
}
md5sums="4460bf9a79a1252ff5c00ba52cf76b2a smartmontools-5.42.tar.gz
-64e6fc908146b885aa3f88796edf72f3 smartd.initd
+b33edf355a83149119d768f0d75787c8 smartd.initd
371cdb7cc9dc924b6d12224d66b193c6 smartd.confd"
diff --git a/main/smartmontools/smartd.initd b/main/smartmontools/smartd.initd
index 560e17d64..131a7d45f 100644
--- a/main/smartmontools/smartd.initd
+++ b/main/smartmontools/smartd.initd
@@ -1,14 +1,14 @@
#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.8 2009/10/11 00:43:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.9 2011/09/15 07:58:50 polynomial-c Exp $
depend() {
need localmount
after bootmisc
}
-opts="${opts} reload"
+extra_started_commands="reload"
checkconfig() {
if [ ! -f "/etc/smartd.conf" ] ; then
@@ -38,6 +38,6 @@ stop() {
reload() {
ebegin "Reloading configuration"
- start-stop-daemon --oknodo --stop --signal HUP --pidfile /var/run/smartd.pid smartd
+ start-stop-daemon --signal HUP --pidfile /var/run/smartd.pid smartd
eend $?
}