summaryrefslogtreecommitdiffstats
path: root/main/smartmontools
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:12:22 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:12:22 +0000
commit877687e793a2758c4e6dbcbcc392ef7ab55e863a (patch)
treec73286bf9441bdc0a4911f8be36e5449e3b9f67b /main/smartmontools
parent326e3880df8dfe920efabf57994121acb8c6fd1d (diff)
downloadaports-877687e793a2758c4e6dbcbcc392ef7ab55e863a.tar.bz2
aports-877687e793a2758c4e6dbcbcc392ef7ab55e863a.tar.xz
main/smartmontools: move to main
Diffstat (limited to 'main/smartmontools')
-rw-r--r--main/smartmontools/APKBUILD32
-rw-r--r--main/smartmontools/smartd.confd4
-rw-r--r--main/smartmontools/smartd.initd43
3 files changed, 79 insertions, 0 deletions
diff --git a/main/smartmontools/APKBUILD b/main/smartmontools/APKBUILD
new file mode 100644
index 000000000..42b13e1e4
--- /dev/null
+++ b/main/smartmontools/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=smartmontools
+pkgver=5.40
+pkgrel=0
+pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
+url="http://smartmontools.sourceforge.net"
+arch="all"
+license="GPL"
+depends=
+makedepends=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ smartd.initd
+ smartd.confd
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir"/ install
+ rm -r "$pkgdir"/etc/rc.d
+ install -Dm755 ../smartd.initd "$pkgdir"/etc/init.d/smartd
+ install -Dm644 ../smartd.confd "$pkgdir"/etc/conf.d/smartd
+}
+md5sums="0f0be0239914ad87830a4fff594bda5b smartmontools-5.40.tar.gz
+64e6fc908146b885aa3f88796edf72f3 smartd.initd
+371cdb7cc9dc924b6d12224d66b193c6 smartd.confd"
diff --git a/main/smartmontools/smartd.confd b/main/smartmontools/smartd.confd
new file mode 100644
index 000000000..4b7db4dfd
--- /dev/null
+++ b/main/smartmontools/smartd.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/smartd: config file for /etc/init.d/smartd
+
+# Insert any other options needed
+SMARTD_OPTS=""
diff --git a/main/smartmontools/smartd.initd b/main/smartmontools/smartd.initd
new file mode 100644
index 000000000..560e17d64
--- /dev/null
+++ b/main/smartmontools/smartd.initd
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.8 2009/10/11 00:43:58 vapier Exp $
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+opts="${opts} reload"
+
+checkconfig() {
+ if [ ! -f "/etc/smartd.conf" ] ; then
+ eerror "You should setup your /etc/smartd.conf file!"
+ eerror "See the smartd.conf(5) manpage."
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting S.M.A.R.T. monitoring daemon"
+ start-stop-daemon --start --exec /usr/sbin/smartd \
+ --pidfile /var/run/smartd.pid \
+ -- -p /var/run/smartd.pid ${SMARTD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping S.M.A.R.T. monitoring daemon"
+ start-stop-daemon --stop --exec /usr/sbin/smartd \
+ --pidfile /var/run/smartd.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading configuration"
+ start-stop-daemon --oknodo --stop --signal HUP --pidfile /var/run/smartd.pid smartd
+ eend $?
+}