summaryrefslogtreecommitdiffstats
path: root/main/squid
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-10 06:28:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-10 06:28:13 +0000
commit955b06f90f949fea22c332c4554b6d6d1a07c449 (patch)
tree03cf75fe8e158809cd49205abad1b8dafc72c132 /main/squid
parent1dfae260fcf5ddbf7efe8bb2723b6cc6f005f8bc (diff)
downloadaports-955b06f90f949fea22c332c4554b6d6d1a07c449.tar.bz2
aports-955b06f90f949fea22c332c4554b6d6d1a07c449.tar.xz
main/squid: move version 3.2 from testing
Diffstat (limited to 'main/squid')
-rw-r--r--main/squid/APKBUILD307
-rw-r--r--main/squid/squid-2-heimdal.patch18
-rw-r--r--main/squid/squid-2.7-gentoo.patch298
-rw-r--r--main/squid/squid-2.7-ims-content-type.patch11
-rw-r--r--main/squid/squid-2.7-loggable-urlgroup.patch33
-rw-r--r--main/squid/squid-3.2.0.12-loggable-urlgroup.patch111
-rw-r--r--[l---------]main/squid/squid.pre-upgrade7
7 files changed, 172 insertions, 613 deletions
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index 27858362e..8f2dc8cd1 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=squid
-pkgver=2.7.9
-_ver=2.7.STABLE9
-pkgrel=4
+pkgver=3.2.0.12
+pkgrel=1
pkgdesc="A full-featured Web proxy cache server."
url="http://www.squid-cache.org"
install="squid.pre-install squid.pre-upgrade squid.post-install"
@@ -11,89 +10,76 @@ pkgusers="squid"
pkggroups="squid"
arch="all"
license="GPL-2"
-depends="$pkgname-errors-english logrotate"
-makedepends="openssl-dev perl-dev autoconf automake heimdal-dev"
-subpackages="$pkgname-doc
- squid_kerb_auth
- $pkgname-errors-armenian:errors_armenian
- $pkgname-errors-azerbaijani:errors_azerbaijani
- $pkgname-errors-bulgarian:errors_bulgarian
- $pkgname-errors-catalan:errors_catalan
- $pkgname-errors-czech:errors_czech
- $pkgname-errors-danish:errors_danish
- $pkgname-errors-dutch:errors_dutch
- $pkgname-errors-english:errors_english
- $pkgname-errors-estonian:errors_estonian
- $pkgname-errors-finnish:errors_finnish
- $pkgname-errors-french:errors_french
- $pkgname-errors-german:errors_german
- $pkgname-errors-greek:errors_greek
- $pkgname-errors-hebrew:errors_hebrew
- $pkgname-errors-hungarian:errors_hungarian
- $pkgname-errors-italian:errors_italian
- $pkgname-errors-japanese:errors_japanese
- $pkgname-errors-korean:errors_korean
- $pkgname-errors-lithuanian:errors_lithuanian
- $pkgname-errors-polish:errors_polish
- $pkgname-errors-portuguese:errors_portuguese
- $pkgname-errors-romanian:errors_romanian
- $pkgname-errors-russian-1251:errors_russian_1251
- $pkgname-errors-russian-koi8-r:errors_russian_koi8_r
- $pkgname-errors-serbian:errors_serbian
- $pkgname-errors-simplify_chinese:errors_simplify_chinese
- $pkgname-errors-slovak:errors_slovak
- $pkgname-errors-spanish:errors_spanish
- $pkgname-errors-swedish:errors_swedish
- $pkgname-errors-traditional_chinese:errors_traditional_chinese
- $pkgname-errors-turkish:errors_turkish
- $pkgname-errors-ukrainian-1251:errors_ukrainian_1251
- $pkgname-errors-ukrainian-koi8-u:errors_ukrainian_koi8_u
- $pkgname-errors-ukrainian-utf8:errors_ukrainian_utf8"
-
-source="http://www.squid-cache.org/Versions/v2/2.7/${pkgname}-${_ver}.tar.bz2
+depends="logrotate"
+makedepends="openssl-dev perl-dev autoconf automake heimdal-dev libtool
+ libcap-dev"
+subpackages="$pkgname-doc"
+linguas="af ar az bg ca cs da de el es et fa fi fr he hu hy id it ja ko lt
+ lv ms nl oc pl pt ro ru sk sl sr sv th tr uk uz vi zh"
+langdir="/usr/share/squid/errors"
+
+source="http://www.squid-cache.org/Versions/v3/3.2/squid-$pkgver.tar.bz2
+ squid-3.2.0.12-loggable-urlgroup.patch
squid.initd
squid.confd
- squid-2.7-gentoo.patch
- squid-2-heimdal.patch
- squid-2.7-ims-content-type.patch
- squid-2.7-loggable-urlgroup.patch
$pkgname.logrotate
"
+
pkgusers="squid"
pkggroups="squid"
-build() {
- cd "$srcdir/$pkgname-$_ver"
-
- for i in "$srcdir"/*.patch; do
- msg "Applying $i..."
- patch -p1 -i $i || return 1
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
+# ./bootstrap.sh
+}
- touch NEWS AUTHORS
- aclocal && autoconf && automake -a || return 1
+build() {
+ cd "$_builddir"
- ./configure --prefix=/usr --datadir=/usr/share/squid \
- --sysconfdir=/etc/squid --libexecdir=/usr/lib/squid \
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/squid \
+ --sysconfdir=/etc/squid \
+ --libexecdir=/usr/lib/squid \
--localstatedir=/var \
- --enable-auth="basic,digest,ntlm,negotiate" \
+ --disable-strict-error-checking \
--enable-removal-policies="lru,heap" \
--enable-digest-auth-helpers="password" \
- --enable-storeio="aufs,ufs,diskd,coss,null" \
--enable-basic-auth-helpers="getpwnam,NCSA,SMB,MSNT,multi-domain-NTLM,squid_radius_auth" \
--enable-epoll \
--enable-external-acl-helpers="ip_user,unix_group,wbinfo_group" \
- --enable-ntlm-auth-helpers="SMB,fakeauth,no_check" \
+ --enable-ntlm-auth-helpers="fakeauth,no_check,smb_lm" \
--enable-negotiate-auth-helpers="squid_kerb_auth" \
- --enable-delay-pools --enable-arp-acl --enable-ssl \
- --enable-linux-netfilter --enable-ident-lookups \
- --enable-useragent-log --enable-cache-digests --enable-referer-log \
- --enable-async-io --enable-truncate --enable-arp-acl \
- --enable-htcp --enable-carp --enable-poll --with-maxfd=4096 \
+ --disable-mit \
+ --enable-heimdal \
+ --enable-delay-pools \
+ --enable-arp-acl \
+ --enable-ssl \
+ --enable-linux-netfilter \
+ --enable-ident-lookups \
+ --enable-useragent-log \
+ --enable-cache-digests \
+ --enable-referer-log \
+ --enable-async-io \
+ --enable-truncate \
+ --enable-arp-acl \
+ --enable-htcp \
+ --enable-carp \
+ --enable-poll --with-maxfd=4096 \
--enable-follow-x-forwarded-for \
- --with-large-files
+ --with-large-files \
+ || return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -114,191 +100,8 @@ squid_kerb_auth() {
mv "$pkgdir"/usr/lib/squid/squid_kerb_auth "$subpkgdir"/usr/lib/squid/
}
-_mv_error() {
- local d=usr/share/squid/errors
- mkdir -p "$subpkgdir/$d"
- mv "$pkgdir/$d/${1}" "$subpkgdir/$d/" || return 1
- # last one removed the dir
- rmdir "$pkgdir/$d" 2>/dev/null
- return 0
-}
-
-errors_armenian() {
- depends="$pkgname"
- _mv_error Armenian
-}
-
-errors_azerbaijani() {
- depends="$pkgname"
- _mv_error Azerbaijani
-}
-
-errors_bulgarian() {
- depends="$pkgname"
- _mv_error Bulgarian
-}
-
-errors_catalan() {
- depends="$pkgname"
- _mv_error Catalan
-}
-
-errors_czech() {
- depends="$pkgname"
- _mv_error Czech
-}
-
-errors_danish() {
- depends="$pkgname"
- _mv_error Danish
-}
-
-errors_dutch() {
- depends="$pkgname"
- _mv_error Dutch
-}
-
-errors_english() {
- depends=
- _mv_error English
-}
-
-errors_estonian() {
- depends="$pkgname"
- _mv_error Estonian
-}
-
-errors_finnish() {
- depends="$pkgname"
- _mv_error Finnish
-}
-
-errors_french() {
- depends="$pkgname"
- _mv_error French
-}
-
-errors_german() {
- depends="$pkgname"
- _mv_error German
-}
-
-errors_greek() {
- depends="$pkgname"
- _mv_error Greek
-}
-
-errors_hebrew() {
- depends="$pkgname"
- _mv_error Hebrew
-}
-
-errors_hungarian() {
- depends="$pkgname"
- _mv_error Hungarian
-}
-
-errors_italian() {
- depends="$pkgname"
- _mv_error Italian
-}
-
-errors_japanese() {
- depends="$pkgname"
- _mv_error Japanese
-}
-
-errors_korean() {
- depends="$pkgname"
- _mv_error Korean
-}
-
-errors_lithuanian() {
- depends="$pkgname"
- _mv_error Lithuanian
-}
-
-errors_polish() {
- depends="$pkgname"
- _mv_error Polish
-}
-
-errors_portuguese() {
- depends="$pkgname"
- _mv_error Portuguese
-}
-
-errors_romanian() {
- depends="$pkgname"
- _mv_error Romanian
-}
-
-errors_russian_1251() {
- depends="$pkgname"
- _mv_error Russian-1251
-}
-
-errors_russian_koi8_r() {
- depends="$pkgname"
- _mv_error Russian-koi8-r
-}
-
-errors_serbian() {
- depends="$pkgname"
- _mv_error Serbian
-}
-
-errors_simplify_chinese() {
- depends="$pkgname"
- _mv_error Simplify_Chinese
-}
-
-errors_slovak() {
- depends="$pkgname"
- _mv_error Slovak
-}
-
-errors_spanish() {
- depends="$pkgname"
- _mv_error Spanish
-}
-
-errors_swedish() {
- depends="$pkgname"
- _mv_error Swedish
-}
-
-errors_traditional_chinese() {
- depends="$pkgname"
- _mv_error Traditional_Chinese
-}
-
-errors_turkish() {
- depends="$pkgname"
- _mv_error Turkish
-}
-
-errors_ukrainian_1251() {
- depends="$pkgname"
- _mv_error Ukrainian-1251
-}
-
-errors_ukrainian_koi8_u() {
- depends="$pkgname"
- _mv_error Ukrainian-koi8-u
-}
-
-errors_ukrainian_utf8() {
- depends="$pkgname"
- _mv_error Ukrainian-utf8
-}
-
-
-md5sums="3c6642c85470b1079207d43bba25a819 squid-2.7.STABLE9.tar.bz2
+md5sums="f11b71b7c58a2a20e87707d4ba441743 squid-3.2.0.12.tar.bz2
+084f7b1af1ac0cb8fea35c7a0905a80e squid-3.2.0.12-loggable-urlgroup.patch
57fed05adc40acab6a5480ec7a014154 squid.initd
44b052db7910f386ef88ddcf69c9ba4e squid.confd
-3827f71d940b47eb385a1a1d92a51d66 squid-2.7-gentoo.patch
-614b97126ad9eecf728095f2de63d33d squid-2-heimdal.patch
-549377b5a6b673bf19ea6c34003d122c squid-2.7-ims-content-type.patch
-d4efa24094b011e77bc7bf45291c0ee9 squid-2.7-loggable-urlgroup.patch
58823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
diff --git a/main/squid/squid-2-heimdal.patch b/main/squid/squid-2-heimdal.patch
deleted file mode 100644
index 67500ae6a..000000000
--- a/main/squid/squid-2-heimdal.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Nru squid-2.7.STABLE6.orig/helpers/negotiate_auth/squid_kerb_auth/Makefile.am squid-2.7.STABLE6/helpers/negotiate_auth/squid_kerb_auth/Makefile.am
---- squid-2.7.STABLE6.orig/helpers/negotiate_auth/squid_kerb_auth/Makefile.am 2007-05-14 23:36:29.000000000 +0000
-+++ squid-2.7.STABLE6/helpers/negotiate_auth/squid_kerb_auth/Makefile.am 2009-02-16 23:26:28.000000000 +0000
-@@ -18,10 +18,10 @@
- #-L$(top_builddir)/lib -lmiscutil $(XTRA_LIBS)
-
- # HEIMDAL
--#KERBINC = -DHEIMDAL -I/usr/include/heimdal
--#KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
-+KERBINC = -DHEIMDAL -I/usr/include/heimdal
-+KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
-
- # MIT
--KERBINC =
--KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
-+#KERBINC =
-+#KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
-
diff --git a/main/squid/squid-2.7-gentoo.patch b/main/squid/squid-2.7-gentoo.patch
deleted file mode 100644
index f9480a990..000000000
--- a/main/squid/squid-2.7-gentoo.patch
+++ /dev/null
@@ -1,298 +0,0 @@
-Gentoo squid patch for 2.7.4
-
-http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-proxy/squid/files/squid-2.7.4-gentoo.patch?view=markup
-
---- squid-2.7.STABLE6/configure.in Wed Feb 4 00:44:06 2009
-+++ squid-2.7.STABLE6-patched/configure.in Mon Feb 16 11:56:34 2009
-@@ -18,9 +18,9 @@
- PRESET_LDFLAGS="$LDFLAGS"
-
- dnl Set default LDFLAGS
--if test -z "$LDFLAGS"; then
-- LDFLAGS="-g"
--fi
-+dnl if test -z "$LDFLAGS"; then
-+dnl LDFLAGS="-g"
-+dnl fi
-
- dnl Check for GNU cc
- AC_PROG_CC
---- squid-2.7.STABLE6/helpers/basic_auth/MSNT/confload.c Wed Jun 26 19:09:48 2002
-+++ squid-2.7.STABLE6-patched/helpers/basic_auth/MSNT/confload.c Mon Feb 16 11:56:34 2009
-@@ -24,7 +24,7 @@
-
- /* Path to configuration file */
- #ifndef SYSCONFDIR
--#define SYSCONFDIR "/usr/local/squid/etc"
-+#define SYSCONFDIR "/etc/squid"
- #endif
- #define CONFIGFILE SYSCONFDIR "/msntauth.conf"
-
---- squid-2.7.STABLE6/helpers/basic_auth/MSNT/msntauth.conf.default Wed Jun 26 18:44:28 2002
-+++ squid-2.7.STABLE6-patched/helpers/basic_auth/MSNT/msntauth.conf.default Mon Feb 16 11:56:34 2009
-@@ -8,6 +8,6 @@
- server other_PDC other_BDC otherdomain
-
- # Denied and allowed users. Comment these if not needed.
--#denyusers /usr/local/squid/etc/msntauth.denyusers
--#allowusers /usr/local/squid/etc/msntauth.allowusers
-+#denyusers /etc/squid/msntauth.denyusers
-+#allowusers /etc/squid/msntauth.allowusers
-
---- squid-2.7.STABLE6/helpers/basic_auth/SMB/Makefile.am Tue May 17 16:56:26 2005
-+++ squid-2.7.STABLE6-patched/helpers/basic_auth/SMB/Makefile.am Mon Feb 16 11:56:34 2009
-@@ -14,7 +14,7 @@
- ## FIXME: autoconf should test for the samba path.
-
- SMB_AUTH_HELPER = smb_auth.sh
--SAMBAPREFIX=/usr/local/samba
-+SAMBAPREFIX=/usr
- SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
-
- libexec_SCRIPTS = $(SMB_AUTH_HELPER)
---- squid-2.7.STABLE6/helpers/basic_auth/SMB/smb_auth.sh Sun Jan 7 23:36:46 2001
-+++ squid-2.7.STABLE6-patched/helpers/basic_auth/SMB/smb_auth.sh Mon Feb 16 11:56:34 2009
-@@ -24,7 +24,7 @@
- read AUTHSHARE
- read AUTHFILE
- read SMBUSER
--read SMBPASS
-+read -r SMBPASS
-
- # Find domain controller
- echo "Domain name: $DOMAINNAME"
-@@ -47,7 +47,7 @@
- addropt=""
- fi
- echo "Query address options: $addropt"
--dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+ / { print $1 ; exit }'`
-+dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+\..+ / { print $1 ; exit }'`
- echo "Domain controller IP address: $dcip"
- [ -n "$dcip" ] || exit 1
-
---- squid-2.7.STABLE6/helpers/external_acl/session/squid_session.8 Sat Jan 6 17:28:35 2007
-+++ squid-2.7.STABLE6-patched/helpers/external_acl/session/squid_session.8 Mon Feb 16 11:56:34 2009
-@@ -35,7 +35,7 @@
- .P
- Configuration example using the default automatic mode
- .IP
--external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/local/squid/libexec/squid_session
-+external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/libexec/squid/squid_session
- .IP
- acl session external session
- .IP
---- squid-2.7.STABLE6/helpers/external_acl/unix_group/squid_unix_group.8 Sun May 14 15:07:24 2006
-+++ squid-2.7.STABLE6-patched/helpers/external_acl/unix_group/squid_unix_group.8 Mon Feb 16 11:56:34 2009
-@@ -27,7 +27,7 @@
- This squid.conf example defines two Squid acls. usergroup1 matches users in group1, and usergroup2
- matches users in group2 or group3
- .IP
--external_acl_type unix_group %LOGIN /usr/local/squid/libexec/squid_unix_group -p
-+external_acl_type unix_group %LOGIN /usr/libexec/squid/squid_unix_group -p
- .IP
- acl usergroup1 external unix_group group1
- .IP
---- squid-2.7.STABLE6/src/Makefile.am Wed Jan 2 15:50:39 2008
-+++ squid-2.7.STABLE6-patched/src/Makefile.am Mon Feb 16 11:56:34 2009
-@@ -340,13 +340,13 @@
- DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
- DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
- DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
--DEFAULT_LOG_PREFIX = $(localstatedir)/logs
-+DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
- DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
- DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
- DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
--DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
-+DEFAULT_PID_FILE = $(localstatedir)/run/squid/squid.pid
- DEFAULT_NETDB_FILE = $(DEFAULT_LOG_PREFIX)/netdb.state
--DEFAULT_SWAP_DIR = $(localstatedir)/cache
-+DEFAULT_SWAP_DIR = $(localstatedir)/cache/squid
- DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
- DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
- DEFAULT_DISKD = $(libexecdir)/`echo diskd-daemon | sed '$(transform);s/$$/$(EXEEXT)/'`
---- squid-2.7.STABLE6/src/access_log.c Tue Mar 18 02:48:43 2008
-+++ squid-2.7.STABLE6-patched/src/access_log.c Mon Feb 16 11:56:34 2009
-@@ -1261,7 +1261,7 @@
- LogfileStatus = LOG_ENABLE;
- }
- #if HEADERS_LOG
-- headerslog = logfileOpen("/usr/local/squid/logs/headers.log", MAX_URL << 1, 0);
-+ headerslog = logfileOpen("/var/log/squid/headers.log", MAX_URL << 1, 0);
- assert(NULL != headerslog);
- #endif
- #if FORW_VIA_DB
---- squid-2.7.STABLE6/src/cf.data.pre Mon Feb 2 11:28:55 2009
-+++ squid-2.7.STABLE6-patched/src/cf.data.pre Mon Feb 16 11:56:34 2009
-@@ -678,6 +678,8 @@
- acl Safe_ports port 488 # gss-http
- acl Safe_ports port 591 # filemaker
- acl Safe_ports port 777 # multiling http
-+acl Safe_ports port 901 # SWAT
-+acl purge method PURGE
- acl CONNECT method CONNECT
- NOCOMMENT_END
- DOC_END
-@@ -711,6 +713,9 @@
- # Only allow cachemgr access from localhost
- http_access allow manager localhost
- http_access deny manager
-+# Only allow purge requests from localhost
-+http_access allow purge localhost
-+http_access deny purge
- # Deny requests to unknown ports
- http_access deny !Safe_ports
- # Deny CONNECT to other than SSL ports
-@@ -728,6 +733,9 @@
- # from where browsing should be allowed
- http_access allow localnet
-
-+# Allow the localhost to have access by default
-+http_access allow localhost
-+
- # And finally deny all other access to this proxy
- http_access deny all
- NOCOMMENT_END
-@@ -3754,11 +3762,11 @@
-
- NAME: cache_mgr
- TYPE: string
--DEFAULT: webmaster
-+DEFAULT: root
- LOC: Config.adminEmail
- DOC_START
- Email-address of local cache manager who will receive
-- mail if the cache dies. The default is "webmaster".
-+ mail if the cache dies. The default is "root".
- DOC_END
-
- NAME: mail_from
-@@ -3787,12 +3795,12 @@
-
- NAME: cache_effective_user
- TYPE: string
--DEFAULT: nobody
-+DEFAULT: squid
- LOC: Config.effectiveUser
- DOC_START
- If you start Squid as root, it will change its effective/real
- UID/GID to the user specified below. The default is to change
-- to UID to nobody. If you define cache_effective_user, but not
-+ to UID to squid. If you define cache_effective_user, but not
- cache_effective_group, Squid sets the GID to the effective
- user's default group ID (taken from the password file) and
- supplementary group list from the from groups membership of
-@@ -4429,12 +4437,12 @@
- NAME: snmp_port
- TYPE: ushort
- LOC: Config.Port.snmp
--DEFAULT: 3401
-+DEFAULT: 0
- IFDEF: SQUID_SNMP
- DOC_START
- Squid can now serve statistics and status information via SNMP.
-- By default it listens to port 3401 on the machine. If you don't
-- wish to use SNMP, set this to "0".
-+ By default snmp_port is disabled. If you wish to use SNMP,
-+ set this to "3401" (or any other number you like).
- DOC_END
-
- NAME: snmp_access
-@@ -4505,12 +4513,12 @@
- NAME: htcp_port
- IFDEF: USE_HTCP
- TYPE: ushort
--DEFAULT: 4827
-+DEFAULT: 0
- LOC: Config.Port.htcp
- DOC_START
- The port number where Squid sends and receives HTCP queries to
-- and from neighbor caches. Default is 4827. To disable use
-- "0".
-+ and from neighbor caches. To turn it on you want to set it to
-+ 4827. By default it is set to "0" (disabled).
- DOC_END
-
- NAME: log_icp_queries
-@@ -5407,6 +5415,9 @@
- If you disable this, it will appear as
-
- X-Forwarded-For: unknown
-+NOCOMMENT_START
-+forwarded_for off
-+NOCOMMENT_END
- DOC_END
-
- NAME: cachemgr_passwd
---- squid-2.7.STABLE6/src/client_side.c Mon Oct 6 21:27:44 2008
-+++ squid-2.7.STABLE6-patched/src/client_side.c Mon Feb 16 11:56:34 2009
-@@ -4706,14 +4706,7 @@
- debug(83, 2) ("clientNegotiateSSL: Session %p reused on FD %d (%s:%d)\n", SSL_get_session(ssl), fd, fd_table[fd].ipaddr, (int) fd_table[fd].remote_port);
- } else {
- if (do_debug(83, 4)) {
-- /* Write out the SSL session details.. actually the call below, but
-- * OpenSSL headers do strange typecasts confusing GCC.. */
-- /* PEM_write_SSL_SESSION(debug_log, SSL_get_session(ssl)); */
--#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x00908000L
-- PEM_ASN1_write((i2d_of_void *) i2d_SSL_SESSION, PEM_STRING_SSL_SESSION, debug_log, (char *) SSL_get_session(ssl), NULL, NULL, 0, NULL, NULL);
--#else
- PEM_ASN1_write(i2d_SSL_SESSION, PEM_STRING_SSL_SESSION, debug_log, (char *) SSL_get_session(ssl), NULL, NULL, 0, NULL, NULL);
--#endif
- /* Note: This does not automatically fflush the log file.. */
- }
- debug(83, 2) ("clientNegotiateSSL: New session %p on FD %d (%s:%d)\n", SSL_get_session(ssl), fd, fd_table[fd].ipaddr, (int) fd_table[fd].remote_port);
---- squid-2.7.STABLE6/src/defines.h Mon Sep 24 13:31:19 2007
-+++ squid-2.7.STABLE6-patched/src/defines.h Mon Feb 16 11:56:34 2009
-@@ -259,7 +259,7 @@
-
- /* were to look for errors if config path fails */
- #ifndef DEFAULT_SQUID_ERROR_DIR
--#define DEFAULT_SQUID_ERROR_DIR "/usr/local/squid/etc/errors"
-+#define DEFAULT_SQUID_ERROR_DIR "/usr/share/squid/errors/English"
- #endif
-
- /* gb_type operations */
---- squid-2.7.STABLE6/src/main.c Thu Sep 25 02:21:52 2008
-+++ squid-2.7.STABLE6-patched/src/main.c Mon Feb 16 11:56:34 2009
-@@ -376,6 +376,22 @@
- asnFreeMemory();
- }
-
-+#if USE_UNLINKD
-+static int
-+needUnlinkd(void)
-+{
-+ int i;
-+ int r = 0;
-+ for (i = 0; i < Config.cacheSwap.n_configured; i++) {
-+ if (strcmp(Config.cacheSwap.swapDirs[i].type, "ufs") == 0 ||
-+ strcmp(Config.cacheSwap.swapDirs[i].type, "aufs") == 0 ||
-+ strcmp(Config.cacheSwap.swapDirs[i].type, "diskd") == 0)
-+ r++;
-+ }
-+ return r;
-+}
-+#endif
-+
- static void
- mainReconfigure(void)
- {
-@@ -614,7 +630,7 @@
-
- if (!configured_once) {
- #if USE_UNLINKD
-- unlinkdInit();
-+ if (needUnlinkd()) unlinkdInit();
- #endif
- urlInitialize();
- cachemgrInit();
-@@ -636,6 +652,9 @@
- #endif
- #if USE_WCCPv2
- wccp2Init();
-+#endif
-+#if USE_UNLINKD
-+ if (needUnlinkd()) unlinkdInit();
- #endif
- serverConnectionsOpen();
- neighbors_init();
diff --git a/main/squid/squid-2.7-ims-content-type.patch b/main/squid/squid-2.7-ims-content-type.patch
deleted file mode 100644
index 8b66197e7..000000000
--- a/main/squid/squid-2.7-ims-content-type.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/HttpReply.c.orig Wed Oct 7 07:08:08 2009
-+++ b/src/HttpReply.c Wed Oct 7 07:08:20 2009
-@@ -43,7 +43,7 @@
- static http_hdr_type Denied304HeadersArr[] =
- {
- HDR_CONTENT_ENCODING, HDR_CONTENT_LANGUAGE, HDR_CONTENT_LENGTH,
-- HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE
-+ HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE, HDR_CONTENT_TYPE
- };
-
- /* local routines */
diff --git a/main/squid/squid-2.7-loggable-urlgroup.patch b/main/squid/squid-2.7-loggable-urlgroup.patch
deleted file mode 100644
index c2bc9e6d6..000000000
--- a/main/squid/squid-2.7-loggable-urlgroup.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Index: squid-2.7.STABLE9/src/access_log.c
-===================================================================
---- squid-2.7.STABLE9.orig/src/access_log.c 2010-11-18 15:02:26.000000000 +0200
-+++ squid-2.7.STABLE9/src/access_log.c 2010-11-18 15:07:34.000000000 +0200
-@@ -301,6 +301,7 @@
- LFT_REQUEST_URLPATH,
- /*LFT_REQUEST_QUERY, * // * this is not needed. see strip_query_terms */
- LFT_REQUEST_VERSION,
-+ LFT_REQUEST_URLGROUP,
-
- LFT_REQUEST_SIZE_TOTAL,
- /*LFT_REQUEST_SIZE_LINE, */
-@@ -411,6 +412,7 @@
- /* { "rq", LFT_REQUEST_QUERY }, * / / * the query-string, INCLUDING the leading ? */
- {">v", LFT_REQUEST_VERSION},
- {"rv", LFT_REQUEST_VERSION},
-+ {"rG", LFT_REQUEST_URLGROUP},
-
- {">st", LFT_REQUEST_SIZE_TOTAL},
- /*{ ">sl", LFT_REQUEST_SIZE_LINE }, * / / * the request line "GET ... " */
-@@ -544,6 +546,12 @@
- quote = 1;
- break;
-
-+ case LFT_REQUEST_URLGROUP:
-+ if (al->request)
-+ out = al->request->urlgroup;
-+ quote = 1;
-+ break;
-+
- case LFT_REPLY_HEADER:
- if (al->reply)
- sb = httpHeaderGetByName(&al->reply->header, fmt->data.header.header);
diff --git a/main/squid/squid-3.2.0.12-loggable-urlgroup.patch b/main/squid/squid-3.2.0.12-loggable-urlgroup.patch
new file mode 100644
index 000000000..ee1646fe5
--- /dev/null
+++ b/main/squid/squid-3.2.0.12-loggable-urlgroup.patch
@@ -0,0 +1,111 @@
+Index: squid-3.2.0.12/src/client_side_request.cc
+===================================================================
+--- squid-3.2.0.12.orig/src/client_side_request.cc 2011-10-07 20:29:10.000000000 +0300
++++ squid-3.2.0.12/src/client_side_request.cc 2011-10-07 21:54:38.000000000 +0300
+@@ -1165,6 +1165,15 @@
+ redirect_state = REDIRECT_DONE;
+
+ if (result) {
++ if (result[0] == '!') {
++ char *t = strchr(result+1, '!');
++ if (t != NULL) {
++ old_request->urlgroup.reset(NULL);
++ old_request->urlgroup.append(result + 1, t - result - 1);
++ result = t + 1;
++ }
++ }
++
+ http_status status = (http_status) atoi(result);
+
+ if (status == HTTP_MOVED_PERMANENTLY
+@@ -1183,7 +1192,7 @@
+ else
+ debugs(85, DBG_CRITICAL, "ERROR: URL-rewrite produces invalid 303 redirect Location: " << result);
+ }
+- } else if (strcmp(result, http->uri)) {
++ } else if (result[0] != 0 && strcmp(result, http->uri)) {
+ // XXX: validate the URL properly *without* generating a whole new request object right here.
+ // XXX: the clone() should be done only AFTER we know the new URL is valid.
+ HttpRequest *new_request = old_request->clone();
+Index: squid-3.2.0.12/src/HttpRequest.cc
+===================================================================
+--- squid-3.2.0.12.orig/src/HttpRequest.cc 2011-10-07 21:02:45.000000000 +0300
++++ squid-3.2.0.12/src/HttpRequest.cc 2011-10-07 21:03:45.000000000 +0300
+@@ -106,6 +106,7 @@
+ peer_login = NULL; // not allocated/deallocated by this class
+ peer_domain = NULL; // not allocated/deallocated by this class
+ vary_headers = NULL;
++ urlgroup = null_string;
+ myportname = null_string;
+ tag = null_string;
+ #if USE_AUTH
+@@ -154,6 +155,7 @@
+ range = NULL;
+ }
+
++ urlgroup.clean();
+ myportname.clean();
+
+ tag.clean();
+@@ -213,6 +215,7 @@
+ copy->vary_headers = vary_headers ? xstrdup(vary_headers) : NULL;
+ // XXX: what to do with copy->peer_domain?
+
++ copy->urlgroup = urlgroup;
+ copy->myportname = myportname;
+ copy->tag = tag;
+ #if USE_AUTH
+Index: squid-3.2.0.12/src/HttpRequest.h
+===================================================================
+--- squid-3.2.0.12.orig/src/HttpRequest.h 2011-10-07 21:02:45.000000000 +0300
++++ squid-3.2.0.12/src/HttpRequest.h 2011-10-07 21:02:55.000000000 +0300
+@@ -187,6 +187,8 @@
+
+ char *peer_domain; /* Configured peer forceddomain */
+
++ String urlgroup;
++
+ String myportname; // Internal tag name= value from port this requests arrived in.
+
+ String tag; /* Internal tag for this request */
+Index: squid-3.2.0.12/src/format/Format.cc
+===================================================================
+--- squid-3.2.0.12.orig/src/format/Format.cc 2011-10-07 21:33:38.000000000 +0300
++++ squid-3.2.0.12/src/format/Format.cc 2011-10-07 21:41:45.000000000 +0300
+@@ -895,6 +895,12 @@
+ out = tmp;
+ break;
+
++ case LFT_REQUEST_URLGROUP:
++ if (al->request)
++ out = al->request->urlgroup.termedBuf();
++ quote = 1;
++ break;
++
+ case LFT_SERVER_REQ_METHOD:
+ if (al->adapted_request) {
+ out = al->adapted_request->method.image();
+Index: squid-3.2.0.12/src/format/Tokens.h
+===================================================================
+--- squid-3.2.0.12.orig/src/format/Tokens.h 2011-10-07 21:34:25.000000000 +0300
++++ squid-3.2.0.12/src/format/Tokens.h 2011-10-07 21:40:26.000000000 +0300
+@@ -100,6 +100,7 @@
+ /*LFT_REQUEST_QUERY, */
+ LFT_REQUEST_VERSION_OLD_2X,
+ LFT_REQUEST_VERSION,
++ LFT_REQUEST_URLGROUP,
+
+ /* Request-Line details sent to the server/peer */
+ LFT_SERVER_REQ_METHOD,
+Index: squid-3.2.0.12/src/format/Tokens.cc
+===================================================================
+--- squid-3.2.0.12.orig/src/format/Tokens.cc 2011-10-07 21:38:05.000000000 +0300
++++ squid-3.2.0.12/src/format/Tokens.cc 2011-10-07 21:40:55.000000000 +0300
+@@ -114,6 +114,7 @@
+ {"rp", LFT_REQUEST_URLPATH_OLD_31},
+ /* { "rq", LFT_REQUEST_QUERY }, * / / * the query-string, INCLUDING the leading ? */
+ {"rv", LFT_REQUEST_VERSION},
++ {"rG", LFT_REQUEST_URLGROUP},
+
+ {"<rm", LFT_SERVER_REQ_METHOD},
+ {"<ru", LFT_SERVER_REQ_URI},
diff --git a/main/squid/squid.pre-upgrade b/main/squid/squid.pre-upgrade
index 70437c5d9..322d21dea 120000..100644
--- a/main/squid/squid.pre-upgrade
+++ b/main/squid/squid.pre-upgrade
@@ -1 +1,6 @@
-squid.pre-install \ No newline at end of file
+#!/bin/sh
+
+adduser -D squid -H /var/cache/squid 2>/dev/null
+addgroup winbind 2>/dev/null
+addgroup squid winbind
+exit 0