summaryrefslogtreecommitdiffstats
path: root/main/syslinux
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-11 00:21:10 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-11 00:21:10 -0500
commit0ef6140b0dfdf44009c170d69288a1a324a1c528 (patch)
treedd623ce1936c8ab1b582cb4d14ba5e6686b63a63 /main/syslinux
parentcddf77d67884c0c62ebbdfb9f0f0d2ae018f1c80 (diff)
downloadaports-0ef6140b0dfdf44009c170d69288a1a324a1c528.tar.bz2
aports-0ef6140b0dfdf44009c170d69288a1a324a1c528.tar.xz
main/syslinux: fix some bugs
Diffstat (limited to 'main/syslinux')
-rw-r--r--main/syslinux/APKBUILD6
-rw-r--r--main/syslinux/extlinux.conf4
-rwxr-xr-xmain/syslinux/update-extlinux18
3 files changed, 18 insertions, 10 deletions
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index df9cef11a..f42a5dff7 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
pkgver=4.04
-pkgrel=1
+pkgrel=2
pkgdesc="a boot loader for the Linux operating system which operates off an MS-DOS/Windows FAT filesystem."
url="http://syslinux.org"
arch="x86 x86_64"
@@ -36,5 +36,5 @@ package() {
}
md5sums="a3936208767eb7ced65320abe2e33a10 syslinux-4.04.tar.bz2
-b7506dbbe9f05bed6d9e78f222b1e0ce extlinux.conf
-2c1016e63c12d4e8ca49aab374f2389e update-extlinux"
+37f8ae1cbb41b68241d6027abd828318 extlinux.conf
+efe69677c78d8037f62a24267d598559 update-extlinux"
diff --git a/main/syslinux/extlinux.conf b/main/syslinux/extlinux.conf
index 5894b4ab3..05bdcc935 100644
--- a/main/syslinux/extlinux.conf
+++ b/main/syslinux/extlinux.conf
@@ -20,3 +20,7 @@ root=
# verbose
# if set to non-zero, update-extlinux will be a lot more verbose.
verbose=0
+
+# hidden
+# if set to non-zero, the boot menu will be hidden by default.
+hidden=1
diff --git a/main/syslinux/update-extlinux b/main/syslinux/update-extlinux
index 831eaa05b..8a5509b9e 100755
--- a/main/syslinux/update-extlinux
+++ b/main/syslinux/update-extlinux
@@ -39,15 +39,19 @@ if [ "$fancy_menu" = "1" ]; then
echo "DEFAULT vesamenu.c32" > /boot/extlinux.conf.new
echo "PROMPT 0" >> /boot/extlinux.conf.new
- echo "MENU TITLE Alpine/$(uname -s) Boot Menu" >> /boot/extlinux.conf
- echo "MENU HIDDEN" >> /boot/extlinux.conf.new
+ echo "MENU TITLE Alpine/$(uname -s) Boot Menu" >> /boot/extlinux.conf.new
+ if [ "$hidden" = "1" ]; then
+ echo "MENU HIDDEN" >> /boot/extlinux.conf.new
+ fi
echo "MENU AUTOBOOT Alpine will be booted automatically in # seconds." >> /boot/extlinux.conf.new
echo "TIMEOUT $rtimeout" >> /boot/extlinux.conf.new
else
echo "DEFAULT menu.c32" > /boot/extlinux.conf.new
echo "PROMPT 0" >> /boot/extlinux.conf.new
- echo "MENU TITLE Alpine/$(uname -s) Boot Menu" >> /boot/extlinux.conf
- echo "MENU HIDDEN" >> /boot/extlinux.conf.new
+ echo "MENU TITLE Alpine/$(uname -s) Boot Menu" >> /boot/extlinux.conf.new
+ if [ "$hidden" = "1" ]; then
+ echo "MENU HIDDEN" >> /boot/extlinux.conf.new
+ fi
echo "MENU AUTOBOOT Alpine will be booted automatically in # seconds." >> /boot/extlinux.conf.new
echo "TIMEOUT $rtimeout" >> /boot/extlinux.conf.new
fi
@@ -72,11 +76,11 @@ for kernel in $(find /boot -name vmlinuz-* -type f); do
lst=$(($lst + 1))
done
-if [ -f "/boot/memtest.bin" ]; then
- everbose "Found memtest86+: /boot/memtest.bin"
+if [ -f "/boot/memtest" ]; then
+ everbose "Found memtest86+: /boot/memtest"
echo "LABEL $lst" >> /boot/extlinux.conf.new
echo " MENU LABEL Memtest86+" >> /boot/extlinux.conf.new
- echo " KERNEL memtest.bin" >> /boot/extlinux.conf.new
+ echo " KERNEL memtest" >> /boot/extlinux.conf.new
lst=$(($lst + 1))
fi