summaryrefslogtreecommitdiffstats
path: root/main/util-linux
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-04-19 09:21:34 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-04-19 09:21:34 +0000
commitad89f93ea4166fc1716014b7db728867d2140442 (patch)
tree0ca449df39b11cf1a3b627ee4f7a562f3916a22a /main/util-linux
parent2cae9a391eae62ccdbce54bb8138b5763344fb19 (diff)
downloadaports-ad89f93ea4166fc1716014b7db728867d2140442.tar.bz2
aports-ad89f93ea4166fc1716014b7db728867d2140442.tar.xz
main/util-linux: upgrade to 2.21
Diffstat (limited to 'main/util-linux')
-rw-r--r--main/util-linux/APKBUILD23
-rw-r--r--main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch13
-rw-r--r--main/util-linux/program-invocation.patch4
3 files changed, 26 insertions, 14 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 5db8f2a2e..99f3e361c 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -1,21 +1,20 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
-pkgver=2.20
-pkgrel=1
+pkgver=2.21
+pkgrel=0
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
license="GPL-2 GPL Public Domain"
depends=
-# use GNU sed til bb sed is fixed
-makedepends="zlib-dev sed ncurses-dev"
+# use GNU sed til bb sed is fixed. Also GNU tar is needed
+makedepends="zlib-dev sed ncurses-dev tar"
install=
source="http://www.kernel.org/pub/linux/utils/util-linux/v${pkgver}/util-linux-$pkgver.tar.gz
program-invocation.patch
- 0001-script-fix-building-with-disable-nls.patch
+ fix_NL_TIME_FIRST_WEEKDAY.patch
"
-
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid sfdisk cfdisk mcookie blkid"
replaces="e2fsprogs util-linux-ng"
@@ -32,9 +31,9 @@ prepare() {
build() {
cd "$_builddir"
- sed -e 's/versionsort/alphasort/g'\
- -e 's/strverscmp.h/dirent.h/g' \
- -i mount/lomount.c
+# sed -e 's/versionsort/alphasort/g'\
+# -e 's/strverscmp.h/dirent.h/g' \
+# -i mount/lomount.c
./configure --prefix=/usr \
--enable-raw \
@@ -105,6 +104,6 @@ mcookie() {
mv "$pkgdir"/usr/bin/mcookie "$subpkgdir"/usr/bin/
}
-md5sums="fbcd168147c87550804744b70c2feac5 util-linux-2.20.tar.gz
-079dc713684e01ad48c7e0bb877dc51a program-invocation.patch
-b0b5ef3a9f785a5431675da696b60262 0001-script-fix-building-with-disable-nls.patch"
+md5sums="4222aa8c2a1b78889e959a4722f1881a util-linux-2.21.tar.gz
+9682a6ddd5abe65434a145ebe512c123 program-invocation.patch
+8c434a785bfaed23d8f222c14d883a82 fix_NL_TIME_FIRST_WEEKDAY.patch"
diff --git a/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch b/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch
new file mode 100644
index 000000000..9ea76a03b
--- /dev/null
+++ b/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch
@@ -0,0 +1,13 @@
+Index: util-linux-2.21/misc-utils/cal.c
+===================================================================
+--- util-linux-2.21.orig/misc-utils/cal.c 2012-02-29 23:41:54.413347665 -0800
++++ util-linux-2.21/misc-utils/cal.c 2012-02-29 23:42:44.573350057 -0800
+@@ -297,7 +297,7 @@
+ * the locale database, which can be overridden with the
+ * -s (Sunday) or -m (Monday) options.
+ */
+-#ifdef HAVE_DECL__NL_TIME_WEEK_1STDAY
++#if HAVE_DECL__NL_TIME_WEEK_1STDAY
+ /*
+ * You need to use 2 locale variables to get the first day of the week.
+ * This is needed to support first_weekday=2 and first_workday=1 for
diff --git a/main/util-linux/program-invocation.patch b/main/util-linux/program-invocation.patch
index c81f97e36..e3c266e5b 100644
--- a/main/util-linux/program-invocation.patch
+++ b/main/util-linux/program-invocation.patch
@@ -1,5 +1,5 @@
---- util-linux-2.19.1.orig/include/c.h
-+++ util-linux-2.19.1/include/c.h
+--- util-linux-2.21.orig/include/c.h
++++ util-linux-2.21.1/include/c.h
@@ -115,7 +115,7 @@
#ifndef HAVE_PROGRAM_INVOCATION_SHORT_NAME