summaryrefslogtreecommitdiffstats
path: root/main/vlc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-03-22 14:11:27 +0200
committerTimo Teräs <timo.teras@iki.fi>2011-03-22 14:11:27 +0200
commit89a1070091a2f9bc438f8bbb6ea320086ec828e4 (patch)
treea3bfd6871665bba3346b3ede41ad8c6e615435f3 /main/vlc
parent5002b2448f71b396b396d20c61e94923c4ddf67c (diff)
downloadaports-89a1070091a2f9bc438f8bbb6ea320086ec828e4.tar.bz2
aports-89a1070091a2f9bc438f8bbb6ea320086ec828e4.tar.xz
main/vlc: unbreak streaming of files to network
The uclibc patch disabled using of monotonic clocks for pthread_cond_timedwait(). This was needed for LinuxThreads as it does not support it. However, this completely breaks the NPTL build. We really need to use the monotonic clock as that's how pthreads_condattr_init constructions our conditions. The original patch was flawed: it should have disabled the monotonic clock via other ways.
Diffstat (limited to 'main/vlc')
-rw-r--r--main/vlc/APKBUILD3
-rw-r--r--main/vlc/uclibc3.patch13
2 files changed, 2 insertions, 14 deletions
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index eb39d69b3..a4978b2cf 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
pkgver=1.1.7
-pkgrel=7
+pkgrel=8
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
url="http://www.videolan.org/vlc/"
arch="all"
@@ -90,6 +90,7 @@ build ()
--disable-optimizations \
--disable-qt4 --disable-skins2 \
--disable-rpath \
+ --enable-debug \
--enable-a52 \
--enable-avcodec \
--enable-avformat \
diff --git a/main/vlc/uclibc3.patch b/main/vlc/uclibc3.patch
index 04154f35b..bacad290a 100644
--- a/main/vlc/uclibc3.patch
+++ b/main/vlc/uclibc3.patch
@@ -34,16 +34,3 @@ index 1644ce6..1440e1c 100644
const char *glcv = gnu_get_libc_version ();
/* gettext in glibc 2.5-2.7 is not thread-safe. LibVLC keeps crashing,
-diff --git a/src/misc/mtime.c b/src/misc/mtime.c
-index 1cc787d..985aa3a 100644
---- a/src/misc/mtime.c
-+++ b/src/misc/mtime.c
-@@ -78,7 +78,7 @@ int nanosleep(struct timespec *, struct timespec *);
- # define _POSIX_CLOCK_SELECTION (-1)
- #endif
-
--# if (_POSIX_CLOCK_SELECTION < 0)
-+# if (_POSIX_CLOCK_SELECTION < 0) || defined(__UCLIBC__)
- /*
- * We cannot use the monotonic clock if clock selection is not available,
- * as it would screw vlc_cond_timedwait() completely. Instead, we have to