summaryrefslogtreecommitdiffstats
path: root/main/wine/wine-isinf-isnan.patch
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-07 15:51:06 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2011-07-07 15:51:06 +0000
commit03c0cafd0ff6fb73231b27e498533cf4375343f2 (patch)
treee4f0539879651f97926ed510ef7e1d1b7c0523bd /main/wine/wine-isinf-isnan.patch
parent021c1656e1448233378ed5d4035d0a392bb6aa5e (diff)
parent8c48da01414415a08c2d06ae76d50089078c26c0 (diff)
downloadaports-03c0cafd0ff6fb73231b27e498533cf4375343f2.tar.bz2
aports-03c0cafd0ff6fb73231b27e498533cf4375343f2.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'main/wine/wine-isinf-isnan.patch')
-rw-r--r--main/wine/wine-isinf-isnan.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/main/wine/wine-isinf-isnan.patch b/main/wine/wine-isinf-isnan.patch
new file mode 100644
index 000000000..e97586c8f
--- /dev/null
+++ b/main/wine/wine-isinf-isnan.patch
@@ -0,0 +1,19 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -2327,6 +2327,8 @@
+ fi
+
+ dnl Check for isinf
++ac_save_LIBS="$LIBS"
++LIBS="$LIBS -lm"
+ AC_CACHE_CHECK([for isinf], ac_cv_have_isinf,
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <math.h>]], [[float f = 0.0; return isinf(f)]])],[ac_cv_have_isinf="yes"],[ac_cv_have_isinf="no"]))
+ if test "$ac_cv_have_isinf" = "yes"
+@@ -2341,6 +2343,7 @@
+ then
+ AC_DEFINE(HAVE_ISNAN, 1, [Define to 1 if you have the `isnan' function.])
+ fi
++LIBS="$ac_save_LIBS"
+
+ dnl *** check for the need to define platform-specific symbols
+