summaryrefslogtreecommitdiffstats
path: root/main/wireshark
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-02 09:38:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-02 09:38:40 +0000
commit37fc6310509c4832e1ea26882970171428ddcb1a (patch)
treeede946ed54802821cc6ee18011882233f0c1ce9b /main/wireshark
parent607d2b046a7376cb5b9b3becec948ffe059a8d6d (diff)
downloadaports-37fc6310509c4832e1ea26882970171428ddcb1a.tar.bz2
aports-37fc6310509c4832e1ea26882970171428ddcb1a.tar.xz
main/wireshark: upgrade to 1.2.8
Diffstat (limited to 'main/wireshark')
-rw-r--r--main/wireshark/APKBUILD17
-rw-r--r--main/wireshark/wireshark-1.1.2--as-needed.patch20
-rw-r--r--main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch30
3 files changed, 64 insertions, 3 deletions
diff --git a/main/wireshark/APKBUILD b/main/wireshark/APKBUILD
index bd315fa3b..7aeb2803e 100644
--- a/main/wireshark/APKBUILD
+++ b/main/wireshark/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
pkgname=wireshark
-pkgver=1.2.6
-pkgrel=2
+pkgver=1.2.8
+pkgrel=0
pkgdesc="network protocol analyzer - GTK version"
url="http://www.wireshark.org"
license="GPLv2"
@@ -12,10 +12,19 @@ makedepends="bison flex perl glib glib-dev pkgconfig libpcap-dev libcap-dev
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
source="http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.bz2
+ wireshark-1.1.2--as-needed.patch
+ wireshark-1.2.8-zlib-1.2.5-capture.patch
wireshark.desktop
wireshark.png"
# depends_dev="somepackage-dev"
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying $i"
+ patch -p1 -i "$i" || return 1
+ done
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -64,6 +73,8 @@ tshark() {
mv "$pkgdir"/usr/bin/tshark "$subpkgdir"/usr/bin/tshark
}
-md5sums="f3e0917ed393366bbf96c53b58cb0931 wireshark-1.2.6.tar.bz2
+md5sums="3a75d4f62317e52b8b39a1e9e37f1553 wireshark-1.2.8.tar.bz2
+cc87d7eb31f256df751b3371b1c426e9 wireshark-1.1.2--as-needed.patch
+cc4fbe2db149f2ee42dd0593944a69fe wireshark-1.2.8-zlib-1.2.5-capture.patch
504ede44c02b2a52f6cbd3bffdf93b8d wireshark.desktop
e771800a8c977fe223583a453bc27397 wireshark.png"
diff --git a/main/wireshark/wireshark-1.1.2--as-needed.patch b/main/wireshark/wireshark-1.1.2--as-needed.patch
new file mode 100644
index 000000000..7da659c09
--- /dev/null
+++ b/main/wireshark/wireshark-1.1.2--as-needed.patch
@@ -0,0 +1,20 @@
+diff --git a/epan/Makefile.am b/epan/Makefile.am
+index b2a569d..717e233 100644
+--- a/epan/Makefile.am
++++ b/epan/Makefile.am
+@@ -130,6 +130,7 @@ libwireshark_la_LIBADD = \
+ dissectors/libdirtydissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
+ @C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ \
+ @KRB5_LIBS@ @SSL_LIBS@ @LIBSMI_LDFLAGS@ @GEOIP_LIBS@ \
++ ${top_builddir}/wiretap/libwiretap.la \
+ ${top_builddir}/wsutil/libwsutil.la -lm
+
+ libwireshark_la_DEPENDENCIES = \
+@@ -137,6 +138,7 @@ libwireshark_la_DEPENDENCIES = \
+ libwireshark_asmopt.la crypt/libairpdcap.la ftypes/libftypes.la \
+ dfilter/libdfilter.la dissectors/libdissectors.la \
+ dissectors/libdirtydissectors.la $(wslua_lib) \
++ ${top_builddir}/wiretap/libwiretap.la \
+ ${top_builddir}/wsutil/libwsutil.la
+
+ #EXTRA_PROGRAMS = reassemble_test
diff --git a/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch b/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch
new file mode 100644
index 000000000..312002740
--- /dev/null
+++ b/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch
@@ -0,0 +1,30 @@
+http://anonsvn.wireshark.org/viewvc?view=rev&revision=32715
+
+--- trunk/wiretap/wtap.c 2010/05/07 19:24:32 32714
++++ trunk/wiretap/wtap.c 2010/05/07 19:45:47 32715
+@@ -35,6 +35,10 @@
+ #include <unistd.h>
+ #endif
+
++#ifdef HAVE_LIBZ
++#include <zlib.h>
++#endif
++
+ #include "wtap-int.h"
+ #include "wtap.h"
+
+@@ -646,6 +650,14 @@
+ */
+ wth->phdr.pkt_encap = wth->file_encap;
+
++#if defined(ZLIB_VERNUM) && ZLIB_VERNUM == 0x1250
++ /* Reset EOF */
++ /* g_log(NULL, G_LOG_LEVEL_DEBUG, "wtap_read: eof before seek: %d", gzeof(wth->fh)); */
++ if (gzeof(wth->fh))
++ gzseek(wth->fh, 0, SEEK_CUR);
++ /* g_log(NULL, G_LOG_LEVEL_DEBUG, "wtap_read: eof after seek: %d", gzeof(wth->fh)); */
++#endif
++
+ if (!wth->subtype_read(wth, err, err_info, data_offset))
+ return FALSE; /* failure */
+