summaryrefslogtreecommitdiffstats
path: root/main/xen/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-17 19:06:17 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-17 19:06:17 -0600
commitbd4729f70cc9cd71d9defca1cd0dc82893bf8f10 (patch)
tree0c39c7f0f0dc3e39f1d6a5701b4256d56db51235 /main/xen/APKBUILD
parentf369602f6bfd7345808a67c2427e770e97f44ca5 (diff)
downloadaports-bd4729f70cc9cd71d9defca1cd0dc82893bf8f10.tar.bz2
aports-bd4729f70cc9cd71d9defca1cd0dc82893bf8f10.tar.xz
testing/xen: promote to main
Diffstat (limited to 'main/xen/APKBUILD')
-rw-r--r--main/xen/APKBUILD77
1 files changed, 77 insertions, 0 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
new file mode 100644
index 000000000..c3ff291ae
--- /dev/null
+++ b/main/xen/APKBUILD
@@ -0,0 +1,77 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=xen
+pkgver=4.0.1
+pkgrel=2
+pkgdesc="Xen hypervisor"
+url="http://www.xen.org/"
+license="GPL"
+depends="coreutils python sed gawk"
+makedepends="libgcrypt-dev gnutls-dev pciutils-dev texinfo wget mesa-dev sdl-dev zlib-dev openssl-dev util-linux-ng-dev python-dev gettext-dev ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.gz
+ xen-blktap-uclibc.patch
+ xen-blktap2-uclibc.patch
+ xen-disable-firmware.patch
+ xen-disable-fsback.patch
+ xen-disable-werror.patch
+ xen-dont-use-lib64.patch
+ xend.initd
+ xendomains.initd"
+arch="x86_64"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i..."
+ patch -s -p1 -N -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
+ # like these values being set. Arguably this is a bug but I can't be
+ # bothered to track it down. --nenolod
+ unset CFLAGS
+ unset LDFLAGS
+
+ # If we provide no parameters it tries to build a kernel image. We
+ # definitely don't want that.
+ (cd tools/check; ./chk build) || return 1
+ make -j1 xen tools stubdom || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
+ # like these values being set. Arguably this is a bug but I can't be
+ # bothered to track it down. --nenolod
+ unset CFLAGS
+ unset LDFLAGS
+
+ make DESTDIR="$pkgdir" install-xen install-tools install-stubdom
+
+ install -m755 -D "$srcdir"/xend.initd "$pkgdir"/etc/init.d/xend
+ install -m755 -D "$srcdir"/xendomains.initd "$pkgdir"/etc/init.d/xendomains
+}
+
+md5sums="d197afad975ab2396a67323d57388c27 xen-4.0.1.tar.gz
+edb5c3e7fba8214702fac709f0e53124 xen-blktap-uclibc.patch
+1f7f847ae0baa915c7b52d0ed5869fe6 xen-blktap2-uclibc.patch
+a569f16a7e3c832ba3fab6154f657244 xen-disable-firmware.patch
+03d1fff892e627b812bba4e6c56d696a xen-disable-fsback.patch
+949d0d3bc1e8f300a849279b60760c6a xen-disable-werror.patch
+b6599060e22b61dabee0fe460b4a0c9d xen-dont-use-lib64.patch
+1d81b04f8c8b919879a73f0e3d2fe80f xend.initd
+a2b5234483f1b5892d22e9315d9c307f xendomains.initd"