summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-nouveau
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-06 12:14:12 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-06 12:14:12 -0500
commit46f24c01db8ca0b2271cd897d0fa1d2c28fabe73 (patch)
tree8e36a92092357ccf894a8286c4589ed7ac0c8f7c /main/xf86-video-nouveau
parent48175a08dd23f4a81079e2c691eefaca0b593de4 (diff)
downloadaports-46f24c01db8ca0b2271cd897d0fa1d2c28fabe73.tar.bz2
aports-46f24c01db8ca0b2271cd897d0fa1d2c28fabe73.tar.xz
main/xf86-video-nouveau: move from testing
Diffstat (limited to 'main/xf86-video-nouveau')
-rw-r--r--main/xf86-video-nouveau/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/xf86-video-nouveau/APKBUILD b/main/xf86-video-nouveau/APKBUILD
new file mode 100644
index 000000000..afb46d00a
--- /dev/null
+++ b/main/xf86-video-nouveau/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor:
+# Maintainer:
+pkgname=xf86-video-nouveau
+_gitdate=20110506
+pkgver=0.0.16_git${_gitdate}
+pkgrel=1
+pkgdesc="Open-source X.org drivers for nVidia video cards"
+url="http://nouveau.freedesktop.org/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=
+makedepends="pkgconfig randrproto renderproto videoproto xextproto libdrm-dev xorg-server-dev util-macros libtool autoconf automake xf86driproto"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dev.alpinelinux.org/~nenolod/xf86-video-nouveau-${_gitdate}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${_gitdate}"
+
+mksource() {
+ mkdir /tmp/${pkgname}-${_gitdate}
+ (cd /tmp/${pkgname}-${_gitdate};
+ git clone -v --depth 1 git://anongit.freedesktop.org/nouveau/xf86-video-nouveau;
+ cd xf86-video-nouveau;
+ git archive --prefix=xf86-video-nouveau-${_gitdate}/ --format=tar HEAD | bzip2 > /tmp/${pkgname}-${_gitdate}/${pkgname}-${_gitdate}.tar.bz2)
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f48ffca3436988f5ffe915d7b47192a9 xf86-video-nouveau-20110506.tar.bz2"