summaryrefslogtreecommitdiffstats
path: root/main/xfce4-xkb-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-20 16:43:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-20 16:44:32 +0000
commit65610cc57fd797fd687934dad6f2f902d12900a6 (patch)
tree1ca97c7cba6e7137f415cf8be2eb29e48255a77c /main/xfce4-xkb-plugin
parent0e126b45acf3a6ab1b87a3eb8ce7128545086cc2 (diff)
downloadaports-65610cc57fd797fd687934dad6f2f902d12900a6.tar.bz2
aports-65610cc57fd797fd687934dad6f2f902d12900a6.tar.xz
main/xfce4-xkb-plugin: upgrade to 0.5.4.0
Diffstat (limited to 'main/xfce4-xkb-plugin')
-rw-r--r--main/xfce4-xkb-plugin/APKBUILD13
-rw-r--r--main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch30
2 files changed, 5 insertions, 38 deletions
diff --git a/main/xfce4-xkb-plugin/APKBUILD b/main/xfce4-xkb-plugin/APKBUILD
index aa59a0b51..bfaa14bc6 100644
--- a/main/xfce4-xkb-plugin/APKBUILD
+++ b/main/xfce4-xkb-plugin/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfce4-xkb-plugin
-pkgver=0.5.3.3
+pkgver=0.5.4.0
_maj=${pkgver%%.*}
_min=${pkgver#${_maj}.}
_min=${_min%%.*}
_ver=${_maj}.${_min}
-pkgrel=5
+pkgrel=0
pkgdesc="plugin to switch keyboard layouts for the Xfce4 panel"
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
arch="all"
@@ -13,13 +13,11 @@ license="custom"
subpackages="$pkgname-doc"
depends=
makedepends="xfce4-panel-dev libxklavier-dev librsvg-dev intltool libwnck-dev
- libxi-dev libxkbfile-dev libsm-dev libgsf-dev e2fsprogs-dev bzip2-dev libxfcegui4-dev"
-source="http://archive.xfce.org/src/panel-plugins/xfce4-xkb-plugin/$_ver/xfce4-xkb-plugin-$pkgver.tar.gz
- xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"
+ libxi-dev libxkbfile-dev libsm-dev libgsf-dev e2fsprogs-dev bzip2-dev libxfce4ui-dev"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-xkb-plugin/$_ver/xfce4-xkb-plugin-$pkgver.tar.bz2"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i ../xfce4-xkb-plugin-0.5.3.3-libxklavier.patch || return 1
}
build () {
@@ -37,5 +35,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="b233cc9de1cbace075eaf6e2c9a8e685 xfce4-xkb-plugin-0.5.3.3.tar.gz
-781165ce1bc08059ae8e846c45c0bab2 xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"
+md5sums="3ea1efe366367af660e6e1d24a240b5f xfce4-xkb-plugin-0.5.4.0.tar.bz2"
diff --git a/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch b/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch
deleted file mode 100644
index 5b9dc5401..000000000
--- a/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur xfce4-xkb-plugin-0.5.3.3.orig/panel-plugin/xkb-config.c xfce4-xkb-plugin-0.5.3.3/panel-plugin/xkb-config.c
---- xfce4-xkb-plugin-0.5.3.3.orig/panel-plugin/xkb-config.c 2009-03-06 15:16:03.000000000 +0200
-+++ xfce4-xkb-plugin-0.5.3.3/panel-plugin/xkb-config.c 2009-07-20 18:40:34.000000000 +0300
-@@ -150,7 +150,7 @@
- config->application_map = g_hash_table_new (g_direct_hash, NULL);
-
- registry = xkl_config_registry_get_instance (config->engine);
-- xkl_config_registry_load (registry);
-+ xkl_config_registry_load (registry, FALSE);
-
- config_item = xkl_config_item_new ();
-
-@@ -214,7 +214,7 @@
-
- gdk_window_remove_filter (NULL, (GdkFilterFunc) handle_xevent, NULL);
-
-- xkl_engine_stop_listen (config->engine);
-+ xkl_engine_stop_listen (config->engine, XKLL_TRACK_KEYBOARD_STATE);
- }
-
- gint
-@@ -547,7 +547,7 @@
- if (!config) return NULL;
-
- registry = xkl_config_registry_get_instance (config->engine);
-- xkl_config_registry_load (registry);
-+ xkl_config_registry_load (registry, FALSE);
-
- return registry;
- }