summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-17 20:46:25 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-17 20:46:51 -0500
commit56b3e818912ac0ccc294efea6fca3a5d07d19fd6 (patch)
tree4d5ba4cb36c507e220149d8f15625a17b912b0d9 /main/xulrunner
parent0314b8125e186c9ec8cbacb8cf8c53ec32da5415 (diff)
downloadaports-56b3e818912ac0ccc294efea6fca3a5d07d19fd6.tar.bz2
aports-56b3e818912ac0ccc294efea6fca3a5d07d19fd6.tar.xz
main/xulrunner: upgrade to 2.0_rc1
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD39
-rw-r--r--main/xulrunner/enable-x86_64-tracemonkey.patch12
-rw-r--r--main/xulrunner/fix-mozilla-portability-cluelessness-libpr0n-edition.patch16
-rw-r--r--main/xulrunner/gecko-c99math.patch11
-rw-r--r--main/xulrunner/ipc-chromium-execinfo.patch25
-rw-r--r--main/xulrunner/mozconfig1
-rw-r--r--main/xulrunner/mozilla-pkgconfig.patch4
-rw-r--r--main/xulrunner/mozjs-c99math.patch24
-rw-r--r--main/xulrunner/xpcom-execinfo.patch23
-rw-r--r--main/xulrunner/xulrunner-png14.patch11
10 files changed, 105 insertions, 61 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 7fbc3889a..cfcef0527 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=1.9.2.15
+pkgver=2.0_rc1
+_ffoxver=4.0rc1
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
@@ -26,20 +27,23 @@ depends_dev="nspr-dev
startup-notification-dev
sqlite-dev
libidl-dev
- fts-dev"
+ fts-dev
+ mesa-dev"
makedepends="$depends_dev
autoconf2.13
python
zip
+ yasm
autoconf
automake
libtool"
install=""
subpackages="$pkgname-dev"
-source="http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
+# http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
+source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
mozconfig
@@ -47,16 +51,19 @@ source="http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}
fix-xulrunner-launcher.patch
mozilla-pkgconfig.patch
- xulrunner-png14.patch
+ ipc-chromium-execinfo.patch
+
+ xulrunner-mozalloc.patch
xulrunner-version.patch
- mozjs-c99math.patch
+ xpcom-execinfo.patch
- ipc-chromium-execinfo.patch
+ mozjs-c99math.patch
+ gecko-c99math.patch
fix-mozilla-portability-cluelessness-libpr0n-edition.patch"
-_xulrunner_version="${pkgver%.*}"
+_xulrunner_version="2.0"
_builddir="${srcdir}/mozilla-${_xulrunner_version}"
prepare() {
local i
@@ -102,13 +109,15 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="09c688b5dabe45f23c653af24d3abfe4 xulrunner-1.9.2.15.source.tar.bz2
-d0908177f4c3879817f5dc7287cbb2b2 mozconfig
-faecc31fd371db93311109117f6bcc40 enable-x86_64-tracemonkey.patch
+md5sums="511828dcc226f38602c6c67bd192ef40 firefox-4.0rc1.source.tar.bz2
+d7a79ba952885c05cc41789faad30bba mozconfig
+78291eb2cd97553d8fd76306c52d40f1 enable-x86_64-tracemonkey.patch
86d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
-d839d1c4ef736e6d89ccf91b23b965a4 mozilla-pkgconfig.patch
-39e3c85c80f7897ac463e7fe7ad9a343 xulrunner-png14.patch
+02c23dc4ebd88e445533314716331818 mozilla-pkgconfig.patch
+60cb07e288889dd5b1b882eecc9f6e86 ipc-chromium-execinfo.patch
+d38ecbb7bb31032d3e1ced8939e26abd xulrunner-mozalloc.patch
371303c5bdc4fa0d955d14521b93b69d xulrunner-version.patch
-03b73ac11442a26a978c53a6c114ef2b mozjs-c99math.patch
-ac1c3725167eb26c89d62b1818810ee4 ipc-chromium-execinfo.patch
-7123ec519e3a4d2c8d07369065a61dc7 fix-mozilla-portability-cluelessness-libpr0n-edition.patch"
+b349739dcac45f3cc0ccaf2943abf6ed xpcom-execinfo.patch
+b187440207e773e9be606594d2c99216 mozjs-c99math.patch
+aacbb29e1448f9af6697e8a885b9bbfa gecko-c99math.patch
+d18eb944a7a5275a1837b2a536689186 fix-mozilla-portability-cluelessness-libpr0n-edition.patch"
diff --git a/main/xulrunner/enable-x86_64-tracemonkey.patch b/main/xulrunner/enable-x86_64-tracemonkey.patch
index f4e1da036..30cccf2e3 100644
--- a/main/xulrunner/enable-x86_64-tracemonkey.patch
+++ b/main/xulrunner/enable-x86_64-tracemonkey.patch
@@ -11,15 +11,3 @@
arm*-*)
ENABLE_JIT=1
NANOJIT_ARCH=ARM
-@@ -2488,7 +2492,10 @@
- i?86-*)
- AC_DEFINE(AVMPLUS_IA32)
- ;;
--
-+x86_64*-*)
-+ AC_DEFINE(AVMPLUS_AMD64)
-+ AC_DEFINE(AVMPLUS_64BIT)
-+ ;;
- arm*-*)
- AC_DEFINE(AVMPLUS_ARM)
- ;;
diff --git a/main/xulrunner/fix-mozilla-portability-cluelessness-libpr0n-edition.patch b/main/xulrunner/fix-mozilla-portability-cluelessness-libpr0n-edition.patch
index 4fc112a07..33ba8ef6d 100644
--- a/main/xulrunner/fix-mozilla-portability-cluelessness-libpr0n-edition.patch
+++ b/main/xulrunner/fix-mozilla-portability-cluelessness-libpr0n-edition.patch
@@ -1,14 +1,14 @@
---- mozilla-1.9.2.orig/gfx/qcms/qcmstypes.h
-+++ mozilla-1.9.2/gfx/qcms/qcmstypes.h
-@@ -7,9 +7,9 @@
+--- mozilla-2.0.orig/gfx/qcms/qcmstypes.h
++++ mozilla-2.0/gfx/qcms/qcmstypes.h
+@@ -7,9 +7,8 @@
/* prtypes.h defines IS_LITTLE_ENDIAN and IS_BIG ENDIAN */
-#if defined (__SVR4) && defined (__sun)
-+#if 1
- /* int_types.h gets included somehow, so avoid redefining the types differently */
+-/* int_types.h gets included somehow, so avoid redefining the types differently */
-#include <sys/int_types.h>
++#if 1
+#include <stdint.h>
- #else
- typedef PRInt8 int8_t;
- typedef PRUint8 uint8_t;
+ #elif defined (_AIX)
+ #include <sys/types.h>
+ #elif !defined(ANDROID)
diff --git a/main/xulrunner/gecko-c99math.patch b/main/xulrunner/gecko-c99math.patch
new file mode 100644
index 000000000..cdb846442
--- /dev/null
+++ b/main/xulrunner/gecko-c99math.patch
@@ -0,0 +1,11 @@
+--- mozilla-2.0.orig/content/canvas/src/nsCanvasRenderingContext2D.cpp
++++ mozilla-2.0/content/canvas/src/nsCanvasRenderingContext2D.cpp
+@@ -159,7 +159,7 @@
+ // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
+ return !!_finite(d);
+ #else
+- return finite(d);
++ return isfinite(d);
+ #endif
+ }
+
diff --git a/main/xulrunner/ipc-chromium-execinfo.patch b/main/xulrunner/ipc-chromium-execinfo.patch
index 48fc1c6a3..4bbc143d8 100644
--- a/main/xulrunner/ipc-chromium-execinfo.patch
+++ b/main/xulrunner/ipc-chromium-execinfo.patch
@@ -1,14 +1,14 @@
---- mozilla-1.9.2.orig/ipc/chromium/src/base/debug_util_posix.cc
-+++ mozilla-1.9.2/ipc/chromium/src/base/debug_util_posix.cc
-@@ -6,7 +6,6 @@
- #include "base/debug_util.h"
-
- #include <errno.h>
+--- mozilla-2.0.orig/ipc/chromium/src/base/debug_util_posix.cc
++++ mozilla-2.0/ipc/chromium/src/base/debug_util_posix.cc
+@@ -12,7 +12,6 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #ifndef ANDROID
-#include <execinfo.h>
- #include <fcntl.h>
- #include <stdio.h>
- #include <sys/stat.h>
-@@ -114,6 +113,7 @@
+ #include <sys/sysctl.h>
+ #endif
+
+@@ -116,6 +115,7 @@
}
StackTrace::StackTrace() {
@@ -16,7 +16,7 @@
const int kMaxCallers = 256;
void* callers[kMaxCallers];
-@@ -128,11 +128,14 @@
+@@ -134,12 +134,15 @@
} else {
trace_.resize(0);
}
@@ -26,8 +26,9 @@
void StackTrace::PrintBacktrace() {
+#if 0
fflush(stderr);
+ #ifndef ANDROID
backtrace_symbols_fd(&trace_[0], trace_.size(), STDERR_FILENO);
+#endif
+ #endif
}
- void StackTrace::OutputToStream(std::ostream* os) {
diff --git a/main/xulrunner/mozconfig b/main/xulrunner/mozconfig
index 90b0bea4c..54786a303 100644
--- a/main/xulrunner/mozconfig
+++ b/main/xulrunner/mozconfig
@@ -30,6 +30,7 @@ ac_add_options --disable-crashreporter
ac_add_options --enable-safe-browsing
ac_add_options --enable-startup-notification
ac_add_options --enable-extensions=default
+ac_add_options --enable-jemalloc
export LIBS="-lfts"
export BUILD_OFFICIAL=1
diff --git a/main/xulrunner/mozilla-pkgconfig.patch b/main/xulrunner/mozilla-pkgconfig.patch
index 9331e0489..5c8bd0fd6 100644
--- a/main/xulrunner/mozilla-pkgconfig.patch
+++ b/main/xulrunner/mozilla-pkgconfig.patch
@@ -6,7 +6,7 @@ diff -Nur mozilla-1.9.2.orig/xulrunner/installer/libxul-embedding.pc.in mozilla-
Description: Static library for version-independent embedding of the Mozilla runtime
Version: %MOZILLA_VERSION%
+Requires: %NSPR_NAME% >= %NSPR_VERSION%
- Libs: -L${sdkdir}/lib -lxpcomglue
+ Libs: -L${sdkdir}/lib -lxpcomglue -ldl
Cflags: -DXPCOM_GLUE -I${includedir} %WCHAR_CFLAGS%
diff -Nur mozilla-1.9.2.orig/xulrunner/installer/libxul.pc.in mozilla-1.9.2/xulrunner/installer/libxul.pc.in
--- mozilla-1.9.2.orig/xulrunner/installer/libxul.pc.in 2010-01-21 05:31:27.000000000 +0200
@@ -55,6 +55,6 @@ diff -Nur mozilla-1.9.2.orig/xulrunner/installer/mozilla-js.pc.in mozilla-1.9.2/
@@ -7,4 +7,4 @@
Version: %MOZILLA_VERSION%
Requires: %NSPR_NAME% >= %NSPR_VERSION%
- Libs: -L${sdkdir}/lib -lmozjs
+ Libs: -L${sdkdir}/lib %MOZ_JS_LINK%
-Cflags: -I${includedir} -DXP_UNIX -DJS_THREADSAFE
+Cflags: -I${includedir} -I${includedir}/js -DXP_UNIX -DJS_THREADSAFE
diff --git a/main/xulrunner/mozjs-c99math.patch b/main/xulrunner/mozjs-c99math.patch
index ce05c1796..fdf346e49 100644
--- a/main/xulrunner/mozjs-c99math.patch
+++ b/main/xulrunner/mozjs-c99math.patch
@@ -5,7 +5,29 @@
return _finite(d);
#else
- return finite(d);
-+ return __finite(d);
++ return isfinite(d);
+ #endif
+ }
+
+--- mozilla-2.0.orig/js/src/ctypes/CTypes.cpp
++++ mozilla-2.0/js/src/ctypes/CTypes.cpp
+@@ -464,7 +464,7 @@
+ #ifdef WIN32
+ return _finite(f) != 0;
+ #else
+- return finite(f);
++ return isfinite(f);
+ #endif
+ }
+
+--- mozilla-2.0.orig/content/base/public/nsContentUtils.h
++++ mozilla-2.0/content/base/public/nsContentUtils.h
+@@ -1942,7 +1942,7 @@
+ #ifdef WIN32
+ return _finite(f);
+ #else
+- return finite(f);
++ return isfinite(f);
#endif
}
diff --git a/main/xulrunner/xpcom-execinfo.patch b/main/xulrunner/xpcom-execinfo.patch
new file mode 100644
index 000000000..1fe320967
--- /dev/null
+++ b/main/xulrunner/xpcom-execinfo.patch
@@ -0,0 +1,23 @@
+--- mozilla-2.0.orig/xpcom/threads/nsThread.cpp
++++ mozilla-2.0/xpcom/threads/nsThread.cpp
+@@ -54,7 +54,9 @@
+ && defined(_GNU_SOURCE)
+ # define MOZ_CANARY
+ # include <unistd.h>
+-# include <execinfo.h>
++# if !defined(__UCLIBC__)
++# include <execinfo.h>
++# endif
+ # include <signal.h>
+ # include <fcntl.h>
+ # include "nsXULAppAPI.h"
+@@ -562,7 +564,9 @@
+ const char msg[29] = "event took too long to run:\n";
+ // use write to be safe in the signal handler
+ write(Canary::sOutputFD, msg, sizeof(msg));
++#if !defined(__UCLIBC__)
+ backtrace_symbols_fd(array, backtrace(array, 30), Canary::sOutputFD);
++#endif
+ }
+
+ #endif
diff --git a/main/xulrunner/xulrunner-png14.patch b/main/xulrunner/xulrunner-png14.patch
deleted file mode 100644
index be80e30f9..000000000
--- a/main/xulrunner/xulrunner-png14.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/modules/libpr0n/encoders/png/nsPNGEncoder.cpp.orig 2010-01-17 00:15:53.979744638 +0100
-+++ b/modules/libpr0n/encoders/png/nsPNGEncoder.cpp 2010-01-17 00:16:07.855993411 +0100
-@@ -135,7 +135,7 @@
-
- // initialize
- mPNG = png_create_write_struct(PNG_LIBPNG_VER_STRING,
-- png_voidp_NULL,
-+ NULL,
- ErrorCallback,
- ErrorCallback);
- if (! mPNG)