summaryrefslogtreecommitdiffstats
path: root/main/zenity
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-16 20:13:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-16 20:13:36 +0000
commit4e655271bc4c2a90f11041dbc6f887daf5d0ad0c (patch)
tree8867d0657d6e8423e73777936bb9ae372bdefe04 /main/zenity
parentdc307c1a4f3ade7b5c70b56c3ca310fdb0e60893 (diff)
downloadaports-4e655271bc4c2a90f11041dbc6f887daf5d0ad0c.tar.bz2
aports-4e655271bc4c2a90f11041dbc6f887daf5d0ad0c.tar.xz
main/zentiy: rebuild against libnotify-0.7
Diffstat (limited to 'main/zenity')
-rw-r--r--main/zenity/APKBUILD10
-rw-r--r--main/zenity/zenity-2.32.1-libnotify-0.7.patch27
2 files changed, 33 insertions, 4 deletions
diff --git a/main/zenity/APKBUILD b/main/zenity/APKBUILD
index e0a8aac16..f6b221adc 100644
--- a/main/zenity/APKBUILD
+++ b/main/zenity/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=zenity
pkgver=2.32.1
-pkgrel=0
+pkgrel=1
pkgdesc="GTK+-based xdialog replacement"
url="http://www.gnome.org/"
arch="all"
@@ -10,8 +10,9 @@ license="GPL"
depends=
makedepends="gtk+-dev intltool gnome-doc-utils libnotify-dev"
install=""
-subpackages="$pkgname-doc"
-source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+subpackages="$pkgname-doc $pkgname-lang"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ zenity-2.32.1-libnotify-0.7.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -44,4 +45,5 @@ doc() {
return 0
}
-md5sums="aa66ec35451b16e424519b4973082170 zenity-2.32.1.tar.bz2"
+md5sums="aa66ec35451b16e424519b4973082170 zenity-2.32.1.tar.bz2
+8e367823e5ef02116f08d77274503e5e zenity-2.32.1-libnotify-0.7.patch"
diff --git a/main/zenity/zenity-2.32.1-libnotify-0.7.patch b/main/zenity/zenity-2.32.1-libnotify-0.7.patch
new file mode 100644
index 000000000..8b7fee738
--- /dev/null
+++ b/main/zenity/zenity-2.32.1-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- ./src/notification.c
++++ ./src/notification.c
+@@ -30,6 +30,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include "zenity.h"
+@@ -184,10 +187,14 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_new_with_status_icon was removed */
++#else
+ notif = notify_notification_new_with_status_icon (
+ message[0] /* title */,
+ message[1] /* summary */,
+ icon, status_icon);
++#endif
+
+ g_strfreev (message);
+ g_free (freeme);