summaryrefslogtreecommitdiffstats
path: root/main/zsh
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-21 21:33:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-21 21:33:21 +0000
commit41988c571159edd0f6477cf85c6a9c6e9e8e1f85 (patch)
treeacb26fab0790f8b7462c9b2d254ea3b4440ae155 /main/zsh
parent23f948cbcb5ee57ac7f3a14e9e363460a0f9eead (diff)
downloadaports-41988c571159edd0f6477cf85c6a9c6e9e8e1f85.tar.bz2
aports-41988c571159edd0f6477cf85c6a9c6e9e8e1f85.tar.xz
main/zsh: moved from testing
Diffstat (limited to 'main/zsh')
-rw-r--r--main/zsh/APKBUILD45
-rw-r--r--main/zsh/zsh.post-install3
-rw-r--r--main/zsh/zsh.post-upgrade3
-rw-r--r--main/zsh/zsh.pre-deinstall3
4 files changed, 54 insertions, 0 deletions
diff --git a/main/zsh/APKBUILD b/main/zsh/APKBUILD
new file mode 100644
index 000000000..bdb885c3b
--- /dev/null
+++ b/main/zsh/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: <kalonji@gmail.com>
+# Maintainer: <ncopa@alpinelinux.org>
+pkgname=zsh
+pkgver=4.3.11
+pkgrel=1
+pkgdesc="A very advanced and programmable command interpreter (shell) for UNIX"
+url="http://www.zsh.org/"
+arch="all"
+license="custom"
+depends=
+makedepends=ncurses-dev
+install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
+source="ftp://ftp.zsh.org/pub/${pkgname}-${pkgver}.tar.gz
+$install"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --bindir=/bin \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/profile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-multibyte \
+ --enable-function-subdirs \
+ --enable-zsh-secure-free \
+ --sysconfdir=/etc \
+ --with-tcsetpgrp \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="127e2a3b9100d6f2fddb6a32cd4aca40 zsh-4.3.11.tar.gz
+aedff0460ef282937905223207ac702e zsh.post-install
+aedff0460ef282937905223207ac702e zsh.post-upgrade
+b48f79e2d4a29047f6152f5a9441f942 zsh.pre-deinstall"
diff --git a/main/zsh/zsh.post-install b/main/zsh/zsh.post-install
new file mode 100644
index 000000000..46506fbee
--- /dev/null
+++ b/main/zsh/zsh.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+grep -q '/bin/zsh' /etc/shells || echo '/bin/zsh' >> /etc/shells
+exit 0
diff --git a/main/zsh/zsh.post-upgrade b/main/zsh/zsh.post-upgrade
new file mode 100644
index 000000000..46506fbee
--- /dev/null
+++ b/main/zsh/zsh.post-upgrade
@@ -0,0 +1,3 @@
+#!/bin/sh
+grep -q '/bin/zsh' /etc/shells || echo '/bin/zsh' >> /etc/shells
+exit 0
diff --git a/main/zsh/zsh.pre-deinstall b/main/zsh/zsh.pre-deinstall
new file mode 100644
index 000000000..bd078e838
--- /dev/null
+++ b/main/zsh/zsh.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+sed -i '/^\/bin\/zsh/d' /etc/shells
+exit 0