summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 08:14:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 08:14:36 +0000
commit1637ec0b4882424c13f093ec40587539680a1101 (patch)
tree1eb07b0b3818967bd4f73de8f5fa96378d3dc110 /main
parent36b2240896f5b7757b23caf892ce9124bb79e059 (diff)
downloadaports-1637ec0b4882424c13f093ec40587539680a1101.tar.bz2
aports-1637ec0b4882424c13f093ec40587539680a1101.tar.xz
main/libc0.9.32: add eventfd support
Diffstat (limited to 'main')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/uclibc-eventfd.patch141
2 files changed, 144 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index cbf5aa339..4b6536332 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.32
_ver=${pkgver/_/-}
-pkgrel=4
+pkgrel=5
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -41,6 +41,7 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
uclibcconfig.arm
uclibcconfig.powerpc
sha512-crypt.patch
+ uclibc-eventfd.patch
uclibc-utils.trigger
"
@@ -150,4 +151,5 @@ beeafc978b9ad3ea963a4760a4334f03 uclibcconfig.i486
8f6e60a43d02b84e3acfea53be9a8d01 uclibcconfig.arm
f02d8174ff7ea74942428bbbaf46abae uclibcconfig.powerpc
7bf1af84106de9e05160ed6d4853c54f sha512-crypt.patch
+26dd7611fda4d29f3dc4a7cf24916931 uclibc-eventfd.patch
f3be4f2bc54d7561d252937e10abf0d2 uclibc-utils.trigger"
diff --git a/main/libc0.9.32/uclibc-eventfd.patch b/main/libc0.9.32/uclibc-eventfd.patch
new file mode 100644
index 000000000..1525366c3
--- /dev/null
+++ b/main/libc0.9.32/uclibc-eventfd.patch
@@ -0,0 +1,141 @@
+From: jc@eclis.ch
+To: uclibc@uclibc.org
+Subject: [PATCH 1/1] Add eventfd support.
+Date: Mon, 24 Oct 2011 19:07:43 +0200
+Message-Id: <1319476064-32442-1-git-send-email-jc@eclis.ch>
+X-Mailer: git-send-email 1.7.2.5
+X-BeenThere: uclibc@uclibc.org
+X-Mailman-Version: 2.1.14
+Precedence: list
+List-Id: "Discussion and development of uClibc \(the embedded C library\)"
+ <uclibc.uclibc.org>
+List-Unsubscribe: <http://lists.busybox.net/mailman/options/uclibc>,
+ <mailto:uclibc-request@uclibc.org?subject=unsubscribe>
+List-Archive: <http://lists.busybox.net/pipermail/uclibc>
+List-Post: <mailto:uclibc@uclibc.org>
+List-Help: <mailto:uclibc-request@uclibc.org?subject=help>
+List-Subscribe: <http://lists.busybox.net/mailman/listinfo/uclibc>,
+ <mailto:uclibc-request@uclibc.org?subject=subscribe>
+MIME-Version: 1.0
+Content-Type: text/plain; charset="us-ascii"
+Content-Transfer-Encoding: 7bit
+Errors-To: uclibc-bounces@uclibc.org
+Sender: uclibc-bounces@uclibc.org
+
+From: Jean-Christian de Rivaz <jc@eclis.ch>
+
+Hello,
+
+I whould like to share this simple patch that add the eventfd call to
+uClibc. Please review so it can be accepted to be merged.
+
+Jean-Christian
+
+Signed-off-by: Jean-Christian de Rivaz <jc@eclis.ch>
+---
+ libc/sysdeps/linux/common/Makefile.in | 3 +-
+ libc/sysdeps/linux/common/eventfd.c | 18 +++++++++++
+ libc/sysdeps/linux/common/sys/eventfd.h | 48 +++++++++++++++++++++++++++++++
+ 3 files changed, 68 insertions(+), 1 deletions(-)
+ create mode 100644 libc/sysdeps/linux/common/eventfd.c
+ create mode 100644 libc/sysdeps/linux/common/sys/eventfd.h
+
+diff --git a/libc/sysdeps/linux/common/Makefile.in b/libc/sysdeps/linux/common/Makefile.in
+index 8f936ff..63f3f6f 100644
+--- a/libc/sysdeps/linux/common/Makefile.in
++++ b/libc/sysdeps/linux/common/Makefile.in
+@@ -24,7 +24,8 @@ CSRC-$(UCLIBC_LINUX_SPECIFIC) += capget.c capset.c inotify.c ioperm.c iopl.c \
+ remap_file_pages.c sched_getaffinity.c sched_setaffinity.c \
+ sendfile64.c sendfile.c setfsgid.c setfsuid.c setresuid.c \
+ splice.c vmsplice.c tee.c signalfd.c swapoff.c swapon.c \
+- sync_file_range.c sysctl.c sysinfo.c timerfd.c uselib.c vhangup.c
++ sync_file_range.c sysctl.c sysinfo.c eventfd.c timerfd.c uselib.c \
++ vhangup.c
+ # NPTL needs these internally: madvise.c
+ CSRC-$(findstring y,$(UCLIBC_LINUX_SPECIFIC)$(UCLIBC_HAS_THREADS_NATIVE)) += madvise.c
+ ifeq ($(UCLIBC_HAS_THREADS_NATIVE),y)
+diff --git a/libc/sysdeps/linux/common/eventfd.c b/libc/sysdeps/linux/common/eventfd.c
+new file mode 100644
+index 0000000..cc3f3f0
+--- /dev/null
++++ b/libc/sysdeps/linux/common/eventfd.c
+@@ -0,0 +1,18 @@
++/* vi: set sw=4 ts=4: */
++/*
++ * eventfd() for uClibc
++ *
++ * Copyright (C) 2011 Jean-Christian de Rivaz <jc@eclis.ch>
++ *
++ * Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
++ */
++
++#include <sys/syscall.h>
++#include <sys/eventfd.h>
++
++/*
++ * eventfd()
++ */
++#ifdef __NR_eventfd
++_syscall2(int, eventfd, int, count, int, flags)
++#endif
+diff --git a/libc/sysdeps/linux/common/sys/eventfd.h b/libc/sysdeps/linux/common/sys/eventfd.h
+new file mode 100644
+index 0000000..311f803
+--- /dev/null
++++ b/libc/sysdeps/linux/common/sys/eventfd.h
+@@ -0,0 +1,48 @@
++/* Copyright (C) 2007, 2008, 2009 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#ifndef _SYS_EVENTFD_H
++#define _SYS_EVENTFD_H 1
++
++#include <stdint.h>
++
++
++/* Type for event counter. */
++typedef uint64_t eventfd_t;
++
++/* Flags for signalfd. */
++enum
++ {
++ EFD_SEMAPHORE = 1,
++#define EFD_SEMAPHORE EFD_SEMAPHORE
++ EFD_CLOEXEC = 02000000,
++#define EFD_CLOEXEC EFD_CLOEXEC
++ EFD_NONBLOCK = 04000
++#define EFD_NONBLOCK EFD_NONBLOCK
++ };
++
++
++__BEGIN_DECLS
++
++/* Return file descriptor for generic event channel. Set initial
++ value to COUNT. */
++extern int eventfd (int __count, int __flags) __THROW;
++
++__END_DECLS
++
++#endif /* sys/eventfd.h */
+--
+1.7.2.5
+
+_______________________________________________
+uClibc mailing list
+uClibc@uclibc.org
+http://lists.busybox.net/mailman/listinfo/uclibc