summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-26 11:30:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-26 11:30:02 +0000
commit27122b883948bc635037f2ffbfe78243cfa5de5e (patch)
tree224308bab6d57bffa6c86f830c7c059093f5356b /main
parentefcd7ef99b94fa79dd054e99cba9175eaa557fb1 (diff)
downloadaports-27122b883948bc635037f2ffbfe78243cfa5de5e.tar.bz2
aports-27122b883948bc635037f2ffbfe78243cfa5de5e.tar.xz
main/linux-grsec: fix constify in makefile
Diffstat (limited to 'main')
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/makefile-constify.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 60813e21f..60fd1b1d2 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.0.3
_kernver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -17,6 +17,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-$_kernver.tar.bz2
grsecurity-2.2.2-3.0.3-201108251825.patch
0004-arp-flush-arp-cache-on-device-change.patch
+ makefile-constify.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -140,5 +141,6 @@ md5sums="398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
1757786b9a9ffbd48ad9642199ff5bd7 patch-3.0.3.bz2
dbf71c02960bdb9e047ed6ccd61e108e grsecurity-2.2.2-3.0.3-201108251825.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
+d948f4dc51ed32f86e9e75d61680597f makefile-constify.patch
406e62e430cee7ba3bb37be341d9ff3e kernelconfig.x86
6957efc9f017c59b05aa0a2e4167255e kernelconfig.x86_64"
diff --git a/main/linux-grsec/makefile-constify.patch b/main/linux-grsec/makefile-constify.patch
new file mode 100644
index 000000000..679bd1ab2
--- /dev/null
+++ b/main/linux-grsec/makefile-constify.patch
@@ -0,0 +1,10 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1383,6 +1383,7 @@
+ $(module-dirs): crmodverdir $(objtree)/Module.symvers
+ $(Q)$(MAKE) $(build)=$(patsubst _module_%,%,$@)
+
++modules: KBUILD_CFLAGS += $(CONSTIFY_PLUGIN) $(STACKLEAK_PLUGIN)
+ modules: $(module-dirs)
+ @$(kecho) ' Building modules, stage 2.';
+ $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost