summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-25 17:30:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-25 17:30:38 +0000
commitb47227307d6fbe3e8f9cc2a2b9233c546cf0a71a (patch)
tree0b5f8900404e8bac459fa4a303a7b882c8b0fcb3 /main
parent7352c094405f3410f5021269a0fc585efd4fe51a (diff)
downloadaports-b47227307d6fbe3e8f9cc2a2b9233c546cf0a71a.tar.bz2
aports-b47227307d6fbe3e8f9cc2a2b9233c546cf0a71a.tar.xz
main/gettext: link to system expat and libxml2 rather than use internal
patches from gentoo
Diffstat (limited to 'main')
-rw-r--r--main/gettext/APKBUILD29
-rw-r--r--main/gettext/gettext-0.15-expat-no-dlopen.patch36
-rw-r--r--main/gettext/gettext-0.17-gnuinfo.patch16
-rw-r--r--main/gettext/gettext-0.17-open-args.patch25
4 files changed, 100 insertions, 6 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index 958e1131c..430068e77 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -1,23 +1,40 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=gettext
pkgver=0.17
-pkgrel=0
+pkgrel=1
pkgdesc="GNU locale utilities"
url="http://www.gnu.org/software/gettext/gettext.html"
license='GPL'
-depends="libiconv expat ncurses"
-makedepends="libiconv-dev"
-source="ftp://ftp.mirror.nl/pub/mirror/gnu/gettext/gettext-0.17.tar.gz"
+depends=
+makedepends="libiconv-dev expat-dev ncurses-dev bash uclibc++-dev libxml2-dev"
+source="ftp://ftp.mirror.nl/pub/mirror/gnu/gettext/gettext-0.17.tar.gz
+ gettext-0.15-expat-no-dlopen.patch
+ gettext-0.17-gnuinfo.patch
+ gettext-0.17-open-args.patch
+ "
subpackages="$pkgname-doc $pkgname-dev"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ export CXX=${CXX_UC:-g++-uc}
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=81628
+ export CPPFLAGS="$CPPFLAGS -I/usr/include/libxml2"
./configure --prefix=/usr \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man \
+ --disable-static
unset MAKEFLAGS
make || return 1
make DESTDIR="$pkgdir/" install
}
-md5sums="58a2bc6d39c0ba57823034d55d65d606 gettext-0.17.tar.gz"
+md5sums="58a2bc6d39c0ba57823034d55d65d606 gettext-0.17.tar.gz
+20dbf5cfc16f8726e7594fb49da5665c gettext-0.15-expat-no-dlopen.patch
+51ba4ca1008c76564c25c632a4ee8b3e gettext-0.17-gnuinfo.patch
+aa0b9cb60cd87298dbfc2662b98e8a0b gettext-0.17-open-args.patch"
diff --git a/main/gettext/gettext-0.15-expat-no-dlopen.patch b/main/gettext/gettext-0.15-expat-no-dlopen.patch
new file mode 100644
index 000000000..4630d1dd9
--- /dev/null
+++ b/main/gettext/gettext-0.15-expat-no-dlopen.patch
@@ -0,0 +1,36 @@
+Add support for expat-2 to xgettext by linking it at build time rather than
+at runtime using dlopen
+
+http://bugs.gentoo.org/146211
+
+--- gettext-0.15/gettext-tools/configure
++++ gettext-0.15/gettext-tools/configure
+@@ -44267,19 +44266,6 @@
+
+
+
+-case "$host_os" in
+- linux*)
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define DYNLOAD_LIBEXPAT 1
+-_ACEOF
+-
+- LIBEXPAT="-ldl"
+- LTLIBEXPAT="-ldl"
+-
+-
+- ;;
+- *)
+
+
+
+@@ -44786,8 +44772,6 @@
+
+
+
+- ;;
+-esac
+
+ # If set to t, that means we are running in a shell under Emacs.
+ # If you have an Emacs named "t", then use the full path.
diff --git a/main/gettext/gettext-0.17-gnuinfo.patch b/main/gettext/gettext-0.17-gnuinfo.patch
new file mode 100644
index 000000000..243916636
--- /dev/null
+++ b/main/gettext/gettext-0.17-gnuinfo.patch
@@ -0,0 +1,16 @@
+Fix broken Info file produced by texinfo 4.11
+http://bugs.gentoo.org/249167
+
+--- gettext-0.17/gettext-tools/doc/gettext.info
++++ gettext-0.17/gettext-tools/doc/gettext.info
+@@ -1,7 +1,8 @@
++This is gettext.info, produced by makeinfo version 4.13 from
++gettext.texi.
++
+ INFO-DIR-SECTION GNU Gettext Utilities
+ START-INFO-DIR-ENTRY
+-This is gettext.info, produced by makeinfo version 4.11 from gettext.texi.
+-
+ * gettext: (gettext). GNU gettext utilities.
+ * autopoint: (gettext)autopoint Invocation. Copy gettext infrastructure.
+ * envsubst: (gettext)envsubst Invocation. Expand environment variables.
diff --git a/main/gettext/gettext-0.17-open-args.patch b/main/gettext/gettext-0.17-open-args.patch
new file mode 100644
index 000000000..6291f0049
--- /dev/null
+++ b/main/gettext/gettext-0.17-open-args.patch
@@ -0,0 +1,25 @@
+2007-11-07 Jim Meyering <meyering@redhat.com>
+ Bruno Haible <bruno@clisp.org>
+
+ * write-catalog.c (msgdomain_list_print): Fix open() call.
+
+--- a/gettext-tools/src/write-catalog.c 7 Oct 2007 19:35:31 -0000 1.4
++++ b/gettext-tools/src/write-catalog.c 7 Nov 2007 11:43:15 -0000
+@@ -1,5 +1,5 @@
+ /* GNU gettext - internationalization aids
+- Copyright (C) 1995-1998, 2000-2006 Free Software Foundation, Inc.
++ Copyright (C) 1995-1998, 2000-2007 Free Software Foundation, Inc.
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -220,7 +220,9 @@
+ /* Open the output file. */
+ if (!to_stdout)
+ {
+- fd = open (filename, O_WRONLY | O_CREAT);
++ fd = open (filename, O_WRONLY | O_CREAT | O_TRUNC,
++ /* 0666 in portable POSIX notation: */
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if (fd < 0)
+ {
+ const char *errno_description = strerror (errno);