summaryrefslogtreecommitdiffstats
path: root/testing/aha
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-09 10:33:04 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-09 10:33:10 +0100
commit7ff75be3b1abfa8861dbf5a1a2475887a9c3b0cd (patch)
tree325f90779e6eed5471d9cce1d938d3394144e949 /testing/aha
parenta1bdf73d2645d58d320ce1ddfdcf4cc9792ea3a8 (diff)
downloadaports-7ff75be3b1abfa8861dbf5a1a2475887a9c3b0cd.tar.bz2
aports-7ff75be3b1abfa8861dbf5a1a2475887a9c3b0cd.tar.xz
testing/aha: new aport
Diffstat (limited to 'testing/aha')
-rw-r--r--testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch32
-rw-r--r--testing/aha/0001-Honor-common-compiler-and-linker-flags.patch33
-rw-r--r--testing/aha/APKBUILD46
3 files changed, 111 insertions, 0 deletions
diff --git a/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch b/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
new file mode 100644
index 000000000..67105bd81
--- /dev/null
+++ b/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
@@ -0,0 +1,32 @@
+From ed4f29b64b16bec894ae1865b8d0b70c3ab7f7c9 Mon Sep 17 00:00:00 2001
+From: Axel Beckert <abe@deuxchevaux.org>
+Date: Wed, 1 Aug 2012 18:03:25 +0200
+Subject: [PATCH] Fix several hyphen-used-as-minus-sign issues in the man page
+
+---
+ aha.1 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/aha.1 b/aha.1
+index 52796fa..93af54a 100644
+--- a/aha.1
++++ b/aha.1
+@@ -43,13 +43,13 @@ Don't include header into generated HTML, useful for inclusion in full HTML file
+
+ .SH EXAMPLE
+ .TP
+-\fBaha\fP \-\-help | \fBaha\fP \-\-black --title "the awesome aha help"> aha-help.htm
++\fBaha\fP \-\-help | \fBaha\fP \-\-black \-\-title "the awesome aha help"> aha\-help.htm
+ Creates an HTML file with the help of aha with black background
+ .TP
+ \fBcolordiff\fP oldfile.c newfile.c | \fBaha\fP > colordiff.htm
+ Creates an HTML file with a colorful diff-output of two files "oldfile.c" and "newfile.c" with white background
+ .TP
+-\fBls\fP \--color=always | \fBaha\fP \-\-pink > ls.htm
++\fBls\fP \-\-color=always | \fBaha\fP \-\-pink > ls.htm
+ Creates an HTML file with a colorful ls-output with pink background.
+ .TP
+ \fBecho\fP q | \fBhtop\fP | \fBaha\fP \-\-black \-\-line\-fix > htop.htm
+--
+1.7.10.4
+
diff --git a/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch b/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch
new file mode 100644
index 000000000..977dd6999
--- /dev/null
+++ b/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch
@@ -0,0 +1,33 @@
+From bf5ed98a037d40bcec0e4fdc4550f7e41eb7e828 Mon Sep 17 00:00:00 2001
+From: Axel Beckert <abe@deuxchevaux.org>
+Date: Tue, 31 Jul 2012 13:31:32 +0200
+Subject: [PATCH] Honor common compiler and linker flags
+
+---
+ CHANGELOG | 2 ++
+ Makefile | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CHANGELOG b/CHANGELOG
+index 3472806..b4ef123 100644
+--- a/CHANGELOG
++++ b/CHANGELOG
+@@ -1,3 +1,5 @@
++- Honor common compiler and linker flags
++
+ Version 0.4.6:
+ - Added Feature for not creating a header e.g. for already existing HTML-files (thanks to Nicolas Zagulajew)
+
+diff --git a/Makefile b/Makefile
+index b880ba0..f113108 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+ all: aha
+
+ aha: aha.c
+- gcc -std=c99 aha.c -o aha
++ gcc -std=c99 $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) aha.c -o aha
+--
+1.7.10.4
+
diff --git a/testing/aha/APKBUILD b/testing/aha/APKBUILD
new file mode 100644
index 000000000..b43d4823e
--- /dev/null
+++ b/testing/aha/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=aha
+pkgver=0.4.6
+pkgrel=0
+pkgdesc="ANSI color to HTML converter"
+url="http://anonscm.debian.org/gitweb/?p=collab-maint/aha.git;a=summary"
+arch="all"
+license="MPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.de.debian.org/debian/pool/main/a/aha/aha_0.4.6.orig.tar.gz
+ 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
+ 0001-Honor-common-compiler-and-linker-flags.patch"
+
+_builddir="$srcdir/theZiz-aha-42a7c6f"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm 755 aha \
+ "$pkgdir"/usr/bin/aha || return 1
+ install -Dm 644 aha.1 \
+ "$pkgdir"/usr/share/man/man1/aha.1 || return 1
+}
+
+md5sums="3557e9437957ca01a171354c872f5bfc aha_0.4.6.orig.tar.gz
+1105a981ee4973945c2000874eeb289b 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
+71425c7044c709848606054578f730da 0001-Honor-common-compiler-and-linker-flags.patch"