summaryrefslogtreecommitdiffstats
path: root/testing/asterisk/APKBUILD
diff options
context:
space:
mode:
authorTimo Teras <timo.teras@iki.fi>2009-06-23 18:48:38 +0300
committerTimo Teras <timo.teras@iki.fi>2009-06-23 19:15:40 +0300
commit5a675d6f07425df85a4b0213def3586038b219b3 (patch)
treee8914a4434291f4914c168b0e051f939de8dcce9 /testing/asterisk/APKBUILD
parent30a0a20ab902639b2da7215a524a29fc918c70b9 (diff)
downloadaports-5a675d6f07425df85a4b0213def3586038b219b3.tar.bz2
aports-5a675d6f07425df85a4b0213def3586038b219b3.tar.xz
testing/asterisk: update to 1.6.3.0_pre20090623
This is svn trunk revision 202568 against 1.6.2.0-beta3 dist tarball. APKBUILD updated according to latest extra/asterisk.
Diffstat (limited to 'testing/asterisk/APKBUILD')
-rw-r--r--testing/asterisk/APKBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/testing/asterisk/APKBUILD b/testing/asterisk/APKBUILD
index ced7f2119..05837d4ae 100644
--- a/testing/asterisk/APKBUILD
+++ b/testing/asterisk/APKBUILD
@@ -1,34 +1,34 @@
# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
-pkgver=1.6.2.0_beta1
-_myver=1.6.2.0-beta1
-pkgrel=4
+pkgver=1.6.3.0_pre20090623
+_basever=1.6.2.0-beta3
+pkgrel=0
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
license="GPL"
-depends="ncurses popt zlib newt dahdi-linux dahdi-tools libltdl libpri freetds"
+depends="dahdi-linux"
makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev
- postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev g++ tar
- freetds-dev"
+ postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar
+ freetds-dev openssl-dev"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc
$pkgname-tds"
-source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$_myver.tar.gz
+source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$_basever.tar.gz
asterisk-01-1.6.0-gsm-pic.patch
- asterisk-03-1.6.2.0-beta1-to-r186562.patch
+ asterisk-02-uclibc-daemon.patch
+ asterisk-03-1.6.2.0-beta3-to-svn-r202568.patch
asterisk-04-1.6.0-beta7.1-caps-uclibc.patch
asterisk-05-1.6.1-glob-uclibc.patch
asterisk-06-overlapped-enum.patch
asterisk-07-issue14068.patch
- 200-uclibc-daemon.patch
asterisk.pre-install
asterisk.post-install
asterisk.initd
asterisk.confd"
build() {
- cd "$srcdir/$pkgname-$_myver"
+ cd "$srcdir/$pkgname-$_basever"
for i in ../*.patch; do
msg "Apply $i"
patch -p1 < $i || return 1
@@ -47,6 +47,7 @@ build() {
--without-iconv --with-popt --with-z --with-newt \
--with-odbc --with-postgres --with-tds \
--with-dahdi --with-pri --with-tonezone \
+ --without-x11 \
|| return 1
# and figure out which modules to build
@@ -70,31 +71,31 @@ _find_and_move() {
}
pgsql() {
- depends="uclibc asterisk libpq zlib"
+ depends=""
install=
_find_and_move '*_pgsql*'
}
odbc() {
- depends="uclibc asterisk unixodbc"
+ depends=""
install=
_find_and_move '*odbc*'
}
tds() {
- depends="uclibc asterisk freetds"
+ depends=""
install=
_find_and_move '*_tds*'
}
-md5sums="1a44f295fc9e72d19da7f42d095e6c60 asterisk-1.6.2.0-beta1.tar.gz
+md5sums="53989aba01b046a67c6f7754d7a3abcd asterisk-1.6.2.0-beta3.tar.gz
97b39fd9777a2521d4f9f095482b7ac2 asterisk-01-1.6.0-gsm-pic.patch
-9f5d2412feea58ed49e2dff5cfd1fb8f asterisk-03-1.6.2.0-beta1-to-r186562.patch
+b00c9d98ce2ad445501248a197c6e436 asterisk-02-uclibc-daemon.patch
+39f12a80ee2ba70689d7ff244a2b20aa asterisk-03-1.6.2.0-beta3-to-svn-r202568.patch
929f740db7043b4553544ebcc7315c91 asterisk-04-1.6.0-beta7.1-caps-uclibc.patch
c37928e95ebef36aad097accfdbbfcb8 asterisk-05-1.6.1-glob-uclibc.patch
1b49f980e56dc7ce493a046eadff3545 asterisk-06-overlapped-enum.patch
-95bdc48553cc18c9d3807ac96956fc8a asterisk-07-issue14068.patch
-b00c9d98ce2ad445501248a197c6e436 200-uclibc-daemon.patch
+cc6a11b73f3ba7e98a621540c8e71542 asterisk-07-issue14068.patch
b4a97cb1ec3cc3f71a10ce8c067ab430 asterisk.pre-install
62ecffc90b6714b85f377d1fac73c58b asterisk.post-install
bbcd152417bb7c838b25cb6007db91da asterisk.initd