summaryrefslogtreecommitdiffstats
path: root/testing/check
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-12-22 22:47:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 12:29:30 +0000
commit23059b966e4169fc67b56e093630461fc93c1f35 (patch)
tree3be3c9d94a5f5a9e5660a1a8618c010658af49cc /testing/check
parentb158662a549e4af7388ff472237361676d43913f (diff)
downloadaports-23059b966e4169fc67b56e093630461fc93c1f35.tar.bz2
aports-23059b966e4169fc67b56e093630461fc93c1f35.tar.xz
Initial APKBUILD for check
Package description: Check is a unit test framework for C. It features a simple interface for defining unit tests, putting little in the way of the developer. Tests are run in a separate address space, so Check can catch both assertion failures and code errors that cause segmentation faults or other signals. The output from unit tests can be used within source code editors and IDEs. Website: http://check.sourceforge.net/
Diffstat (limited to 'testing/check')
-rw-r--r--testing/check/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/check/APKBUILD b/testing/check/APKBUILD
new file mode 100644
index 000000000..a5d2e2f17
--- /dev/null
+++ b/testing/check/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=check
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="A unit test framework for C"
+url="http://check.sourceforge.net/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="pkgconfig"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/check/check-$pkgver.tar.gz"
+_builddir="$srcdir"/check-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="5d75e9a6027cde79d2c339ef261e7470 check-0.9.8.tar.gz"