summaryrefslogtreecommitdiffstats
path: root/testing/chromium
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-11-22 20:26:52 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-11-22 20:26:52 -0600
commitd0301f9696ea6d97a146204a5033e84fa4e68831 (patch)
treea516e3628aee945cac8d098d2ae11e4876135636 /testing/chromium
parenta0b24b058a9660cbbc5c15018d77a29e9ddf7a06 (diff)
downloadaports-d0301f9696ea6d97a146204a5033e84fa4e68831.tar.bz2
aports-d0301f9696ea6d97a146204a5033e84fa4e68831.tar.xz
testing/v8: x86 build fix
Diffstat (limited to 'testing/chromium')
-rw-r--r--testing/chromium/APKBUILD66
1 files changed, 62 insertions, 4 deletions
diff --git a/testing/chromium/APKBUILD b/testing/chromium/APKBUILD
index b19ee388f..2adaf905f 100644
--- a/testing/chromium/APKBUILD
+++ b/testing/chromium/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Unmaintained <unmaintained@alpinelinux.org>
pkgname=chromium
-pkgver=13.0.754.0
+pkgver=17.0.942.0
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
@@ -12,8 +12,10 @@ depends=
depends_dev="alsa-lib-dev libevent-dev libpng-dev jpeg-dev cairo-dev cups-dev mesa-dev
dbus-glib-dev gtk+-dev libxml2-dev freetype-dev
libxslt-dev libxtst-dev icu-dev flac-dev speex-dev
- hunspell-dev libxinerama-dev"
-makedepends="$depends_dev xdg-utils yasm gperf"
+ hunspell-dev libxinerama-dev ffmpeg-dev nss-dev
+ libwebp-dev v8-dev bzip2-dev libevent-dev libvpx-dev
+ sqlite-dev"
+makedepends="$depends_dev xdg-utils yasm gperf elfutils bison flex"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://build.chromium.org/official/chromium-$pkgver.tar.bz2
@@ -36,6 +38,55 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+
+ msg "Stripping Google cruft..."
+ find third_party -type f \! -iname '*.gyp*' \
+ \! -path 'third_party/WebKit/*' \
+ \! -path 'third_party/angle/*' \
+ \! -path 'third_party/cacheinvalidation/*' \
+ \! -path 'third_party/cld/*' \
+ \! -path 'third_party/expat/*' \
+ \! -path 'third_party/ffmpeg/*' \
+ \! -path 'third_party/flac/flac.h' \
+ \! -path 'third_party/gpsd/*' \
+ \! -path 'third_party/harfbuzz/*' \
+ \! -path 'third_party/hunspell/*' \
+ \! -path 'third_party/iccjpeg/*' \
+ \! -path 'third_party/jsoncpp/*' \
+ \! -path 'third_party/launchpad_translations/*' \
+ \! -path 'third_party/leveldb/*' \
+ \! -path 'third_party/leveldatabase/*' \
+ \! -path 'third_party/libjingle/*' \
+ \! -path 'third_party/libphonenumber/*' \
+ \! -path 'third_party/libvpx/*' \
+ \! -path 'third_party/lss/*' \
+ \! -path 'third_party/mesa/*' \
+ \! -path 'third_party/modp_b64/*' \
+ \! -path 'third_party/mongoose/*' \
+ \! -path 'third_party/npapi/*' \
+ \! -path 'third_party/openmax/*' \
+ \! -path 'third_party/ots/*' \
+ \! -path 'third_party/protobuf/*' \
+ \! -path 'third_party/scons-2.0.1/*' \
+ \! -path 'third_party/sfntly/*' \
+ \! -path 'third_party/skia/*' \
+ \! -path 'third_party/smhasher/*' \
+ \! -path 'third_party/speex/speex.h' \
+ \! -path 'third_party/sqlite/*' \
+ \! -path 'third_party/tcmalloc/*' \
+ \! -path 'third_party/tlslite/*' \
+ \! -path 'third_party/undoview/*' \
+ \! -path 'third_party/v8-i18n/*' \
+ \! -path 'third_party/webdriver/*' \
+ \! -path 'third_party/webgl_conformance/*' \
+ \! -path 'third_party/webrtc/*' \
+ \! -path 'third_party/zlib/contrib/minizip/*' \
+ -delete || return 1
+
+ msg "Hacking source tree to use system V8 headers..."
+ find v8 -type f \! -iname '*.gyp*' -delete || return 1
+ rmdir v8/include || return 1
+ ln -s /usr/include v8/include || return 1
}
build() {
@@ -44,9 +95,11 @@ build() {
chromium_arch=ia32
test ${CARCH} = x86_64 && chromium_arch=x64
+ # enabling SSE2 causes psABI breakage.
msg "chromium architecture is ${chromium_arch}"
GYP_DEFINES="\
werror= \
+ disable_sse2=1 \
no_strict_aliasing=1 \
linux_sandbox_path=/usr/lib/${pkgname}/chromium-sandbox \
linux_sandbox_chrome_path=/usr/lib/${pkgname}/chromium \
@@ -61,7 +114,12 @@ build() {
use_system_yasm=1 \
use_system_libevent=1 \
use_system_icu=1 \
- use_system_ssl=0 \
+ use_system_v8=1 \
+ use_system_libwebp=1 \
+ use_system_ffmpeg=1 \
+ use_system_vpx=1 \
+ use_system_ssl=1 \
+ use_system_sqlite=1 \
use_gconf=0 \
use_gnome_keyring=0 \
remoting=0 \