summaryrefslogtreecommitdiffstats
path: root/testing/dnsenum
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-03 13:28:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-03 20:17:18 +0000
commit6ecd66852925c10bbea34168f1339cd9b8f0c654 (patch)
tree72db38e35158295f00fc726740c5ed65f4afbf0b /testing/dnsenum
parent0405a516497d73a866aff4c6ee123b034628b341 (diff)
downloadaports-6ecd66852925c10bbea34168f1339cd9b8f0c654.tar.bz2
aports-6ecd66852925c10bbea34168f1339cd9b8f0c654.tar.xz
Initial APKBUILD for dnsenum
Package description: The purpose of Dnsenum is to gather as much information as possible about a domain. The program currently performs the following operations: 1) Get the host's addresse (A record). 2) Get the namservers (threaded). 3) Get the MX record (threaded). 4) Perform axfr queries on nameservers and get BIND versions(threaded). 5) Get extra names and subdomains via google scraping (google query = "allinurl: -www site:domain"). 6) Brute force subdomains from file, can also perform recursion on subdomain that have NS records (all threaded). 7) Calculate C class domain network ranges and perform whois queries on them (threaded). 8) Perform reverse lookups on netranges ( C class or/and whois netranges). 9) Write to domain_ips.txt file ip-blocks.
Diffstat (limited to 'testing/dnsenum')
-rw-r--r--testing/dnsenum/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/dnsenum/APKBUILD b/testing/dnsenum/APKBUILD
new file mode 100644
index 000000000..1d9f1b04d
--- /dev/null
+++ b/testing/dnsenum/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=dnsenum
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A tool to enumerate DNS info about domains"
+url="http://code.google.com/p/dnsenum/"
+arch="noarch"
+license="GPL2+"
+depends="perl-net-ip perl-net-dns perl-net-netmask perl-xml-writer"
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 "$pkgname".pl "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+md5sums="d8806daddff880dcadf90af79720e7fe dnsenum-1.2.2.tar.gz"