summaryrefslogtreecommitdiffstats
path: root/testing/dovecot-deleted-to-trash-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-06 10:39:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-06 10:39:46 +0000
commit6d86bbdf79ff6ae352468c37a94e4ec954296e8a (patch)
tree5ce96cf097ad5d9189b9b0fa16a0706e3263a8de /testing/dovecot-deleted-to-trash-plugin
parentf7822ba83617fdd806ae6e4d2dfef3f5a008891c (diff)
downloadaports-6d86bbdf79ff6ae352468c37a94e4ec954296e8a.tar.bz2
aports-6d86bbdf79ff6ae352468c37a94e4ec954296e8a.tar.xz
testing/dovecot-deleted-to-trash-plugin: new aport
Copy deleted email to trash for broken IMAP clients (Outlook) http://wiki2.dovecot.org/Plugins/deleted-to-trash
Diffstat (limited to 'testing/dovecot-deleted-to-trash-plugin')
-rw-r--r--testing/dovecot-deleted-to-trash-plugin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/dovecot-deleted-to-trash-plugin/APKBUILD b/testing/dovecot-deleted-to-trash-plugin/APKBUILD
new file mode 100644
index 000000000..12c706980
--- /dev/null
+++ b/testing/dovecot-deleted-to-trash-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dovecot-deleted-to-trash-plugin
+pkgver=0.3
+pkgrel=0
+pkgdesc="Copy deleted email to trash for broken IMAP clients (Outlook)"
+url="http://wiki2.dovecot.org/Plugins/deleted-to-trash"
+arch="all"
+license="unknown"
+depends=""
+makedepends="dovecot-dev"
+install=""
+subpackages=""
+source="http://dev.alpinelinux.org/archive/dovecot-deleted-to-trash-plugin/dovecot-deleted-to-trash-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/dovecot-deleted-to-trash-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="63bdfa71312abc2dcaae5cfedd1db622 dovecot-deleted-to-trash-plugin-0.3.tar.bz2"