summaryrefslogtreecommitdiffstats
path: root/testing/eio
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-23 12:31:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-23 12:31:29 +0000
commit0cd8a13ed16a8fac18f4dea203aeb25e80de515a (patch)
tree76f487ead39dbaf2edf52257b257e0aa0a3164a5 /testing/eio
parent3bb97ad5560cddd7b5c78d79df4a338ce65a696f (diff)
downloadaports-0cd8a13ed16a8fac18f4dea203aeb25e80de515a.tar.bz2
aports-0cd8a13ed16a8fac18f4dea203aeb25e80de515a.tar.xz
testing/eio: new aport
Eio, async I/O library http://trac.enlightenment.org/e/wiki/Eina
Diffstat (limited to 'testing/eio')
-rw-r--r--testing/eio/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/eio/APKBUILD b/testing/eio/APKBUILD
new file mode 100644
index 000000000..e65331c0a
--- /dev/null
+++ b/testing/eio/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=eio
+pkgver=1.7.4
+pkgrel=0
+pkgdesc="Eio, async I/O library"
+url="http://trac.enlightenment.org/e/wiki/Eina"
+arch="all"
+license="LGPLv2.1"
+depends=
+depends_dev="eet-dev eina-dev ecore-dev"
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/eio-$pkgver.tar.gz"
+
+_builddir="$srcdir"/eio-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="f2e4b4e4c04e83bc9533ef7938b51218 eio-1.7.4.tar.gz"