summaryrefslogtreecommitdiffstats
path: root/testing/emotion
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-23 12:41:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-23 12:41:57 +0000
commit22a8ad3e3b379755b324575f3230132396508752 (patch)
tree858df305260c5d802c3e96fdef95b4c728666b92 /testing/emotion
parent5c59506bd9106786bf2af5f9ef4e9d08d3c4aca5 (diff)
downloadaports-22a8ad3e3b379755b324575f3230132396508752.tar.bz2
aports-22a8ad3e3b379755b324575f3230132396508752.tar.xz
testing/emotion: new aport
Emotion, video and audio codec API http://trac.enlightenment.org/e/wiki/Emotion
Diffstat (limited to 'testing/emotion')
-rw-r--r--testing/emotion/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/emotion/APKBUILD b/testing/emotion/APKBUILD
new file mode 100644
index 000000000..1af028ea9
--- /dev/null
+++ b/testing/emotion/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=emotion
+pkgver=1.7.4
+pkgrel=0
+pkgdesc="Emotion, video and audio codec API"
+url="http://trac.enlightenment.org/e/wiki/Emotion"
+arch="all"
+license="BSD"
+depends=
+depends_dev="ecore-dev evas-dev eet-dev eina-dev edje-dev eio-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/emotion-$pkgver.tar.gz"
+
+_builddir="$srcdir"/emotion-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir"/usr/lib/ -name '*.la' -delete
+}
+
+md5sums="402e1da5f5281607585c860012200b49 emotion-1.7.4.tar.gz"