summaryrefslogtreecommitdiffstats
path: root/testing/etherdump
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-15 19:20:13 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commit3f14327ad4270b6475c6ccbfb44b49e8ed9dbdd2 (patch)
tree4cd9271fc98766ff298283cbbb77cdbe2201c5a6 /testing/etherdump
parent6b6688c7f490e9455d3ac6c3d30c493e8e210fbe (diff)
downloadaports-3f14327ad4270b6475c6ccbfb44b49e8ed9dbdd2.tar.bz2
aports-3f14327ad4270b6475c6ccbfb44b49e8ed9dbdd2.tar.xz
Initial APKBUILD for etherdump
Package description: etherdump is an extremely small packet sniffer. It can be used to dump raw ethernet frames for parsing (optimally with Ethereal's text2pcap), or for viewing the network traffic of a few common TCP/IP protocols. On a uClibc system a dynamically-linked version is about 8kB and a statically linked version is about 30kB because it does not depend on libpcap.
Diffstat (limited to 'testing/etherdump')
-rw-r--r--testing/etherdump/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/etherdump/APKBUILD b/testing/etherdump/APKBUILD
new file mode 100644
index 000000000..6dacf2ce6
--- /dev/null
+++ b/testing/etherdump/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=etherdump
+pkgver=2.10
+pkgrel=0
+pkgdesc="An extremely small packet sniffer"
+url="http://freshmeat.net/projects/etherdump/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://sourceforge.net/projects/psydev/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 "$pkgname" "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+md5sums="b207b74a9e1fa945dcd0b55725384c8b etherdump-2.10.tar.gz"