summaryrefslogtreecommitdiffstats
path: root/testing/fetch-crl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-26 09:34:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-26 20:15:50 +0000
commit1c7db7ad0c3106efda8c3c87b86b757454681ba0 (patch)
tree76746843fa9f832240e4896ed632795c7d2ab6a0 /testing/fetch-crl
parenteb57d8bfd057ac52cd8210d581c5ebdee883358c (diff)
downloadaports-1c7db7ad0c3106efda8c3c87b86b757454681ba0.tar.bz2
aports-1c7db7ad0c3106efda8c3c87b86b757454681ba0.tar.xz
testing/fetch-crl: added patch for bb wget support
if WGET_RETRIES WGET_TIMEOUT or WGET_TIMESTAMPING is set you'll need GNU wget.
Diffstat (limited to 'testing/fetch-crl')
-rw-r--r--testing/fetch-crl/APKBUILD10
-rw-r--r--testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch41
2 files changed, 48 insertions, 3 deletions
diff --git a/testing/fetch-crl/APKBUILD b/testing/fetch-crl/APKBUILD
index 5d1bf5d94..accba3cb4 100644
--- a/testing/fetch-crl/APKBUILD
+++ b/testing/fetch-crl/APKBUILD
@@ -2,21 +2,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetch-crl
pkgver=2.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to keep Certificate Revocation Lists (CRLs) up-to-date"
url="http://dist.eugridpma.info/distribution/util/fetch-crl/"
license="custom"
subpackages="$pkgname-doc"
source="
http://dist.eugridpma.info/distribution/util/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-2.7.0-bb-wget.patch
"
build() {
cd "$srcdir/$pkgname-$pkgver"
- sed -i -e 's:etc/sysconfig:etc/conf.d:g' \
+ sed -i -e 's:etc/sysconfig:etc/fetch-crl:g' \
edg-fetch-crl fetch-crl.cron fetch-crl.8
sed -i -e 's:bin/bash:bin/sh:' fetch-crl.cron
+ patch -p1 -i "$srcdir"/$pkgname-2.7.0-bb-wget.patch || return 1
+
_r=$pkgname-$pkgver
install -m755 -D edg-fetch-crl "$pkgdir"/usr/sbin/fetch-crl
@@ -28,4 +31,5 @@ build() {
install -m755 -D fetch-crl.cron "$pkgdir"/usr/share/doc/$_r/fetch-crl.periodic
}
-md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz"
+md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz
+613e4987db52cbd231cd4d7a46070d74 fetch-crl-2.7.0-bb-wget.patch"
diff --git a/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch b/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch
new file mode 100644
index 000000000..48fa7457e
--- /dev/null
+++ b/testing/fetch-crl/fetch-crl-2.7.0-bb-wget.patch
@@ -0,0 +1,41 @@
+--- fetch-crl-2.7.0/edg-fetch-crl.orig 2009-02-26 08:54:17 +0000
++++ fetch-crl-2.7.0/edg-fetch-crl 2009-02-26 09:20:27 +0000
+@@ -94,8 +94,8 @@
+ allWarnings=no # warnings follow verbosity
+
+ # get defaults
+-WGET_RETRIES=2
+-WGET_TIMEOUT=10
++#WGET_RETRIES=2
++#WGET_TIMEOUT=10
+ FETCH_CRL_SYSCONFIG="${FETCH_CRL_SYSCONFIG:-/etc/fetch-crl/fetch-crl}"
+
+ # specific work-around for incidental filesystem corruption
+@@ -149,7 +149,15 @@
+ fi
+
+ # add the other default arguments
+- wgetOptions="${wgetOptions} -t $WGET_RETRIES -T $WGET_TIMEOUT "
++ if [ -n "$WGET_RETRIES" ]; then
++ wgetOptions="${wgetOptions} -t $WGET_RETRIES "
++ fi
++ if [ -n "$WGET_TIMEOUT" ]; then
++ wgetOptions="${wgetOptions} -T $WGET_TIMEOUT "
++ fi
++ if [ -n "$WGET_TIMESTAMPING" ] && [ "$WGET_TIMESTAMPING" != "no" ]; then
++ wgetOptions="${wgetOptions} -N "
++ fi
+
+ # only add "-q" if the extra options do not have a -v. They are exclusive
+ expr match "${wgetAdditionalOptions}" '.*-v' >/dev/null 2>&1
+@@ -175,8 +183,8 @@
+ ${rm} -f "${cacheDirectory}/${hash}/pre"
+ ${cp} "${cacheDirectory}/${hash}/"* \
+ "${cacheDirectory}/${hash}/pre" >/dev/null 2>&1
+- PrintDebug ${wget} ${wgetOptions} -N -P "${cacheDirectory}/${hash}" "${url}"
+- ${wget} ${wgetOptions} -N -P "${cacheDirectory}/${hash}" "${url}"
++ PrintDebug ${wget} ${wgetOptions} -P "${cacheDirectory}/${hash}" "${url}"
++ ${wget} ${wgetOptions} -P "${cacheDirectory}/${hash}" "${url}"
+ rc=$?
+ if [ $rc -ne 0 ]; then
+ PrintWarning "RetrieveFileByURL: wget download error $rc for ${url}"