summaryrefslogtreecommitdiffstats
path: root/testing/fetch-crl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-04 14:03:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-04 14:03:48 +0000
commit8e16459a23c1c8801e5193bdc954faa08d210333 (patch)
tree264e2e1ea2290fa2e526f0e7c9bb41e0fc52e141 /testing/fetch-crl
parent5d089d56afa69c5e97437633c6dd2a655153974b (diff)
downloadaports-8e16459a23c1c8801e5193bdc954faa08d210333.tar.bz2
aports-8e16459a23c1c8801e5193bdc954faa08d210333.tar.xz
testing/fetch-crl: new aport
Tool to keep Certificate Revocation Lists (CRLs) up-to-date http://dist.eugridpma.info/distribution/util/fetch-crl/
Diffstat (limited to 'testing/fetch-crl')
-rw-r--r--testing/fetch-crl/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/fetch-crl/APKBUILD b/testing/fetch-crl/APKBUILD
new file mode 100644
index 000000000..a5bcb2bd5
--- /dev/null
+++ b/testing/fetch-crl/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fetch-crl
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="Tool to keep Certificate Revocation Lists (CRLs) up-to-date"
+url="http://dist.eugridpma.info/distribution/util/fetch-crl/"
+license="custom"
+subpackages="$pkgname-doc"
+source="
+ http://dist.eugridpma.info/distribution/util/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i -e 's:etc/sysconfig:etc/conf.d:g' \
+ edg-fetch-crl fetch-crl.cron fetch-crl.8
+ sed -i -e 's:bin/bash:bin/sh:' fetch-crl.cron
+
+ _r=$pkgname-$pkgver
+ install -m755 -D edg-fetch-crl "$pkgdir"/usr/sbin/fetch-crl
+ install -m644 -D fetch-crl.sysconfig "$pkgdir"/etc/conf.d/fetch-crl
+
+ install -m644 -D fetch-crl.8 "$pkgdir"/usr/share/man/man8/fetch-crl.8
+ install -m644 README "$pkgdir"/usr/share/doc/$_r/README
+ install -m644 CHANGES "$pkgdir"/usr/share/doc/$_r/CHANGES
+ install -m755 -D fetch-crl.cron "$pkgdir"/usr/share/doc/$_r/fetch-crl.periodic
+}
+
+md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz"