summaryrefslogtreecommitdiffstats
path: root/testing/freeradius/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-01 11:32:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-01 11:32:47 +0000
commit446e780e3df73cba0be025507947d9d5f6eda025 (patch)
treebaed73fb0c72b6c8b2b2f6976c488c9330c7febc /testing/freeradius/APKBUILD
parent5fd9a0bceef19f9be172b4a1811711fa52dd6602 (diff)
downloadaports-446e780e3df73cba0be025507947d9d5f6eda025.tar.bz2
aports-446e780e3df73cba0be025507947d9d5f6eda025.tar.xz
testing/freeradius: upgrade to 2.1.10
fixes #439
Diffstat (limited to 'testing/freeradius/APKBUILD')
-rw-r--r--testing/freeradius/APKBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/testing/freeradius/APKBUILD b/testing/freeradius/APKBUILD
index 8d5caa8ba..8715e6685 100644
--- a/testing/freeradius/APKBUILD
+++ b/testing/freeradius/APKBUILD
@@ -1,8 +1,8 @@
# Contributor:
# Maintainer:
pkgname=freeradius
-pkgver=2.1.7
-pkgrel=2
+pkgver=2.1.10
+pkgrel=0
pkgdesc="RADIUS (Remote Authentication Dial-In User Service) server"
url="http://freeradius.org/"
license="GPL"
@@ -17,34 +17,41 @@ subpackages="$pkgname-doc $pkgname-dev"
source="ftp://ftp.freeradius.org/pub/freeradius/$pkgname-server-$pkgver.tar.gz
freeradius.confd
freeradius.initd
- 0001-Fix-detection-of-TLS-for-uClibc.patch
- freeradius-2.1.6-nothreads.patch
freeradius-2.1.7-pkglibdir.patch
"
-build() {
- cd "$srcdir/$pkgname-server-$pkgver"
+_builddir="$srcdir"/$pkgname-server-$pkgver
+
+prepare() {
+ cd "$_builddir"
for i in ../*.patch; do
msg "Applying $i"
patch -p1 -i $i || return 1
done
aclocal && ./autogen.sh || return 1
+}
- export CONFIG_SHELL=/bin/bash
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-static \
+ --enable-shared \
+ --disable-ltdl-install \
+ --with-system-libltdl \
+ --with-system-libtool \
|| return 1
-# # the configure script fails to detect that we dont have TLS
-# sed -i -e '/^\#define HAVE_THREAD_TLS/d' src/include/autoconf.h \
-# || return 1
-
+ # workaround parallel build issue
make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
install -d -m0750 -o root -g radiusd "$pkgdir"/etc/raddb
install -d -m0750 -o root -g radiusd "$pkgdir"/var/run/radius
install -d -m0750 -o root -g radiusd "$pkgdir"/var/log/radius
@@ -60,9 +67,7 @@ build() {
}
-md5sums="b1f77c5e3116bcb0ac0aa9080a06ebf1 freeradius-server-2.1.7.tar.gz
+md5sums="e552704fc1b46d51176e575afa96dcc6 freeradius-server-2.1.10.tar.gz
fc6693f3df5a0694610110287a28568a freeradius.confd
b22092fcdcb61d7f0b8e13a007c444c5 freeradius.initd
-2e39f10c814bc7e1172c4cb2d178b39b 0001-Fix-detection-of-TLS-for-uClibc.patch
-1e04786d3f626200999f53471c19ac47 freeradius-2.1.6-nothreads.patch
4c8af50e174d392c0210cbf494cd15cd freeradius-2.1.7-pkglibdir.patch"