summaryrefslogtreecommitdiffstats
path: root/testing/gitolite
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-06-08 09:42:18 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-06-08 10:01:59 +0200
commit1fa277477ab6b71b8af8d1a2808fbfc071028b37 (patch)
treef7273621b0154f38912dd18db1e6c4ce3db86825 /testing/gitolite
parentaa2dee7daff1b6bec4a0fe1e7a6baf82ac3fbafe (diff)
downloadaports-1fa277477ab6b71b8af8d1a2808fbfc071028b37.tar.bz2
aports-1fa277477ab6b71b8af8d1a2808fbfc071028b37.tar.xz
testing/gitolite: upgrade to 3.03
Diffstat (limited to 'testing/gitolite')
-rw-r--r--testing/gitolite/APKBUILD57
-rw-r--r--testing/gitolite/configuration.patch27
2 files changed, 17 insertions, 67 deletions
diff --git a/testing/gitolite/APKBUILD b/testing/gitolite/APKBUILD
index 673f0d6bd..3a4eab3f9 100644
--- a/testing/gitolite/APKBUILD
+++ b/testing/gitolite/APKBUILD
@@ -1,47 +1,24 @@
+# Maintainer: Bartłomiej Pioteowski <nospam@bpiotrowski.pl>
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+
pkgname=gitolite
-pkgver=2.1
+pkgver=3.03
pkgrel=0
-pkgdesc="A centralized git server, with very fine-grained access control and many powerful features."
-url="http://github.com/sitaramc/gitolite"
-arch="noarch"
-license="GPL2"
-depends="git perl"
-depends_dev=""
-makedepends="$depends_dev wget"
-install=""
-subpackages="$pkgname-doc"
-source="saveas-https://github.com/sitaramc/gitolite/tarball/v2.1/gitolite-2.1.tar.gz
- configuration.patch"
-
-_builddir="$srcdir"/sitaramc-gitolite-871ed28
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
-}
+pkgdesc='A centralized git server, with very fine-grained access control and many powerful features.'
+url='http://github.com/sitaramc/gitolite'
+arch='noarch'
+license='GPL2'
+depends='git perl'
+#TODO: subpackages="$pkgname-doc"
+source="https://github.com/sitaramc/$pkgname/tarball/v${pkgver}/$pkgname-$pkgver.tar.gz"
package() {
- cd "$_builddir"
- mkdir -p "$pkgdir"/usr/bin \
- "$pkgdir"/etc/gitolite \
- "$pkgdir"/usr/share/gitolite/hooks \
- "$pkgdir"/usr/share/doc/gitolite
- mv src/* "$pkgdir"/usr/bin/
- mv conf/* "$pkgdir"/etc/gitolite/
- mv hooks/* "$pkgdir"/usr/share/gitolite/hooks/
- mv doc/* "$pkgdir"/usr/share/doc/gitolite/
+ cd "$srcdir"/sitaramc-gitolite-*
+
+ install -d "$pkgdir"/usr/lib/gitolite || return 1
+ install -d "${pkgdir}"/usr/bin || return 1
+ ./install -to "${pkgdir}"/usr/lib/gitolite || return 1
+ ln -s /usr/lib/gitolite/gitolite ${pkgdir}/usr/bin/ || return 1
}
-md5sums="33e0f6f384cf0596aed974fa563b50c3 gitolite-2.1.tar.gz
-b4603bb37d3a746a1508bd7528464ba4 configuration.patch"
+md5sums="5b66437e362e610595ad1d1b099e0812 gitolite-3.03.tar.gz"
diff --git a/testing/gitolite/configuration.patch b/testing/gitolite/configuration.patch
deleted file mode 100644
index 403dc4e26..000000000
--- a/testing/gitolite/configuration.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/conf/example.gitolite.rc b/conf/example.gitolite.rc
-index d800357..95c5a24 100644
---- a/conf/example.gitolite.rc
-+++ b/conf/example.gitolite.rc
-@@ -19,8 +19,8 @@ $GL_CONF_COMPILED="$GL_ADMINDIR/conf/gitolite.conf-compiled.pm";
- # DO NOT CHANGE THE NEXT FOUR LINES UNLESS YOU REALLY KNOW WHAT YOU'RE DOING.
- # These variables are set automatically by the install method you choose.
- # (PACKAGE MAINTAINERS: PLEASE READ doc/packaging.mkd)
--# $GL_PACKAGE_CONF = "";
--# $GL_PACKAGE_HOOKS = "";
-+$GL_PACKAGE_CONF = "/etc/gitolite";
-+$GL_PACKAGE_HOOKS = "/usr/share/gitolite/hooks";
-
- # ------------------------------------------------------------------------------
- # most often used/changed variables
-diff --git a/src/gl-setup b/src/gl-setup
-index fd8357b..59de183 100755
---- a/src/gl-setup
-+++ b/src/gl-setup
-@@ -1,6 +1,6 @@
- #!/bin/sh
-
--GL_PACKAGE_CONF=/tmp/share/gitolite/conf
-+GL_PACKAGE_CONF=/etc/gitolite
- # must be the same as the value for the same variable in
- # $GL_PACKAGE_CONF/example.gitolite.rc. Sorry about the catch-22 :)
-