summaryrefslogtreecommitdiffstats
path: root/testing/ices
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-17 08:35:39 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-17 08:35:39 +0000
commitb011c6968562d203256ee5c8320ffbdca8cb0dcf (patch)
treea85cc00876b335bf88e92a6f5fae69c29311c8b5 /testing/ices
parent184643ed8e56114696c685947be7bd2a5e25f7a9 (diff)
downloadaports-b011c6968562d203256ee5c8320ffbdca8cb0dcf.tar.bz2
aports-b011c6968562d203256ee5c8320ffbdca8cb0dcf.tar.xz
testing/ices : added conf file
Diffstat (limited to 'testing/ices')
-rw-r--r--testing/ices/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/ices/APKBUILD b/testing/ices/APKBUILD
new file mode 100644
index 000000000..51ec809eb
--- /dev/null
+++ b/testing/ices/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=ices
+pkgver=0.4
+pkgrel=0
+pkgdesc="Source client for broadcasting in MP3 format to an icecast2 server"
+url="http://icecast.org/ices.php"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="libogg-dev libxml2-dev libvorbis-dev libshout-dev alsa-lib-dev lame-dev perl-dev python-dev libxml2-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.us.xiph.org/releases/ices/$pkgname-$pkgver.tar.gz"
+_builddir=$srcdir/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-lame \
+ --with-vorbis \
+ --with-python \
+ --with-perl
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D conf/$pkgname.conf.dist "$pkgdir"/etc/$pkgname/$pkgname.conf
+}
+
+md5sums="d31450c4011561dae0229f071cb41cb6 ices-0.4.tar.gz"