summaryrefslogtreecommitdiffstats
path: root/testing/keepalived/APKBUILD
diff options
context:
space:
mode:
authorPablo Castorino <pcastorino@mendoza-conicet.gob.ar>2010-12-27 14:51:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-28 13:52:48 +0000
commit9010f45d39cb7eb566227bd5259a9bbc6436d5d1 (patch)
tree2a49809cca3d34bc8d3b30191fac836e831d2174 /testing/keepalived/APKBUILD
parent165f16e48c93875e1141c734ffde07c9e39c01db (diff)
downloadaports-9010f45d39cb7eb566227bd5259a9bbc6436d5d1.tar.bz2
aports-9010f45d39cb7eb566227bd5259a9bbc6436d5d1.tar.xz
testing/keepalived: new aport
Diffstat (limited to 'testing/keepalived/APKBUILD')
-rw-r--r--testing/keepalived/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/testing/keepalived/APKBUILD b/testing/keepalived/APKBUILD
new file mode 100644
index 000000000..dbe3adc5c
--- /dev/null
+++ b/testing/keepalived/APKBUILD
@@ -0,0 +1,62 @@
+# This is an example APKBUILD file. Use this as a start to creating your own,
+# and remove these comments.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Pablo Castorino <pcastorino@mendoza-conicet.gob.ar>
+# Maintainer: Pablo Castorino <pcastorino@mendoza-conicet.gob.ar>
+pkgname=keepalived
+pkgver=1.1.20
+pkgrel=0
+pkgdesc="Health Checking for Linux Virtual Server & High-Availability"
+url="http://www.keepalived.org/"
+license="GPL"
+depends=
+makedepends="openssl-dev popt-dev linux-headers"
+install=
+subpackages="$pkgname-doc"
+source="http://www.keepalived.org/software/$pkgname-$pkgver.tar.gz
+ keepalived-1.1.20-ipvs_haeader_check.patch
+ $pkgname.initd
+ $pkgname.confd
+ "
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-kernel-dir=/usr/include/linux \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="6c3065c94bb9e2187c4b5a80f6d8be31 keepalived-1.1.20.tar.gz
+78c19e15f649e353c2fba44e1f70b1e1 keepalived-1.1.20-ipvs_haeader_check.patch
+d20faa8d55b8a41b8ddb71bb00a6bead keepalived.initd
+56ff68ad19e973826c2dbc42c892939f keepalived.confd"