summaryrefslogtreecommitdiffstats
path: root/testing/libmng
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-17 20:42:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-17 20:42:56 +0000
commit849eadb672f5036b311955b10543b14ce40476e1 (patch)
tree3d9c49769d8e1e8a550034845d070915d5a0018e /testing/libmng
parent46ea5efd6f5548be6b7ea4aad3af5684e0fefcd2 (diff)
downloadaports-849eadb672f5036b311955b10543b14ce40476e1.tar.bz2
aports-849eadb672f5036b311955b10543b14ce40476e1.tar.xz
teseting/libmng: new aport
A collection of routines used to create and manipulate MNG format graphics files http://www.libmng.com/
Diffstat (limited to 'testing/libmng')
-rw-r--r--testing/libmng/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libmng/APKBUILD b/testing/libmng/APKBUILD
new file mode 100644
index 000000000..e9da11cb2
--- /dev/null
+++ b/testing/libmng/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmng
+pkgver=1.0.10
+pkgrel=0
+pkgdesc="A collection of routines used to create and manipulate MNG format graphics files"
+url="http://www.libmng.com/"
+license="custom"
+depends=""
+depends_dev="jpeg-dev"
+makedepends="zlib-dev jpeg-dev autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/libmng/libmng-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ ln -s makefiles/configure.in .
+ ln -s makefiles/Makefile.am .
+ autoreconf --force --install
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="a464ae7d679781beebdf7440d144b7bd libmng-1.0.10.tar.gz"