summaryrefslogtreecommitdiffstats
path: root/testing/libvirt
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-12-14 08:00:01 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-12-14 08:00:27 +0000
commita6526fe70a6b61239789cc9b4fc730b927c5ecd6 (patch)
tree8997e6273f130724415f001a0799813b258270b0 /testing/libvirt
parent5006297519a265441543ae132dda9e6040527725 (diff)
downloadaports-a6526fe70a6b61239789cc9b4fc730b927c5ecd6.tar.bz2
aports-a6526fe70a6b61239789cc9b4fc730b927c5ecd6.tar.xz
testing/libvirt: upgrade to 0.8.6
Diffstat (limited to 'testing/libvirt')
-rw-r--r--testing/libvirt/APKBUILD18
-rw-r--r--testing/libvirt/fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch117
2 files changed, 127 insertions, 8 deletions
diff --git a/testing/libvirt/APKBUILD b/testing/libvirt/APKBUILD
index 19b8edf8d..f1e6a5133 100644
--- a/testing/libvirt/APKBUILD
+++ b/testing/libvirt/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname=libvirt
-pkgver=0.8.5
+pkgver=0.8.6
pkgrel=0
pkgdesc="A virtualization API for several hypervisor and container systems"
url="http://libvirt.org/"
@@ -13,14 +13,15 @@ install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://libvirt.org/sources/$pkgname-$pkgver.tar.gz
libvirt.confd
- libvirt.initd"
+ libvirt.initd
+ fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch"
_builddir="$srcdir"/$pkgname-$pkgver
-#prepare() {
-# cd "$_builddir"
-# # apply patches here
-#}
+prepare() {
+ cd "$_builddir"
+ patch -p1 < ../fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch || return 1
+}
build() {
cd "$_builddir"
@@ -39,6 +40,7 @@ package() {
install -D -m755 $srcdir/$pkgname.confd $pkgdir/etc/conf.d/libvirtd
}
-md5sums="92a96b3e534209a6103fa7a4bee9fbc1 libvirt-0.8.5.tar.gz
+md5sums="9ed61a02983dc42d0ea0224711ace025 libvirt-0.8.6.tar.gz
1c84a7baeafe0a7f4e9d7ae5180311b7 libvirt.confd
-3d32c12642cb9a84baf019c7b0971755 libvirt.initd"
+3d32c12642cb9a84baf019c7b0971755 libvirt.initd
+85045a97007ecd6355d4d79251f5051b fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch"
diff --git a/testing/libvirt/fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch b/testing/libvirt/fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch
new file mode 100644
index 000000000..c00d38bd1
--- /dev/null
+++ b/testing/libvirt/fix_undefined_symbol_error_when_macvtap_support_is_disabled.patch
@@ -0,0 +1,117 @@
+diff --git a/src/libvirt_macvtap.syms b/src/libvirt_macvtap.syms
+index 107b7da..b48565b 100644
+--- a/src/libvirt_macvtap.syms
++++ b/src/libvirt_macvtap.syms
+@@ -1,9 +1,10 @@
+ #
++# These symbols are dependent on WITH_MACVTAP.
++#
++
+
+ # macvtap.h
+ delMacvtap;
+ openMacvtapTap;
+-virVMOperationTypeFromString;
+-virVMOperationTypeToString;
+ vpAssociatePortProfileId;
+ vpDisassociatePortProfileId;
+diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
+index 310d8f4..3c1c823 100644
+--- a/src/libvirt_private.syms
++++ b/src/libvirt_private.syms
+@@ -504,6 +504,11 @@ virLogStartup;
+ virLogUnlock;
+
+
++# macvtap.h
++virVMOperationTypeFromString;
++virVMOperationTypeToString;
++
++
+ # memory.h
+ virAlloc;
+ virAllocN;
+diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
+index fcb90a3..aa3478f 100644
+--- a/src/qemu/qemu_driver.c
++++ b/src/qemu/qemu_driver.c
+@@ -11879,6 +11879,7 @@ cleanup:
+ return ret;
+ }
+
++#if WITH_MACVTAP
+ static void
+ qemudVPAssociatePortProfiles(virDomainDefPtr def) {
+ int i;
+@@ -11913,6 +11914,7 @@ err_exit:
+ }
+ }
+ }
++#endif /* WITH_MACVTAP */
+
+ /* Finish is the third and final step, and it runs on the destination host. */
+ static virDomainPtr
+@@ -11974,7 +11976,9 @@ qemudDomainMigrateFinish2 (virConnectPtr dconn,
+ goto cleanup;
+ }
+
++#if WITH_MACVTAP
+ qemudVPAssociatePortProfiles(vm->def);
++#endif /* WITH_MACVTAP */
+
+ if (flags & VIR_MIGRATE_PERSIST_DEST) {
+ if (vm->persistent)
+diff --git a/src/util/macvtap.h b/src/util/macvtap.h
+index 389d1fd..3ae2c24 100644
+--- a/src/util/macvtap.h
++++ b/src/util/macvtap.h
+@@ -57,11 +57,6 @@ struct _virVirtualPortProfileParams {
+ } u;
+ };
+
+-
+-# if defined(WITH_MACVTAP)
+-
+-# include "internal.h"
+-
+ enum virVMOperationType {
+ VIR_VM_OP_CREATE,
+ VIR_VM_OP_SAVE,
+@@ -75,6 +70,10 @@ enum virVMOperationType {
+ VIR_VM_OP_LAST
+ };
+
++# if WITH_MACVTAP
++
++# include "internal.h"
++
+ int openMacvtapTap(const char *ifname,
+ const unsigned char *macaddress,
+ const char *linkdev,
+@@ -90,11 +89,9 @@ void delMacvtap(const char *ifname,
+ const char *linkdev,
+ virVirtualPortProfileParamsPtr virtPortProfile);
+
+-# endif /* WITH_MACVTAP */
+-
+-# define MACVTAP_MODE_PRIVATE_STR "private"
+-# define MACVTAP_MODE_VEPA_STR "vepa"
+-# define MACVTAP_MODE_BRIDGE_STR "bridge"
++# define MACVTAP_MODE_PRIVATE_STR "private"
++# define MACVTAP_MODE_VEPA_STR "vepa"
++# define MACVTAP_MODE_BRIDGE_STR "bridge"
+
+ int vpAssociatePortProfileId(const char *macvtap_ifname,
+ const unsigned char *macvtap_macaddr,
+@@ -109,6 +106,8 @@ int vpDisassociatePortProfileId(const char *macvtap_ifname,
+ const virVirtualPortProfileParamsPtr virtPort,
+ enum virVMOperationType vmOp);
+
++# endif /* WITH_MACVTAP */
++
+ VIR_ENUM_DECL(virVirtualPort)
+ VIR_ENUM_DECL(virVMOperation)
+
+--
+1.7.0.4
+