summaryrefslogtreecommitdiffstats
path: root/testing/libx86
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-26 08:57:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-26 08:57:34 +0000
commit0c5ec46423f591c5d03125ec2e7f51442823a85a (patch)
treed0b68a202892cf6852eb1703a9d10f2106865c1e /testing/libx86
parentb5574acc6732b7d7eb5f78d0246e6ae15b0e282a (diff)
downloadaports-0c5ec46423f591c5d03125ec2e7f51442823a85a.tar.bz2
aports-0c5ec46423f591c5d03125ec2e7f51442823a85a.tar.xz
testing/libx86: new aport
Library for making real-mode x86 calls http://www.codon.org.uk/~mjg59/libx86 ref #960
Diffstat (limited to 'testing/libx86')
-rw-r--r--testing/libx86/APKBUILD44
-rw-r--r--testing/libx86/libx86-add-pkgconfig.patch64
-rw-r--r--testing/libx86/libx86-mmap-offset.patch187
3 files changed, 295 insertions, 0 deletions
diff --git a/testing/libx86/APKBUILD b/testing/libx86/APKBUILD
new file mode 100644
index 000000000..cfd63e3f7
--- /dev/null
+++ b/testing/libx86/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libx86
+pkgver=1.1
+pkgrel=0
+pkgdesc="Library for making real-mode x86 calls"
+url="http://www.codon.org.uk/~mjg59/libx86"
+arch="x86 x86_64"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.codon.org.uk/~mjg59/libx86/downloads/libx86-$pkgver.tar.gz
+ libx86-add-pkgconfig.patch
+ libx86-mmap-offset.patch
+ "
+
+_builddir="$srcdir"/libx86-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make BACKEND=x86emu || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="41bee1f8e22b82d82b5f7d7ba51abc2a libx86-1.1.tar.gz
+7958f84486ebe60cebd85ae3807c5e58 libx86-add-pkgconfig.patch
+cfa7e8b178d2d14431dc0c3e9d5f842d libx86-mmap-offset.patch"
diff --git a/testing/libx86/libx86-add-pkgconfig.patch b/testing/libx86/libx86-add-pkgconfig.patch
new file mode 100644
index 000000000..3aeaff791
--- /dev/null
+++ b/testing/libx86/libx86-add-pkgconfig.patch
@@ -0,0 +1,64 @@
+From fc4f25c4d16aaff7dcb5dd42cc20b292f4eb2218 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Tue, 4 Aug 2009 13:08:42 +1000
+Subject: [PATCH] git add x86.pc
+
+---
+ Makefile | 15 ++++++++++++---
+ x86.pc.in | 10 ++++++++++
+ 2 files changed, 22 insertions(+), 3 deletions(-)
+ create mode 100644 x86.pc.in
+
+diff --git a/Makefile b/Makefile
+index 951b617..953a499 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,7 @@
+ OBJECTS = x86-common.o
+ CFLAGS ?= -O2 -Wall -DDEBUG -g
+ LIBDIR ?= /usr/lib
++INCLUDEDIR ?= /usr/include
+
+ ifeq ($(BACKEND),x86emu)
+ OBJECTS += thunk.o x86emu/decode.o x86emu/debug.o x86emu/fpu.o \
+@@ -29,10 +30,18 @@ objclean:
+ rm -f *.o *~
+
+ clean: objclean
+- rm -f *.so.1 *.a
++ rm -f *.so.1 *.a x86.pc
+
+-install: libx86.so.1
++x86.pc:
++ sed -e's,@prefix@,/usr,' x86.pc.in > x86.pc
++ sed -e's,@exec_prefix@,/usr,' -i x86.pc
++ sed -e's,@libdir@,${LIBDIR},' -i x86.pc
++ sed -e's,@includedir@,${INCLUDEDIR},' -i x86.pc
++ sed -e's,@PACKAGE_VERSION@,1.1,' -i x86.pc
++
++install: libx86.so.1 x86.pc
+ install -D libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so.1
+ install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
++ install -D x86.pc $(DESTDIR)$(LIBDIR)/pkgconfig/x86.pc
+ ln -sf libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so
+- install -p -m 0644 -D lrmi.h $(DESTDIR)/usr/include/libx86.h
++ install -p -m 0644 -D lrmi.h $(DESTDIR)$(INCLUDEDIR)/libx86.h
+diff --git a/x86.pc.in b/x86.pc.in
+new file mode 100644
+index 0000000..711d90d
+--- /dev/null
++++ b/x86.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: x86
++Description: Library providing x86 emulator access
++Version: @PACKAGE_VERSION@
++Cflags: -I${includedir}
++Libs: -L${libdir} -lx86
+--
+1.5.4.1
+
diff --git a/testing/libx86/libx86-mmap-offset.patch b/testing/libx86/libx86-mmap-offset.patch
new file mode 100644
index 000000000..881bc6615
--- /dev/null
+++ b/testing/libx86/libx86-mmap-offset.patch
@@ -0,0 +1,187 @@
+diff -ur libx86-1.1/lrmi.c libx86-1.1.hack/lrmi.c
+--- libx86-1.1/lrmi.c 2006-10-30 15:10:16.000000000 -0500
++++ libx86-1.1.hack/lrmi.c 2009-10-26 15:55:42.000000000 -0400
+@@ -136,7 +136,7 @@
+ if (context.ready)
+ return 1;
+
+- if (!LRMI_common_init())
++ if (!LRMI_common_init(0))
+ return 0;
+
+ /*
+diff -ur libx86-1.1/thunk.c libx86-1.1.hack/thunk.c
+--- libx86-1.1/thunk.c 2008-04-02 20:48:00.000000000 -0400
++++ libx86-1.1.hack/thunk.c 2009-10-26 16:05:39.000000000 -0400
+@@ -139,11 +139,11 @@
+ int i;
+ X86EMU_intrFuncs intFuncs[256];
+
+- if (!LRMI_common_init())
++ mmap_addr = LRMI_common_init(1);
++
++ if (!mmap_addr)
+ return 0;
+
+- mmap_addr = 0;
+-
+ X86EMU_pioFuncs pioFuncs = {
+ (&x_inb),
+ (&x_inw),
+@@ -169,10 +169,10 @@
+ X86_ESP = 0xFFF9;
+ memset (stack, 0, 64*1024);
+
+- *((char *)0) = 0x4f; /* Make sure that we end up jumping back to a
+- halt instruction */
++ *mmap_addr = 0x4f; /* Make sure that we end up jumping back to a
++ halt instruction */
+
+- M.mem_base = 0;
++ M.mem_base = (unsigned long)mmap_addr;
+ M.mem_size = 1024*1024;
+
+ return 1;
+diff -ur libx86-1.1/x86-common.c libx86-1.1.hack/x86-common.c
+--- libx86-1.1/x86-common.c 2008-05-16 12:56:23.000000000 -0400
++++ libx86-1.1.hack/x86-common.c 2009-10-26 16:03:21.000000000 -0400
+@@ -45,14 +45,15 @@
+ static struct {
+ int ready;
+ int count;
++ void *offset;
+ struct mem_block blocks[REAL_MEM_BLOCKS];
+ } mem_info = { 0 };
+
+ static int
+-real_mem_init(void)
++real_mem_init(int high_page)
+ {
+ void *m;
+- int fd_zero;
++ int fd_zero, flags = MAP_SHARED;
+
+ if (mem_info.ready)
+ return 1;
+@@ -63,9 +64,12 @@
+ return 0;
+ }
+
++ if (!high_page)
++ flags |= MAP_FIXED;
++
+ m = mmap((void *)REAL_MEM_BASE, REAL_MEM_SIZE,
+- PROT_READ | PROT_WRITE | PROT_EXEC,
+- MAP_FIXED | MAP_SHARED, fd_zero, 0);
++ PROT_READ | PROT_WRITE | PROT_EXEC,
++ flags, fd_zero, 0);
+
+ if (m == (void *)-1) {
+ perror("mmap /dev/zero");
+@@ -76,6 +80,7 @@
+ close(fd_zero);
+
+ mem_info.ready = 1;
++ mem_info.offset = m;
+ mem_info.count = 1;
+ mem_info.blocks[0].size = REAL_MEM_SIZE;
+ mem_info.blocks[0].free = 1;
+@@ -87,7 +92,7 @@
+ real_mem_deinit(void)
+ {
+ if (mem_info.ready) {
+- munmap((void *)REAL_MEM_BASE, REAL_MEM_SIZE);
++ munmap(mem_info.offset, REAL_MEM_SIZE);
+ mem_info.ready = 0;
+ }
+ }
+@@ -119,7 +124,7 @@
+ LRMI_alloc_real(int size)
+ {
+ int i;
+- char *r = (char *)REAL_MEM_BASE;
++ char *r = (char *)mem_info.offset;
+
+ if (!mem_info.ready)
+ return NULL;
+@@ -151,7 +156,7 @@
+ LRMI_free_real(void *m)
+ {
+ int i;
+- char *r = (char *)REAL_MEM_BASE;
++ char *r = (char *)mem_info.offset;
+
+ if (!mem_info.ready)
+ return;
+@@ -200,13 +205,15 @@
+ return *(unsigned short *)(i * 4);
+ }
+
+-int LRMI_common_init(void)
++void *LRMI_common_init(int high_page)
+ {
+- void *m;
++ void *m, *offset;
+ int fd_mem;
+
+- if (!real_mem_init())
+- return 0;
++ if (!real_mem_init(high_page))
++ return NULL;
++
++ offset = mem_info.offset - REAL_MEM_BASE;
+
+ /*
+ Map the Interrupt Vectors (0x0 - 0x400) + BIOS data (0x400 - 0x502)
+@@ -217,33 +224,33 @@
+ if (fd_mem == -1) {
+ real_mem_deinit();
+ perror("open /dev/mem");
+- return 0;
++ return NULL;
+ }
+
+- m = mmap((void *)0, 0x502,
+- PROT_READ | PROT_WRITE | PROT_EXEC,
+- MAP_FIXED | MAP_SHARED, fd_mem, 0);
++ m = mmap(offset, 0x502,
++ PROT_READ | PROT_WRITE | PROT_EXEC,
++ MAP_FIXED | MAP_SHARED, fd_mem, 0);
+
+ if (m == (void *)-1) {
+ close(fd_mem);
+ real_mem_deinit();
+ perror("mmap /dev/mem");
+- return 0;
++ return NULL;
+ }
+
+- m = mmap((void *)0xa0000, 0x100000 - 0xa0000,
++ m = mmap(offset+0xa0000, 0x100000 - 0xa0000,
+ PROT_READ | PROT_WRITE | PROT_EXEC,
+ MAP_FIXED | MAP_SHARED, fd_mem, 0xa0000);
+
+ if (m == (void *)-1) {
+- munmap((void *)0, 0x502);
++ munmap(offset, 0x502);
+ close(fd_mem);
+ real_mem_deinit();
+ perror("mmap /dev/mem");
+- return 0;
++ return NULL;
+ }
+
+ close(fd_mem);
+
+- return 1;
++ return offset;
+ }
+diff -ur libx86-1.1/x86-common.h libx86-1.1.hack/x86-common.h
+--- libx86-1.1/x86-common.h 2006-09-07 18:44:27.000000000 -0400
++++ libx86-1.1.hack/x86-common.h 2009-10-26 16:01:19.000000000 -0400
+@@ -40,4 +40,4 @@
+
+ void *LRMI_alloc_real(int size);
+ void LRMI_free_real(void *m);
+-int LRMI_common_init(void);
++void *LRMI_common_init(int high_page);