summaryrefslogtreecommitdiffstats
path: root/testing/lwm
diff options
context:
space:
mode:
authorMichael Zhou <zhoumichaely@gmail.com>2011-08-06 06:36:00 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-08-08 02:26:04 -0500
commitc4c8a89a2dc51251f531adb4c71d84bfc99a28b5 (patch)
treeda89af07840fea91e5e229a531800dec2e82ae42 /testing/lwm
parentd1507046301cc9396fb16a4fd070a155e6a4408d (diff)
downloadaports-c4c8a89a2dc51251f531adb4c71d84bfc99a28b5.tar.bz2
aports-c4c8a89a2dc51251f531adb4c71d84bfc99a28b5.tar.xz
testing/lwm: new port
Diffstat (limited to 'testing/lwm')
-rw-r--r--testing/lwm/APKBUILD42
-rw-r--r--testing/lwm/no_xmkmf_makefile.patch11
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/lwm/APKBUILD b/testing/lwm/APKBUILD
new file mode 100644
index 000000000..0746ebef1
--- /dev/null
+++ b/testing/lwm/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Michael Zhou <zhoumichaely@gmail.com>
+# Maintainer:
+pkgname=lwm
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Lightweight Window Manager that tries to keep out of your face"
+url="http://www.jfc.org.uk/software/lwm.html"
+arch="x86 x86_64"
+license="GPL"
+depends=""
+makedepends="libx11-dev libsm-dev"
+install=""
+subpackages=""
+source="
+ http://www.jfc.org.uk/files/$pkgname/$pkgname-$pkgver.tar.gz
+ no_xmkmf_makefile.patch
+"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -f no_xmkmf_makefile || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin
+ install lwm "$pkgdir"/usr/bin
+}
+
+md5sums="1748722a293e03d632b615275ef84498 lwm-1.2.2.tar.gz
+cbfa8518daed50927fe4cc8ae5d2e550 no_xmkmf_makefile.patch"
diff --git a/testing/lwm/no_xmkmf_makefile.patch b/testing/lwm/no_xmkmf_makefile.patch
new file mode 100644
index 000000000..6b7ff60f0
--- /dev/null
+++ b/testing/lwm/no_xmkmf_makefile.patch
@@ -0,0 +1,11 @@
+--- a/no_xmkmf_makefile
++++ b/no_xmkmf_makefile
+@@ -24,7 +24,7 @@
+ #DEFINES = -D_POSIX_C_SOURCE=2
+
+ # Add any strange libraries your system needs here.
+-LDFLAGS = -lXext -lX11 -lICE -lSM
++LDFLAGS = -lX11 -lICE -lSM
+
+ # -----------------------------------------------------------------------------
+