summaryrefslogtreecommitdiffstats
path: root/testing/minidlna/makefile.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-19 20:21:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-19 20:21:31 +0000
commit4ab6246313f2d357aa6aafe30b0711ad9e26e56c (patch)
treecb7a750b32c98194cf9e7ab9ea1b17cd7de403fe /testing/minidlna/makefile.patch
parent044801b10f02ef9a8419a68820fea7b5ed60d7ab (diff)
downloadaports-4ab6246313f2d357aa6aafe30b0711ad9e26e56c.tar.bz2
aports-4ab6246313f2d357aa6aafe30b0711ad9e26e56c.tar.xz
testing/minidlna: update to 1.0.25 and misc fixes
- create minidlna user - fix initd script - ship default config
Diffstat (limited to 'testing/minidlna/makefile.patch')
-rw-r--r--testing/minidlna/makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/minidlna/makefile.patch b/testing/minidlna/makefile.patch
new file mode 100644
index 000000000..a3be83f82
--- /dev/null
+++ b/testing/minidlna/makefile.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+index 86e03a3..17871ea 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,13 +12,17 @@
+ #
+ #CFLAGS = -Wall -O -D_GNU_SOURCE -g -DDEBUG
+ #CFLAGS = -Wall -g -Os -D_GNU_SOURCE
+-CFLAGS = -Wall -g -O3 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
+- -I/usr/include/ffmpeg \
+- -I/usr/include/libavutil -I/usr/include/libavcodec -I/usr/include/libavformat \
+- -I/usr/include/ffmpeg/libavutil -I/usr/include/ffmpeg/libavcodec -I/usr/include/ffmpeg/libavformat
++
++libavutil_cflags := $(shell pkg-config --cflags libavutil)
++libavformat_cflags := $(shell pkg-config --cflags libavformat)
++libavfilter_cflags := $(shell pkg-config --cflags libavfilter)
++
++CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -I. \
++ $(libavutil_cflags) $(libavfilter_cflags) $(libavformat_clfags)
++
+ #STATIC_LINKING: CFLAGS += -DSTATIC
+ #STATIC_LINKING: LDFLAGS = -static
+-CC = gcc
++CC ?= gcc
+ RM = rm -f
+ INSTALL = install
+