summaryrefslogtreecommitdiffstats
path: root/testing/nodejs
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-15 14:48:59 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-15 14:48:59 -0500
commit6793d228d302d048d6872e52360886ed1722408c (patch)
tree20ed7829fe66d6af9d1ee8fd3e5f459b722857f6 /testing/nodejs
parent29c2454c60a1bb2e5cc858a836963d27fbf28430 (diff)
downloadaports-6793d228d302d048d6872e52360886ed1722408c.tar.bz2
aports-6793d228d302d048d6872e52360886ed1722408c.tar.xz
testing/nodejs: new aport, orphaned (no personal interest in this package)
Diffstat (limited to 'testing/nodejs')
-rw-r--r--testing/nodejs/APKBUILD48
-rw-r--r--testing/nodejs/nodejs-multiplicity.patch10
-rw-r--r--testing/nodejs/nodejs-uclibc.patch20
3 files changed, 78 insertions, 0 deletions
diff --git a/testing/nodejs/APKBUILD b/testing/nodejs/APKBUILD
new file mode 100644
index 000000000..e0d76551e
--- /dev/null
+++ b/testing/nodejs/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=nodejs
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="event-oriented javascript framework and execution environment"
+url="http://nodejs.org/"
+
+# v8 is not portable so we have to list archs by hand
+arch="x86 x86_64 arm"
+
+license="MIT BSD Apache-2"
+depends=
+depends_dev=
+makedepends="$depends_dev python libev-dev c-ares-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://nodejs.org/dist/node-v${pkgver}.tar.gz
+ nodejs-uclibc.patch
+ nodejs-multiplicity.patch"
+
+_builddir="${srcdir}/node-v${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --shared-cares \
+ --shared-libev
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9e9e791e125f6a601ebc663dc99c72a8 node-v0.4.2.tar.gz
+b5d7568f58bb9a14d5b9a971e89560c6 nodejs-uclibc.patch
+912d504d56fb194b4ceda8f693f6e200 nodejs-multiplicity.patch"
diff --git a/testing/nodejs/nodejs-multiplicity.patch b/testing/nodejs/nodejs-multiplicity.patch
new file mode 100644
index 000000000..87479690d
--- /dev/null
+++ b/testing/nodejs/nodejs-multiplicity.patch
@@ -0,0 +1,10 @@
+--- node-v0.4.2.orig/wscript
++++ node-v0.4.2/wscript
+@@ -436,7 +436,6 @@
+ # LFS
+ conf.env.append_value('CPPFLAGS', '-D_LARGEFILE_SOURCE')
+ conf.env.append_value('CPPFLAGS', '-D_FILE_OFFSET_BITS=64')
+- conf.env.append_value('CPPFLAGS', '-DEV_MULTIPLICITY=0')
+
+ # Makes select on windows support more than 64 FDs
+ if sys.platform.startswith("win32"):
diff --git a/testing/nodejs/nodejs-uclibc.patch b/testing/nodejs/nodejs-uclibc.patch
new file mode 100644
index 000000000..68fadff06
--- /dev/null
+++ b/testing/nodejs/nodejs-uclibc.patch
@@ -0,0 +1,20 @@
+--- node-v0.4.2.orig/deps/v8/src/platform-linux.cc
++++ node-v0.4.2/deps/v8/src/platform-linux.cc
+@@ -46,7 +46,7 @@
+ #include <sys/stat.h> // open
+ #include <fcntl.h> // open
+ #include <unistd.h> // sysconf
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h> // backtrace, backtrace_symbols
+ #endif // def __GLIBC__
+ #include <strings.h> // index
+@@ -447,7 +447,7 @@
+
+ int OS::StackWalk(Vector<OS::StackFrame> frames) {
+ // backtrace is a glibc extension.
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ int frames_size = frames.length();
+ ScopedVector<void*> addresses(frames_size);
+