summaryrefslogtreecommitdiffstats
path: root/testing/openvcp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-02-25 09:24:08 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-02-25 09:50:43 +0000
commit3dbdb56642145c75704b371a6e2db3e35afda36e (patch)
tree153b146e361e69483d17d559bd5ba17b572dcda2 /testing/openvcp
parentba872ec497b16da98cf0238649acdd2aa6dff74d (diff)
downloadaports-3dbdb56642145c75704b371a6e2db3e35afda36e.tar.bz2
aports-3dbdb56642145c75704b371a6e2db3e35afda36e.tar.xz
testing/openvcp: depends, APKBUILD style fixes
Diffstat (limited to 'testing/openvcp')
-rw-r--r--testing/openvcp/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/openvcp/APKBUILD b/testing/openvcp/APKBUILD
index f72c2637c..bee3a90c3 100644
--- a/testing/openvcp/APKBUILD
+++ b/testing/openvcp/APKBUILD
@@ -9,14 +9,16 @@ pkgdesc="Control Panel for VServer instances"
url="http://www.openvcp.org"
arch="all"
license="GPL"
-depends="rsync"
-depends_dev="gnutls-dev util-vserver-dev libxml2-dev libpcap-dev sqlite-dev"
-makedepends="$depends_dev"
-install=""
-subpackages=""
+depends=
+depends_dev=
+makedepends="gnutls-dev util-vserver-dev libxml2-dev libpcap-dev libtool sqlite-dev"
+install=
+subpackages=
source="http://files.openvcp.org/$_pkgname-$_pkgver.tar.gz
$pkgname.initd"
+
_builddir="$srcdir"/$_pkgname-$_pkgver
+
prepare() {
local i
cd "$_builddir"
@@ -26,6 +28,7 @@ prepare() {
esac
done
}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -33,6 +36,7 @@ build() {
--with-gnutls
make || return 1
}
+
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
@@ -40,4 +44,4 @@ package() {
}
md5sums="9c65d706133ea48553c90236997f1b8b openvcpd-0.5rc3.tar.gz
-08cef22e3abc5824133733e17aa4e607 openvcp.initd"
+db8efb9c086673fd2e3e2532294c7a2f openvcp.initd"