summaryrefslogtreecommitdiffstats
path: root/testing/perl-data-section
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-10-29 10:42:56 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-10-29 10:42:56 +0000
commit9b5918bdba19b36f3600271fa0fc299939b77445 (patch)
tree693149bf491a6208765cf32c6564307ce4a94927 /testing/perl-data-section
parent5bb659f9bdaa9b8a6c7b1546d0ed8d58a402bb7f (diff)
downloadaports-9b5918bdba19b36f3600271fa0fc299939b77445.tar.bz2
aports-9b5918bdba19b36f3600271fa0fc299939b77445.tar.xz
testing/perl-data-section: new aport
Diffstat (limited to 'testing/perl-data-section')
-rw-r--r--testing/perl-data-section/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-data-section/APKBUILD b/testing/perl-data-section/APKBUILD
new file mode 100644
index 000000000..a907d2ec3
--- /dev/null
+++ b/testing/perl-data-section/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-data-section
+_pkgreal=Data-Section
+pkgver=0.101621
+pkgrel=0
+pkgdesc="read multiple hunks of data out of your DATA section"
+url="http://search.cpan.org/dist/Data-Section/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-mro-compat perl-sub-exporter"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="573fd1a74356b13116118d86084a4693 Data-Section-0.101621.tar.gz"