summaryrefslogtreecommitdiffstats
path: root/testing/perl-libapreq2
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-01-02 08:28:52 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-01-02 08:28:52 +0000
commit330a49e1c7a5b4cf3014a546d92594280f0626c2 (patch)
tree1c1b3282e5cd8e2be55ab8c7dc0b3d3db805108d /testing/perl-libapreq2
parenteb275884ad7ab102a4014d6d45d1a7eac646bbba (diff)
downloadaports-330a49e1c7a5b4cf3014a546d92594280f0626c2.tar.bz2
aports-330a49e1c7a5b4cf3014a546d92594280f0626c2.tar.xz
testing/perl-algorithm-diff: new apkbuild
Diffstat (limited to 'testing/perl-libapreq2')
-rw-r--r--testing/perl-libapreq2/APKBUILD54
-rw-r--r--testing/perl-libapreq2/perl-libapreq2.conf1
-rwxr-xr-xtesting/perl-libapreq2/perl-libapreq2.post-install9
3 files changed, 64 insertions, 0 deletions
diff --git a/testing/perl-libapreq2/APKBUILD b/testing/perl-libapreq2/APKBUILD
new file mode 100644
index 000000000..4b5853c54
--- /dev/null
+++ b/testing/perl-libapreq2/APKBUILD
@@ -0,0 +1,54 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-libapreq2
+_pkgreal=libapreq2
+pkgver=2.13
+pkgrel=0
+pkgdesc="Perl module for libapreq2"
+url="http://search.cpan.org/dist/libapreq2/"
+arch="all"
+license="APACHE"
+cpandepends="perl-extutils-xsbuilder perl-test-simple"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev apache2-dev apache2-mod-perl-dev libtool automake autoconf $cpanmakedepends"
+install="$pkgname.post-install"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/I/IS/ISAAC/$_pkgreal-$pkgver.tar.gz
+ $pkgname.conf"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ ./configure --with-apache2-apxs=/usr/sbin/apxs
+# PERL_MM_USE_DEFAULT=1 perl Makefile.PL || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 ../../$pkgname.conf "$pkgdir"/etc/apache2/conf.d/mod-perl-apreq2.conf || return 1
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/apache2/*.la
+
+}
+
+doc() {
+ arch="noarch"
+ # doc files
+ _docs="LICENSE README"
+ for _doc in $_docs; do
+ install -Dm644 "$_builddir"/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ done
+}
+
+md5sums="c11fb0861aa84dcc6cd0f0798b045eee libapreq2-2.13.tar.gz
+90288cabd74c73d76be4e7a27a620f9b perl-libapreq2.conf"
diff --git a/testing/perl-libapreq2/perl-libapreq2.conf b/testing/perl-libapreq2/perl-libapreq2.conf
new file mode 100644
index 000000000..884799d1a
--- /dev/null
+++ b/testing/perl-libapreq2/perl-libapreq2.conf
@@ -0,0 +1 @@
+LoadModule apreq_module /usr/lib/apache2/mod_apreq2.so
diff --git a/testing/perl-libapreq2/perl-libapreq2.post-install b/testing/perl-libapreq2/perl-libapreq2.post-install
new file mode 100755
index 000000000..301c33c5e
--- /dev/null
+++ b/testing/perl-libapreq2/perl-libapreq2.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+echo "*" >&2
+echo "* To finish installing apache2-mod-perl-apreq2:" >&2
+echo "* 1) See if you need to modify the apache2 config:" >&2
+echo "* /etc/apache2/conf.d/mod-perl-apreq2.conf" >&2
+echo "* 2) Restart apache2 when done." >&2
+echo "*" >&2
+