summaryrefslogtreecommitdiffstats
path: root/testing/perl-net-netmask
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-03 13:11:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-03 20:16:58 +0000
commit6d7126c865ec4fb1cdefacaaf4dca4c634d36a67 (patch)
treeb39fb60271008cf7d15237873d439c074263a6aa /testing/perl-net-netmask
parentbdd18a1500063566f95979e619bc9ba250605109 (diff)
downloadaports-6d7126c865ec4fb1cdefacaaf4dca4c634d36a67.tar.bz2
aports-6d7126c865ec4fb1cdefacaaf4dca4c634d36a67.tar.xz
Initial APKBUILD for perl-net-netmask
Package description: Perl module for manipulation and lookup of IP network blocks
Diffstat (limited to 'testing/perl-net-netmask')
-rw-r--r--testing/perl-net-netmask/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/perl-net-netmask/APKBUILD b/testing/perl-net-netmask/APKBUILD
new file mode 100644
index 000000000..ca9479438
--- /dev/null
+++ b/testing/perl-net-netmask/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-net-netmask
+_realname=Net-Netmask
+pkgver=1.9016
+pkgrel=0
+pkgdesc="Perl extension to parse, manipulate, and lookup IP network blocks"
+url="http://search.cpan.org/~muir/Net-Netmask-1.9016/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="174606b568f8545b8968aecf50ba7a37 Net-Netmask-1.9016.tar.gz"