summaryrefslogtreecommitdiffstats
path: root/testing/perl-radiusperl
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-08-30 12:06:22 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-08-30 12:06:22 +0000
commitbe9cfdd9ddec3fc483581b10922f7b0decd61ead (patch)
tree09a547d1f3ff0c502dc53d643fc0fceedbb6d9b5 /testing/perl-radiusperl
parentf8e5bb62a5ce94b1da68e5184c2bba13c4fb8271 (diff)
downloadaports-be9cfdd9ddec3fc483581b10922f7b0decd61ead.tar.bz2
aports-be9cfdd9ddec3fc483581b10922f7b0decd61ead.tar.xz
testing/arping perl-data-hexdump perl-sys-syslog: new aports
main/rp-pppoe: leave ip_forward untouched
Diffstat (limited to 'testing/perl-radiusperl')
-rw-r--r--testing/perl-radiusperl/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-radiusperl/APKBUILD b/testing/perl-radiusperl/APKBUILD
new file mode 100644
index 000000000..5c7d9a150
--- /dev/null
+++ b/testing/perl-radiusperl/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-radiusperl
+_pkgreal=RadiusPerl
+_modulename=Authen-Radius
+pkgver=0.20
+pkgrel=0
+pkgdesc="Perl module for RadiusPerl"
+url="http://search.cpan.org/dist/RadiusPerl/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-data-hexdump"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MA/MANOWAR/$_pkgreal-$pkgver.tar.gz"
+_builddir="$srcdir/$_modulename-$pkgver"
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+build() {
+ cd "$_builddir"
+ # I don't make test because this packages need a radius server installed
+ make
+}
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+md5sums="acd0f83204117e47bacc0105868266b1 RadiusPerl-0.20.tar.gz"