summaryrefslogtreecommitdiffstats
path: root/testing/perl-test-simple
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-08 22:06:04 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit4c200e98f68b4c857d9a29ebf9ea7416505b6d51 (patch)
tree9b400a2cb642f146b2c36b510804c601fde940f2 /testing/perl-test-simple
parentdcbe753d5198c72ad5d4ac92cd9aacc57334160c (diff)
downloadaports-4c200e98f68b4c857d9a29ebf9ea7416505b6d51.tar.bz2
aports-4c200e98f68b4c857d9a29ebf9ea7416505b6d51.tar.xz
Inital APKBUILD for perl-test-simple
Diffstat (limited to 'testing/perl-test-simple')
-rw-r--r--testing/perl-test-simple/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/perl-test-simple/APKBUILD b/testing/perl-test-simple/APKBUILD
new file mode 100644
index 000000000..8122e47de
--- /dev/null
+++ b/testing/perl-test-simple/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-test-simple
+_realname=Test-Simple
+pkgver=0.98
+pkgrel=0
+pkgdesc="Perl modules for writing tests"
+url="http://search.cpan.org/~mschwern/Test-Simple-0.98/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/$_realname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="a8b26c97440269b33dd79fd847c521d8 Test-Simple-0.98.tar.gz"